aboutsummaryrefslogtreecommitdiff
path: root/audio/last.fm/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-08-03 19:12:16 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-08-03 19:12:16 +0000
commitab8fa281522ac35f0e3ec665551bd754e8a966b7 (patch)
tree9d769a058546c78a6cf377459048dc1f6d6c06af /audio/last.fm/Makefile
parent8a34c2856c1f45232f56181a9f4f7e31183893e9 (diff)
downloadports-ab8fa281522ac35f0e3ec665551bd754e8a966b7.tar.gz
ports-ab8fa281522ac35f0e3ec665551bd754e8a966b7.zip
Notes
Diffstat (limited to 'audio/last.fm/Makefile')
-rw-r--r--audio/last.fm/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index c4a0ebb23f0a..f1b503a46326 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -33,10 +33,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GCC=4.2+
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|bash|sh|g' -e 's|qmake|${QMAKE}|g' \
+ -E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
+ ${WRKSRC}/configure
+
post-build:
cd ${WRKSRC}/src/output/RtAudio && \
- ${QMAKE} -spec freebsd-g++ "QMAKE_CXX=${CXX}" "QMAKE_LINK=${CXX}" \
- "QMAKE_LINK_SHLIB=${CXX}" && make
+ ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} && make
${REINPLACE_CMD} -e 's|`dirname $$0`|${DATADIR}|g' \
${WRKSRC}/bin/last.fm