aboutsummaryrefslogtreecommitdiff
path: root/audio/last.fm
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2009-11-04 23:02:14 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2009-11-04 23:02:14 +0000
commit7b842ae8edb2f7be973402c09e1f583303373b5b (patch)
tree4feabc6becbe950ed838186b55814fc0ca6d266f /audio/last.fm
parentb64c7a77295364ecfe600891fe6a276ae13a404f (diff)
downloadports-7b842ae8edb2f7be973402c09e1f583303373b5b.tar.gz
ports-7b842ae8edb2f7be973402c09e1f583303373b5b.zip
Notes
Diffstat (limited to 'audio/last.fm')
-rw-r--r--audio/last.fm/Makefile22
-rw-r--r--audio/last.fm/distinfo6
-rw-r--r--audio/last.fm/files/last.fm13
-rw-r--r--audio/last.fm/files/patch-src-AudioController.cpp12
-rw-r--r--audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp10
-rw-r--r--audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp13
-rw-r--r--audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h4
-rw-r--r--audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp11
-rw-r--r--audio/last.fm/pkg-descr2
-rw-r--r--audio/last.fm/pkg-plist39
10 files changed, 72 insertions, 60 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index 0d6a84432f9c..2760f1772f47 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -6,15 +6,20 @@
#
PORTNAME= last.fm
-PORTVERSION= 1.3.2.14
-PORTREVISION= 2
+PORTVERSION= 1.4.2.58240
CATEGORIES= audio net
MASTER_SITES= http://cdn.last.fm/client/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arved@FreeBSD.org
COMMENT= Official last.fm radio player
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= gpod.5:${PORTSDIR}/audio/libgpod \
+ mad.2:${PORTSDIR}/audio/libmad \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ fftw3f.5:${PORTSDIR}/math/fftw3-float
+
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
@@ -23,6 +28,7 @@ USE_QT_VER= 4
QT_COMPONENTS= gui imageformats_run moc_build network qmake_build rcc_build \
sql uic_build xml
HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -33,20 +39,26 @@ USE_GCC=4.2+
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|bash|sh|g' -e 's|qmake|${QMAKE}|g' \
+ ${REINPLACE_CMD} -e 's|/bin/bash|/${LOCALBASE}/bin/bash|g' \
-E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
-e 's|function header|header()|g' \
-e 's|function middle|middle()|g' \
-e 's|-pthread|-pthread -R/usr/local/share/last.fm|g' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|linux\*|unix|g' ${WRKSRC}/src/src.pro
+ ${REINPLACE_CMD} -e 's|/usr/include/gpod|${LOCALBASE}/include/gpod|; \
+ s|/usr/include/glib|${LOCALBASE}/include/glib|;s|linux|freebsd|' \
+ ${WRKSRC}/src/mediadevices/ipod/ipod.pro
+ ${REINPLACE_CMD} -e 's|^RUNDIR.*|RUNDIR=${DATADIR}|' ${WRKSRC}/bin/last.fm.sh
+ ${RM} ${WRKSRC}/bin/libmad.1.dylib ${WRKSRC}/bin/libmad.dylib \
+ ${WRKSRC}/bin/last.fm.sh.bak
post-build:
cd ${WRKSRC}/src/output/RtAudio && \
${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} && make
do-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/last.fm ${PREFIX}/bin/last.fm
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/last.fm.sh ${PREFIX}/bin/last.fm
${MKDIR} ${PREFIX}/share/applications ${PREFIX}/share/services
${INSTALL_DATA} ${FILESDIR}/last.fm.desktop ${PREFIX}/share/applications
${INSTALL_DATA} ${FILESDIR}/lastfm.protocol ${PREFIX}/share/services
diff --git a/audio/last.fm/distinfo b/audio/last.fm/distinfo
index 3eeee2b8fa2c..4fe9ac952b1e 100644
--- a/audio/last.fm/distinfo
+++ b/audio/last.fm/distinfo
@@ -1,3 +1,3 @@
-MD5 (last.fm-1.3.2.14.src.tar.bz2) = 842608e71c30851c2089c0573be30816
-SHA256 (last.fm-1.3.2.14.src.tar.bz2) = 3c765fb5a8a0d5137f93ba35b8fd59ecc04cfa98d551b8ddd0dd0138d15fc461
-SIZE (last.fm-1.3.2.14.src.tar.bz2) = 1615505
+MD5 (last.fm-1.4.2.58240.src.tar.bz2) = 977d349736c9cd73e4b028c392898467
+SHA256 (last.fm-1.4.2.58240.src.tar.bz2) = 6e66f3408021b3ea512224451599e81bd0fb9ede464575d9acae2cc16d5b6429
+SIZE (last.fm-1.4.2.58240.src.tar.bz2) = 7302117
diff --git a/audio/last.fm/files/last.fm b/audio/last.fm/files/last.fm
deleted file mode 100644
index 56a3560451ec..000000000000
--- a/audio/last.fm/files/last.fm
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-# executes all *nix variants of Last.fm executable --mxcl
-
-RUNDIR=/usr/local/share/last.fm
-LD_LIBRARY_PATH=$RUNDIR; export LD_LIBRARY_PATH
-
-if [ -f $RUNDIR/last.fm.app ]; then
- exec $RUNDIR/last.fm.app $*
-elif [ -f $RUNDIR/last.fm.app_debug ]; then
- exec $RUNDIR/last.fm.app_debug $*
-elif [ -d $RUNDIR/Last.fm.app ]; then
- exec $RUNDIR/Last.fm_debug $*
-fi
diff --git a/audio/last.fm/files/patch-src-AudioController.cpp b/audio/last.fm/files/patch-src-AudioController.cpp
index 29efbebc50a9..fa671556dec2 100644
--- a/audio/last.fm/files/patch-src-AudioController.cpp
+++ b/audio/last.fm/files/patch-src-AudioController.cpp
@@ -1,9 +1,9 @@
---- src/AudioController.cpp.orig Sat Jul 14 09:50:13 2007
-+++ src/AudioController.cpp Sat Jul 14 09:50:28 2007
-@@ -160,13 +160,7 @@
- }
+--- src/AudioController.cpp.orig 2007-12-18 15:18:20.000000000 +0100
++++ src/AudioController.cpp 2009-11-04 19:22:00.000000000 +0100
+@@ -168,13 +168,7 @@
+
m_transcode->setBufferCapacity( kDecodedBufferMinSize );
-
+
- #ifdef WIN32
m_output = qobject_cast<OutputInterface*>( loadPlugin( "rtaudioplayback" ) );
- #elif defined LINUX
@@ -13,4 +13,4 @@
- #endif
if ( m_output == 0 )
- {
+ return false;
diff --git a/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp b/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp
new file mode 100644
index 000000000000..d5d6da6f7f4b
--- /dev/null
+++ b/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp
@@ -0,0 +1,10 @@
+--- src/Helper/mediadevicewatcher.cpp.orig 2009-11-04 22:48:51.000000000 +0100
++++ src/Helper/mediadevicewatcher.cpp 2009-11-04 22:50:13.000000000 +0100
+@@ -73,6 +73,7 @@
+ QString appExe = "Last.fm_debug";
+ #endif
+ #endif
++ QString appExe = "last.fm";
+
+ QString app = QCoreApplication::applicationDirPath() + "/" + appExe;
+ QStringList params( "-tray" );
diff --git a/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp b/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp
new file mode 100644
index 000000000000..59dce4a1dcb0
--- /dev/null
+++ b/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp
@@ -0,0 +1,13 @@
+--- src/mediadevices/itunes/itunesdevice.cpp.orig 2009-11-04 22:07:06.000000000 +0100
++++ src/mediadevices/itunes/itunesdevice.cpp 2009-11-04 22:07:12.000000000 +0100
+@@ -589,8 +589,9 @@
+ //HACK
+ #ifdef WIN32
+ QDir qcd = m_path;
+- #endif
+ QSettings().setValue( "devicePaths/" + uid + "/path", qcd.absolutePath() );
++ #endif
++
+ //HACK
+ }
+ else
diff --git a/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h b/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
index bf6952d5b72e..a9d30beadad3 100644
--- a/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
+++ b/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
@@ -1,5 +1,5 @@
---- src/LastFMHelper/controlinterface.h.orig 2007-09-24 23:41:54.000000000 +0200
-+++ src/LastFMHelper/controlinterface.h 2007-09-24 23:42:01.000000000 +0200
+--- src/Helper/controlinterface.h.orig 2007-09-24 23:41:54.000000000 +0200
++++ src/Helper/controlinterface.h 2007-09-24 23:42:01.000000000 +0200
@@ -24,6 +24,7 @@
#include <QObject>
diff --git a/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp b/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
deleted file mode 100644
index 4f9fe9e64aed..000000000000
--- a/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mp3transcode/mp3transcode.cpp.orig 2007-09-27 17:37:07.000000000 +0300
-+++ src/mp3transcode/mp3transcode.cpp 2008-09-08 01:43:36.000000000 +0300
-@@ -281,7 +281,7 @@
- {
- int length;
- int cnt;
-- length = qMin( numBytes, ssize_t( getDecodedBufferFilled() ) );
-+ length = qMin( numBytes, getDecodedBufferFilled() );
-
- while (length > 0)
- {
diff --git a/audio/last.fm/pkg-descr b/audio/last.fm/pkg-descr
index 5cf7ae7359e8..14343914bc79 100644
--- a/audio/last.fm/pkg-descr
+++ b/audio/last.fm/pkg-descr
@@ -1,4 +1,4 @@
The official last.fm radio player application. Integrates with Konqueror and
(Linux-)Firefox.
-WWW: http://www.last.fm
+WWW: http://www.last.fm/
diff --git a/audio/last.fm/pkg-plist b/audio/last.fm/pkg-plist
index 073b7699bfb0..15d10a7c818a 100644
--- a/audio/last.fm/pkg-plist
+++ b/audio/last.fm/pkg-plist
@@ -1,5 +1,5 @@
bin/last.fm
-%%DATADIR%%/LastFMHelper
+%%DATADIR%%/LastFmHelper
%%DATADIR%%/data/about.png
%%DATADIR%%/data/about_generic.png
%%DATADIR%%/data/about_mac.png
@@ -13,19 +13,9 @@ bin/last.fm
%%DATADIR%%/data/buttons/action_upload.png
%%DATADIR%%/data/buttons/action_upload_down.png
%%DATADIR%%/data/buttons/action_upload_hover.png
-%%DATADIR%%/data/buttons/addToMyPlaylist.png
-%%DATADIR%%/data/buttons/ban.png
%%DATADIR%%/data/buttons/closebutton.png
-%%DATADIR%%/data/buttons/love.png
%%DATADIR%%/data/buttons/myprofile.png
-%%DATADIR%%/data/buttons/play.png
-%%DATADIR%%/data/buttons/recommend.png
%%DATADIR%%/data/buttons/scrobble.png
-%%DATADIR%%/data/buttons/skip.png
-%%DATADIR%%/data/buttons/skip_active.png
-%%DATADIR%%/data/buttons/stop.png
-%%DATADIR%%/data/buttons/stop_active.png
-%%DATADIR%%/data/buttons/tag.png
%%DATADIR%%/data/icons/as.ico
%%DATADIR%%/data/icons/as.png
%%DATADIR%%/data/icons/blackprofile24.png
@@ -39,7 +29,6 @@ bin/last.fm
%%DATADIR%%/data/icons/icon_tag.png
%%DATADIR%%/data/icons/icon_track.png
%%DATADIR%%/data/icons/icon_user.png
-%%DATADIR%%/data/icons/lastfm.icns
%%DATADIR%%/data/icons/loved_radio.png
%%DATADIR%%/data/icons/my_bookmarks.png
%%DATADIR%%/data/icons/my_friends.png
@@ -97,24 +86,36 @@ bin/last.fm
%%DATADIR%%/data/wizard.png
%%DATADIR%%/data/wizard_generic.png
%%DATADIR%%/data/wizard_mac.png
+%%DATADIR%%/glib-2.0.lib
+%%DATADIR%%/gpod.lib
%%DATADIR%%/last.fm
-%%DATADIR%%/last.fm.app
-%%DATADIR%%/libLastFmTools.so
-%%DATADIR%%/libLastFmTools.so.1
-%%DATADIR%%/libLastFmTools.so.1.0
+%%DATADIR%%/last.fm.sh
+%%DATADIR%%/libLastFmFingerprint.so.1.0.0
+%%DATADIR%%/libLastFmFingerprint.so.1.0
+%%DATADIR%%/libLastFmFingerprint.so.1
+%%DATADIR%%/libLastFmFingerprint.so
%%DATADIR%%/libLastFmTools.so.1.0.0
+%%DATADIR%%/libLastFmTools.so.1.0
+%%DATADIR%%/libLastFmTools.so.1
+%%DATADIR%%/libLastFmTools.so
+%%DATADIR%%/libMoose.so.1.0.0
+%%DATADIR%%/libMoose.so.1.0
+%%DATADIR%%/libMoose.so.1
+%%DATADIR%%/libMoose.so
+%%DATADIR%%/libfftw3f-3.lib
+%%DATADIR%%/services/libsrv_Ipod_device.so
%%DATADIR%%/services/libsrv_httpinput.so
%%DATADIR%%/services/libsrv_itunesdevice.so
-%%DATADIR%%/services/libsrv_mp3transcode.so
+%%DATADIR%%/services/libsrv_madtranscode.so
%%DATADIR%%/services/libsrv_rtaudioplayback.so
+%%DATADIR%%/updater-autorestart.sh
+%%DATADIR%%/zlibwapi.lib
share/applications/last.fm.desktop
share/services/lastfm.protocol
@dirrmtry share/services
@dirrmtry share/applications
@dirrm %%DATADIR%%/services
-@dirrm %%DATADIR%%/extensions
@dirrm %%DATADIR%%/data/icons
-@dirrm %%DATADIR%%/data/i18n
@dirrm %%DATADIR%%/data/buttons
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%