aboutsummaryrefslogtreecommitdiff
path: root/audio/last.fm
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-09-24 21:52:13 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-09-24 21:52:13 +0000
commitbd8aa8f138edd27e35c5c9ac031038feaa67bb44 (patch)
tree8da30da56b9910ff12ea5a2e9c1e9445fbf7786c /audio/last.fm
parent07d2f4962545118ccd06ae945b6cc3470992378d (diff)
downloadports-bd8aa8f138edd27e35c5c9ac031038feaa67bb44.tar.gz
ports-bd8aa8f138edd27e35c5c9ac031038feaa67bb44.zip
Notes
Diffstat (limited to 'audio/last.fm')
-rw-r--r--audio/last.fm/Makefile1
-rw-r--r--audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h10
2 files changed, 10 insertions, 1 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index 4f509aac4e7f..7b7ac8526959 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -30,7 +30,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= Does not compile
USE_GCC=4.2+
.endif
diff --git a/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h b/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
new file mode 100644
index 000000000000..bf6952d5b72e
--- /dev/null
+++ b/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
@@ -0,0 +1,10 @@
+--- src/LastFMHelper/controlinterface.h.orig 2007-09-24 23:41:54.000000000 +0200
++++ src/LastFMHelper/controlinterface.h 2007-09-24 23:42:01.000000000 +0200
+@@ -24,6 +24,7 @@
+
+ #include <QObject>
+ #include <QMutex>
++#include <QCoreApplication>
+
+ class ControlInterface : public QObject
+ {