aboutsummaryrefslogtreecommitdiff
path: root/audio/lastfm-desktop/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/lastfm-desktop/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'audio/lastfm-desktop/Makefile')
-rw-r--r--audio/lastfm-desktop/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/lastfm-desktop/Makefile b/audio/lastfm-desktop/Makefile
index 2e6e4d9bdaa6..0a1101b28943 100644
--- a/audio/lastfm-desktop/Makefile
+++ b/audio/lastfm-desktop/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= liblastfm.so:audio/liblastfm \
USE_GITHUB= yes
GH_ACCOUNT= lastfm
-USES= gettext pkgconfig qmake gmake
-USE_QT4= corelib dbus gui linguist_build moc_build network phonon \
+USES= gettext pkgconfig qmake gmake qt:4
+USE_QT= corelib dbus gui linguist_build moc_build network phonon \
rcc_build sql uic_build webkit xml
SUB_FILES= lastfm-desktop.sh
@@ -37,7 +37,8 @@ OPTIONS_SINGLE= PHONON
OPTIONS_SINGLE_PHONON= GSTREAMER VLC
OPTIONS_DEFAULT= VLC
GSTREAMER_DESC= Multimedia via Phonon-GStreamer
-GSTREAMER_USE= QT4=phonon-gst_run
+GSTREAMER_USES= qt:4
+GSTREAMER_USE= QT=phonon-gst_run
VLC_DESC= Multimedia via Phonon-VLC
VLC_RUN_DEPENDS= phonon-vlc-qt4>=0.6.1:multimedia/phonon-vlc@qt4