aboutsummaryrefslogtreecommitdiff
path: root/audio/libaiff/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-03 15:37:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-03 15:37:46 +0000
commit0a02e66c582e4e2854cc82d709775876fd6768ed (patch)
tree9885c33c6207ee3dfdd10a384abc507869158b0e /audio/libaiff/Makefile
parent54684b0574937dd1e372de565b79eb0d0be934f0 (diff)
downloadports-0a02e66c582e4e2854cc82d709775876fd6768ed.tar.gz
ports-0a02e66c582e4e2854cc82d709775876fd6768ed.zip
Notes
Diffstat (limited to 'audio/libaiff/Makefile')
-rw-r--r--audio/libaiff/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/audio/libaiff/Makefile b/audio/libaiff/Makefile
index 3e5bdb6c7bec..e4aa76bacd60 100644
--- a/audio/libaiff/Makefile
+++ b/audio/libaiff/Makefile
@@ -6,20 +6,27 @@
#
PORTNAME= libaiff
-PORTVERSION= 3.0
+PORTVERSION= 5.0
CATEGORIES= audio
MASTER_SITES= SF/aifftools
+DISTNAME= libaiff-5.0-release
MAINTAINER= miwi@FreeBSD.org
COMMENT= Read and write AIFF files
GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= lib/${PORTNAME}.a include/${PORTNAME}/config.h include/${PORTNAME}/endian.h \
- include/${PORTNAME}/${PORTNAME}.h
+ include/${PORTNAME}/${PORTNAME}.h include/${PORTNAME}/config.vc.h
PLIST_DIRS= include/${PORTNAME}
post-patch:
- @${REINPLACE_CMD} -e 's/install: libaiff.a/install:/' ${WRKSRC}/${MAKEFILE}.in
+ @${REINPLACE_CMD} -e 's/install: libaiff.a/install:/' \
+ ${WRKSRC}/${MAKEFILE}.in
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
.include <bsd.port.mk>