aboutsummaryrefslogtreecommitdiff
path: root/audio/libamrwb/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
commit08b574207595f41bec773a876c9b3586b11878ae (patch)
treee242ef80f9b5948d4d177e61cff39aafb95af347 /audio/libamrwb/files
parentbd248d23564c3bf784600de05100437f0b5ceca0 (diff)
Notes
Diffstat (limited to 'audio/libamrwb/files')
-rw-r--r--audio/libamrwb/files/patch-Makefile.in24
-rw-r--r--audio/libamrwb/files/patch-configure15
-rw-r--r--audio/libamrwb/files/patch-prepare_sources.sh31
-rw-r--r--audio/libamrwb/files/pkg-message.in17
4 files changed, 87 insertions, 0 deletions
diff --git a/audio/libamrwb/files/patch-Makefile.in b/audio/libamrwb/files/patch-Makefile.in
new file mode 100644
index 000000000000..a768eb212d27
--- /dev/null
+++ b/audio/libamrwb/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig Thu Jun 7 00:32:12 2007
++++ Makefile.in Sun Jul 15 00:58:13 2007
+@@ -224,7 +224,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = amrwb-any-cflags.patch amrwb-dhf-declaration.patch amrwb-intsizes.patch prepare_sources.sh amrwb.spec
+-DISTCLEANFILES = 26204-700.zip 26204-700.doc 26204-700_ANSI-C_source_code.zip
++DISTCLEANFILES = 26204-700.doc 26204-700_ANSI-C_source_code.zip
+ lib_LTLIBRARIES = \
+ libamrwb.la
+
+@@ -807,10 +807,10 @@
+ chmod og-w 26204-700.doc
+
+ 26204-700.zip:
+- $(WGET) -N http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/26204-700.zip
++ test -e 26204-700.zip
+
+ extraclean:
+- rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26204-700.zip $(distdir)/26204-700.doc $(distdir)/26204-700_ANSI-C_source_code.zip
++ rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26204-700.doc $(distdir)/26204-700_ANSI-C_source_code.zip
+
+ # WARNING: These commands use internal automake command and may fail in future version.
+ extradist-gzip: distdir extraclean
diff --git a/audio/libamrwb/files/patch-configure b/audio/libamrwb/files/patch-configure
new file mode 100644
index 000000000000..e0a2568cbea1
--- /dev/null
+++ b/audio/libamrwb/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Fri Jun 22 13:50:03 2007
++++ configure Fri Jun 22 13:50:27 2007
+@@ -20338,12 +20338,6 @@
+ fi
+
+
+-if test x"$WGET" = x -a ! "(" -f "26204-700.zip" -o -f "enc_main.c" ")" ; then
+- { { echo "$as_me:$LINENO: error: You need wget utility to download sources." >&5
+-echo "$as_me: error: You need wget utility to download sources." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+ # Checks for libraries.
+ { echo "$as_me:$LINENO: checking for library containing sqrt" >&5
+ echo $ECHO_N "checking for library containing sqrt... $ECHO_C" >&6; }
diff --git a/audio/libamrwb/files/patch-prepare_sources.sh b/audio/libamrwb/files/patch-prepare_sources.sh
new file mode 100644
index 000000000000..3dc6ae8f030c
--- /dev/null
+++ b/audio/libamrwb/files/patch-prepare_sources.sh
@@ -0,0 +1,31 @@
+--- prepare_sources.sh.orig Thu Jun 7 00:29:29 2007
++++ prepare_sources.sh Sun Jul 15 01:00:53 2007
+@@ -1,10 +1,10 @@
+-#! /bin/bash
++#! /bin/sh
+
+ set -o errexit
+-trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" ERR
++trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" 0
+
+ if [ "$0" = prepare_sources.sh ] ; then
+- cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . fi )"
++ cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . ; fi )"
+ else
+ cd "${0%/*}"
+ fi
+@@ -24,7 +24,7 @@
+ patch <amrwb-any-cflags.patch
+ patch <amrwb-dhf-declaration.patch
+
+-for FILE in {dec,enc}_if.{c,h} ; do
++for FILE in dec_if.[ch] enc_if.[ch] ; do
+ echo "modifying file $FILE"
+ if test $FILE = ${FILE%.h} ; then
+ ENDSTRING="^}"
+@@ -47,3 +47,5 @@
+ mv $FILE.new $FILE
+ rm $FILE.def $FILE.all
+ done
++
++trap 0
diff --git a/audio/libamrwb/files/pkg-message.in b/audio/libamrwb/files/pkg-message.in
new file mode 100644
index 000000000000..eed7dd4140e8
--- /dev/null
+++ b/audio/libamrwb/files/pkg-message.in
@@ -0,0 +1,17 @@
+
+AMR codecs incorporate several patents, held by Ericsson,
+Universite de Sherbrooke (VoiceAge) and Nokia.
+VoiceAge claims to provide patent portfolio for AMR codecs. Depending on law in
+your country, manufacturers and developers may need to get a license.
+Because it is a shared library, you may need a special contract for each one
+application, which links against this library, directly or indirectly.
+
+* 3GPP policy on licensing and 3G Patent Platform:
+ http://www.3gpp.org/faq/faq_2005_2.htm#A3.1
+* Intellectual property in ETSI standards:
+ http://webapp.etsi.org/IPR/home.asp
+* On 3GPP legal issues:
+ http://www.3gpp.org/legal/legal.htm
+* On VoiceAge licensing:
+ http://www.voiceage.com/licensing.php
+