aboutsummaryrefslogtreecommitdiff
path: root/audio/libebur128/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-05-02 15:45:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-05-02 15:45:59 +0000
commit4e74521ff0ee509456093eeb8115ad448555f6eb (patch)
treeca56d5b12129c68710b84184b49ce3d07212b704 /audio/libebur128/Makefile
parent57e1777e91936a84f4ca0ca0ab62fdc9da78cf30 (diff)
downloadports-4e74521ff0ee509456093eeb8115ad448555f6eb.tar.gz
ports-4e74521ff0ee509456093eeb8115ad448555f6eb.zip
Notes
Diffstat (limited to 'audio/libebur128/Makefile')
-rw-r--r--audio/libebur128/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/libebur128/Makefile b/audio/libebur128/Makefile
new file mode 100644
index 000000000000..4f7521217268
--- /dev/null
+++ b/audio/libebur128/Makefile
@@ -0,0 +1,25 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= libebur128
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Implementation of the EBU R128 loudness standard
+
+LICENSE= MIT
+
+LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speex
+
+USES= cmake:outsource pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= jiixyj
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 1214547
+
+PLIST_SUB+= VER1=${PORTVERSION:R:R} \
+ VER3=${PORTVERSION}
+
+.include <bsd.port.mk>