aboutsummaryrefslogtreecommitdiff
path: root/audio/libgme
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-10 05:47:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-10 05:47:48 +0000
commitf822f25ed88dac9d64de3e3a659ababb7478c47f (patch)
treeb9462c30aff1cee6441fa006de3d826d45d0990e /audio/libgme
parentd23b00341960508cda0e618533d0628fe5bc9b98 (diff)
downloadports-f822f25ed88dac9d64de3e3a659ababb7478c47f.tar.gz
ports-f822f25ed88dac9d64de3e3a659ababb7478c47f.zip
Notes
Diffstat (limited to 'audio/libgme')
-rw-r--r--audio/libgme/Makefile23
-rw-r--r--audio/libgme/distinfo3
-rw-r--r--audio/libgme/pkg-descr14
-rw-r--r--audio/libgme/pkg-plist19
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/libgme/Makefile b/audio/libgme/Makefile
new file mode 100644
index 000000000000..ae88f830b09b
--- /dev/null
+++ b/audio/libgme/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libgme
+# Date created: 9 May 2010
+# Whom: Anonymous
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgme
+PORTVERSION= 0.5.5
+CATEGORIES= audio
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PROJECTHOST}-${PORTVERSION}
+EXTRACT_SUFX= .tbz2
+
+MAINTAINER= swell.k@gmail.com
+COMMENT= A collection of video game music emulators
+
+PROJECTHOST= game-music-emu
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/audio/libgme/distinfo b/audio/libgme/distinfo
new file mode 100644
index 000000000000..9d424ade41ec
--- /dev/null
+++ b/audio/libgme/distinfo
@@ -0,0 +1,3 @@
+MD5 (game-music-emu-0.5.5.tbz2) = 94459001a763fb76209a550a03b7949e
+SHA256 (game-music-emu-0.5.5.tbz2) = ecb3586aac9feff2b3141167835f73da0c997efbdd32e559f99477ad01e19089
+SIZE (game-music-emu-0.5.5.tbz2) = 161954
diff --git a/audio/libgme/pkg-descr b/audio/libgme/pkg-descr
new file mode 100644
index 000000000000..0ddbfb24ee36
--- /dev/null
+++ b/audio/libgme/pkg-descr
@@ -0,0 +1,14 @@
+Game_Music_Emu is a collection of video game music file emulators that support
+the following formats and systems:
+
+AY ZX Spectrum/Amstrad CPC
+GBS Nintendo Game Boy
+GYM Sega Genesis/Mega Drive
+HES NEC TurboGrafx-16/PC Engine
+KSS MSX Home Computer/other Z80 systems (doesn't support FM sound)
+NSF/NSFE Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
+SAP Atari systems using POKEY sound chip
+SPC Super Nintendo/Super Famicom
+VGM/VGZ Sega Master System/Mark III, Sega Genesis/Mega Drive,BBC Micro
+
+WWW: http://code.google.com/p/game-music-emu/
diff --git a/audio/libgme/pkg-plist b/audio/libgme/pkg-plist
new file mode 100644
index 000000000000..ce2982823bfd
--- /dev/null
+++ b/audio/libgme/pkg-plist
@@ -0,0 +1,19 @@
+include/gme/Blip_Buffer.h
+include/gme/Classic_Emu.h
+include/gme/Data_Reader.h
+include/gme/Dual_Resampler.h
+include/gme/Effects_Buffer.h
+include/gme/Fir_Resampler.h
+include/gme/Gme_File.h
+include/gme/M3u_Playlist.h
+include/gme/Multi_Buffer.h
+include/gme/Music_Emu.h
+include/gme/blargg_common.h
+include/gme/blargg_config.h
+include/gme/blargg_source.h
+include/gme/gme.h
+include/gme/gme_types.h
+lib/libgme.so
+lib/libgme.so.0
+lib/libgme.so.0.5.3
+@dirrm include/gme