aboutsummaryrefslogtreecommitdiff
path: root/audio/libgpod/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-01-18 14:45:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-01-18 14:45:54 +0000
commita2fe96c6e1f1cb699415e01f227fe430b0c84773 (patch)
tree9679d2a9224a15d0b28bab18dd7b886044274703 /audio/libgpod/Makefile
parent73aa1f565edc95b1c6c2ea63683119304f0ca4eb (diff)
downloadports-a2fe96c6e1f1cb699415e01f227fe430b0c84773.tar.gz
ports-a2fe96c6e1f1cb699415e01f227fe430b0c84773.zip
Notes
Diffstat (limited to 'audio/libgpod/Makefile')
-rw-r--r--audio/libgpod/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
new file mode 100644
index 000000000000..8bdf7c9753dd
--- /dev/null
+++ b/audio/libgpod/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libgpod
+# Date created: Wed Jan 1 00:48:58 EST 2006
+# Whom: Devon Ryan <dpryan@dpryan.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgpod
+PORTVERSION= 0.3.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkpod
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A library for direct access of iPod's contents
+
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-extract:
+ @${REINPLACE_CMD} -e \
+ 's,libdir)/pkgconfig,prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>