aboutsummaryrefslogtreecommitdiff
path: root/audio/libgpod
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-06-09 02:07:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-06-09 02:07:52 +0000
commit94b6ecf0c790bafd5628843fc317e75f8189f01f (patch)
tree09098c7e4da9cc6aad0d6bcf259ed97cd05bcfd4 /audio/libgpod
parent0a51bdd9648c37e062c2371622ad1ae84fd6cdab (diff)
downloadports-94b6ecf0c790bafd5628843fc317e75f8189f01f.tar.gz
ports-94b6ecf0c790bafd5628843fc317e75f8189f01f.zip
Make support for Apple iPhone/iPod Touch (and thus `comms/libimobiledevice'
dependency) optional (but enabled by default). Users of older Apple gadgets can unset it to make their systems slightly less polluted e.g. with GnuTLS, (default SSL implementation throughout the Ports Collection is OpenSSL). Approved by: maintainer (implicit)
Notes
Notes: svn path=/head/; revision=275255
Diffstat (limited to 'audio/libgpod')
-rw-r--r--audio/libgpod/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index 29d81be64257..cde6b4880038 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -29,8 +29,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-hal --with-html-dir="${PREFIX}/share/doc"
-OPTIONS= PYTHON "Enable Python bindings" off \
- MONO "Enable Mono bindings" off
+OPTIONS= IMOBILE "Support Apple iPhone/iPod Touch" on \
+ PYTHON "Enable Python bindings" off \
+ MONO "Enable Mono bindings" off
PORTDOCS= ChangeLog NEWS README*
@@ -59,7 +60,8 @@ PLIST_SUB+= MONO="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 800107 && ${OSVERSION} < 900000 || ${OSVERSION} > 900002
+.if defined(WITH_IMOBILE) && (${OSVERSION} > 900002 || \
+ ${OSVERSION} < 900000 && ${OSVERSION} > 800107)
LIB_DEPENDS+= imobiledevice.1:${PORTSDIR}/comms/libimobiledevice
CONFIGURE_ENV+= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
.else