aboutsummaryrefslogtreecommitdiff
path: root/audio/libgpod
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-06-16 12:37:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-06-16 12:37:11 +0000
commit8e886397bc3b46600b30976145299dc03c220bee (patch)
tree04a8684269cde43922c4a1a62aca374bb8e9909a /audio/libgpod
parent422b6e5c91ded060fdc2b5eb8818b378812f8534 (diff)
downloadports-8e886397bc3b46600b30976145299dc03c220bee.tar.gz
ports-8e886397bc3b46600b30976145299dc03c220bee.zip
Notes
Diffstat (limited to 'audio/libgpod')
-rw-r--r--audio/libgpod/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index e2250d4ed48d..3a71231e3574 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -22,10 +22,23 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-post-extract:
- @${REINPLACE_CMD} -e \
+.include <bsd.port.pre.mk>
+
+post-extract: .SILENT
+ ${REINPLACE_CMD} -e \
's,libdir)/pkgconfig,prefix)/libdata/pkgconfig,' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '25s,^,#include <sys/types.h>,' \
+ ${WRKSRC}/src/db-parse-context.c
+.if defined(GCCVERSION)
+. if ${GCCVERSION} < 030000
+ ${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h
+. endif
+.else
+. if ${OSVERSION} < 500035
+ ${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h
+. endif
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>