aboutsummaryrefslogtreecommitdiff
path: root/audio/liblo
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-22 15:55:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-22 15:55:30 +0000
commita26ec5f1f08376fdaf9e940349c125e5ea0440ec (patch)
tree2d567a76d98cc906c2d2570312ff1e60ccfed4ac /audio/liblo
parentf916b896249016c024f59f42e51d8147e94f6ef6 (diff)
downloadports-a26ec5f1f08376fdaf9e940349c125e5ea0440ec.tar.gz
ports-a26ec5f1f08376fdaf9e940349c125e5ea0440ec.zip
Notes
Diffstat (limited to 'audio/liblo')
-rw-r--r--audio/liblo/Makefile36
-rw-r--r--audio/liblo/distinfo5
-rw-r--r--audio/liblo/files/patch-src_lo__types__internal.h18
-rw-r--r--audio/liblo/files/patch-src_message.c13
-rw-r--r--audio/liblo/pkg-descr9
-rw-r--r--audio/liblo/pkg-plist13
6 files changed, 37 insertions, 57 deletions
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index f5cb9794cafd..e48f8d716f05 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -2,24 +2,26 @@
# $FreeBSD$
PORTNAME= liblo
-PORTVERSION= 0.28
-PORTREVISION= 3
+PORTVERSION= 0.30
CATEGORIES= audio
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Lightweight Open Sound Control implementation
LICENSE= LGPL21
+USES= gmake libtool pathfix
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix
USE_LDCONFIG= yes
PORTDOCS= *
-PORTEXAMPLES= example_client example_server \
- example_tcp_echo_server nonblocking_server_example
+PORTEXAMPLES= example_client \
+ example_server \
+ example_tcp_echo_server \
+ nonblocking_server_example
OPTIONS_DEFINE= DOXYGEN DOCS EXAMPLES
OPTIONS_SUB= yes
@@ -30,21 +32,19 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
post-patch:
.if ${ARCH} == i386 || ${ARCH} == powerpc
- @${REINPLACE_CMD} -e 's,deadbeef,, ; s,f00baa23,,' \
- ${WRKSRC}/lo/lo_macros.h
+ @${REINPLACE_CMD} -e 's|deadbeef||; s|f00baa23||' ${WRKSRC}/lo/lo_macros.h
.endif
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in AUTHORS ChangeLog NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} \
- ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog NEWS README TODO ${STAGEDIR}${DOCSDIR}
+
post-install-DOXYGEN-on:
- (cd ${WRKSRC}/doc/man/man3 && ${INSTALL_MAN} l*.3 p*.3 \
- ${STAGEDIR}${PREFIX}/share/man/man3/)
- (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+ cd ${WRKSRC}/doc/man/man3 && ${INSTALL_MAN} l*.3 p*.3 ${STAGEDIR}${PREFIX}/share/man/man3/
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_SCRIPT} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/audio/liblo/distinfo b/audio/liblo/distinfo
index 46ce84048a70..eca4f34fc762 100644
--- a/audio/liblo/distinfo
+++ b/audio/liblo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (liblo-0.28.tar.gz) = da94a9b67b93625354dd89ff7fe31e5297fc9400b6eaf7378c82ee1caf7db909
-SIZE (liblo-0.28.tar.gz) = 591659
+TIMESTAMP = 1582354950
+SHA256 (liblo-0.30.tar.gz) = 30a7c9de49a25ed7f2425a7a7415f5b14739def62431423d3419ea26fb978d1b
+SIZE (liblo-0.30.tar.gz) = 641498
diff --git a/audio/liblo/files/patch-src_lo__types__internal.h b/audio/liblo/files/patch-src_lo__types__internal.h
deleted file mode 100644
index 7ddcfa966359..000000000000
--- a/audio/liblo/files/patch-src_lo__types__internal.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/lo_types_internal.h.orig 2013-07-25 10:14:32 UTC
-+++ src/lo_types_internal.h
-@@ -20,6 +20,7 @@
- #else
- #define closesocket close
- #include <netdb.h>
-+#include <netinet/in.h>
- #include <arpa/inet.h>
- #endif
-
-@@ -33,6 +34,7 @@ typedef __int32 int32_t;
-
- #ifdef ENABLE_THREADS
- #include <pthread.h>
-+#include <sys/socket.h>
- #endif
-
- #include "lo/lo_osc_types.h"
diff --git a/audio/liblo/files/patch-src_message.c b/audio/liblo/files/patch-src_message.c
deleted file mode 100644
index 1d72a7025726..000000000000
--- a/audio/liblo/files/patch-src_message.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/message.c.orig 2014-01-20 11:49:42 UTC
-+++ src/message.c
-@@ -996,8 +996,8 @@ void lo_message_pp(lo_message m)
- putchar('\n');
- if (d != end) {
- fprintf(stderr,
-- "liblo warning: type and data do not match (off by %d) in message %p\n",
-- abs((char *) d - (char *) end), m);
-+ "liblo warning: type and data do not match (off by %td) in message %p\n",
-+ d >= end ? (char *) d - (char *) end : (char *) end - (char *) d, m);
- }
- }
-
diff --git a/audio/liblo/pkg-descr b/audio/liblo/pkg-descr
index 8b20259ab206..92be3ca642b3 100644
--- a/audio/liblo/pkg-descr
+++ b/audio/liblo/pkg-descr
@@ -1,8 +1,7 @@
liblo is a lightweight library that provides an easy to use implementation of
-the Open Sound Control protocol for POSIX systems. For more information about
-the Open Sound Control protocol, please see:
-
- - http://www.cnmat.berkeley.edu/OpenSoundControl/
- - http://www.opensoundcontrol.org/
+the OSC protocol. For more information about the OSC protocol, please see:
+- http://www.cnmat.berkeley.edu/OpenSoundControl/
+- http://www.opensoundcontrol.org/
WWW: http://liblo.sourceforge.net/
+WWW: https://github.com/radarsat1/liblo
diff --git a/audio/liblo/pkg-plist b/audio/liblo/pkg-plist
index 5debce5b6627..68c1a4c607b7 100644
--- a/audio/liblo/pkg-plist
+++ b/audio/liblo/pkg-plist
@@ -1,5 +1,6 @@
bin/oscdump
bin/oscsend
+bin/oscsendfile
include/lo/lo.h
include/lo/lo_cpp.h
include/lo/lo_endian.h
@@ -12,12 +13,22 @@ include/lo/lo_throw.h
include/lo/lo_types.h
lib/liblo.so
lib/liblo.so.7
-lib/liblo.so.7.2.0
+lib/liblo.so.7.4.0
libdata/pkgconfig/liblo.pc
%%DOXYGEN%%share/man/man3/liblo.3.gz
+%%DOXYGEN%%share/man/man3/liblocpp.3.gz
%%DOXYGEN%%share/man/man3/liblolowlevel.3.gz
%%DOXYGEN%%share/man/man3/lo.h.3.gz
+%%DOXYGEN%%share/man/man3/lo_Address.3.gz
+%%DOXYGEN%%share/man/man3/lo_Blob.3.gz
+%%DOXYGEN%%share/man/man3/lo_Bundle.3.gz
+%%DOXYGEN%%share/man/man3/lo_Message.3.gz
+%%DOXYGEN%%share/man/man3/lo_Method.3.gz
+%%DOXYGEN%%share/man/man3/lo_PathMsg.3.gz
+%%DOXYGEN%%share/man/man3/lo_Server.3.gz
+%%DOXYGEN%%share/man/man3/lo_ServerThread.3.gz
%%DOXYGEN%%share/man/man3/lo_arg.3.gz
+%%DOXYGEN%%share/man/man3/lo_cpp.h.3.gz
%%DOXYGEN%%share/man/man3/lo_lowlevel.h.3.gz
%%DOXYGEN%%share/man/man3/lo_osc_types.h.3.gz
%%DOXYGEN%%share/man/man3/lo_serverthread.h.3.gz