aboutsummaryrefslogtreecommitdiff
path: root/audio/libmad
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 00:50:00 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 00:50:00 +0000
commit2e0d331d7ac90c127cb522cc9d64f1181c455229 (patch)
tree8f94493710a456c9db09cf7bb9ca5d162b1bd2c3 /audio/libmad
parent396b9657ea07e84f1486bf1111614e69c626f83d (diff)
downloadports-2e0d331d7ac90c127cb522cc9d64f1181c455229.tar.gz
ports-2e0d331d7ac90c127cb522cc9d64f1181c455229.zip
Notes
Diffstat (limited to 'audio/libmad')
-rw-r--r--audio/libmad/Makefile24
-rw-r--r--audio/libmad/distinfo1
-rw-r--r--audio/libmad/files/patch-configure10
-rw-r--r--audio/libmad/pkg-descr20
-rw-r--r--audio/libmad/pkg-plist4
5 files changed, 59 insertions, 0 deletions
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
new file mode 100644
index 000000000000..77fe00fa5a73
--- /dev/null
+++ b/audio/libmad/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libmad
+# Date created: 26 November 2003
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmad
+PORTVERSION= 0.15.0b
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://ftp.mars.org/pub/mpeg/
+MASTER_SITE_SUBDIR= mad
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Libmad library (part of MAD project)
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --disable-debugging \
+ --enable-sso \
+ --enable-accuracy
+
+.include <bsd.port.mk>
diff --git a/audio/libmad/distinfo b/audio/libmad/distinfo
new file mode 100644
index 000000000000..081f5ec8c55c
--- /dev/null
+++ b/audio/libmad/distinfo
@@ -0,0 +1 @@
+MD5 (libmad-0.15.0b.tar.gz) = 2e4487cdf922a6da2546bad74f643205
diff --git a/audio/libmad/files/patch-configure b/audio/libmad/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/audio/libmad/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/libmad/pkg-descr b/audio/libmad/pkg-descr
new file mode 100644
index 000000000000..3bb6fa27f919
--- /dev/null
+++ b/audio/libmad/pkg-descr
@@ -0,0 +1,20 @@
+MAD is a high-quality MPEG audio decoder. It currently supports MPEG-1
+as well as the MPEG-2 extension to Lower Sampling Frequencies. All
+three audio layers (Layer I, Layer II, and Layer III a.k.a. MP3) are
+fully implemented.
+
+MAD does not yet support MPEG-2 multichannel audio (although it should
+be backward compatible with such streams) or AAC, nor does it support
+the so-called MPEG 2.5 format.
+
+MAD has the following special features:
+
+ - 24-bit PCM output
+ - 100% fixed-point (integer) computation
+ - completely new implementation based on the ISO/IEC standards
+ - distributed under the terms of the GNU General Public License (GPL)
+
+The software is distributed as a library (libmad) and command-line
+front-end (madplay).
+
+WWW: http://mad.sourceforge.net/
diff --git a/audio/libmad/pkg-plist b/audio/libmad/pkg-plist
new file mode 100644
index 000000000000..62140005a69f
--- /dev/null
+++ b/audio/libmad/pkg-plist
@@ -0,0 +1,4 @@
+include/mad.h
+lib/libmad.a
+lib/libmad.so
+lib/libmad.so.2