aboutsummaryrefslogtreecommitdiff
path: root/audio/libmp3splt/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2011-03-18 16:25:50 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2011-03-18 16:25:50 +0000
commitc25aad5d6484b439b9bf6790677cf1345cebeba7 (patch)
treeb8def83d80e64cf7734aa8b9ad1ffcfe0428a731 /audio/libmp3splt/Makefile
parent335307a83ad62ae24b86f246e6f062953ab2ceb5 (diff)
Notes
Diffstat (limited to 'audio/libmp3splt/Makefile')
-rw-r--r--audio/libmp3splt/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/audio/libmp3splt/Makefile b/audio/libmp3splt/Makefile
index 5ff448f50795..91716f2f9ee6 100644
--- a/audio/libmp3splt/Makefile
+++ b/audio/libmp3splt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libmp3splt
-PORTVERSION= 0.6
+PORTVERSION= 0.6.1a
CATEGORIES= audio
MASTER_SITES= SF/mp3splt/${PORTNAME}/${PORTVERSION}
@@ -20,6 +20,7 @@ MAKE_JOBS_SAFE= yes
OPTIONS= MP3 "mp3 support" on \
ID3 "id3tag support for the mp3" on \
+ PCRE "pcre support to set tags from input filename" on \
VORBIS "ogg vorbis support" on \
NLS "native language support" on
@@ -44,6 +45,12 @@ PLIST_FILES+= lib/libmp3splt/libsplt_mp3.a \
lib/libmp3splt/libsplt_mp3.so.0
.endif
+.if defined(WITHOUT_PCRE)
+CONFIGURE_ARGS+= --disable-pcre
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
.if defined(WITHOUT_ID3)
CONFIGURE_ARGS+= --disable-id3tag
.else
@@ -65,7 +72,7 @@ PLIST_FILES+= lib/libmp3splt/libsplt_ogg.a \
CONFIGURE_ARGS+= --disable-nls
.else
USE_GETTEXT= yes
-LANGUAGES= de fr
+LANGUAGES= de_DE es fr_FR
.for language in ${LANGUAGES}
PLIST_FILES+= share/locale/${language}/LC_MESSAGES/libmp3splt.mo
.endfor