aboutsummaryrefslogtreecommitdiff
path: root/audio/libmp3splt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2012-06-19 14:52:48 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2012-06-19 14:52:48 +0000
commitd36b804b071e03498e36082bbc87d510f255c3f1 (patch)
tree71196224bb2c4c00f1c6100542893276b05cd38c /audio/libmp3splt
parent1eaaf2ca6d8825769ad4b3517377cfddd4602325 (diff)
downloadports-d36b804b071e03498e36082bbc87d510f255c3f1.tar.gz
ports-d36b804b071e03498e36082bbc87d510f255c3f1.zip
Notes
Diffstat (limited to 'audio/libmp3splt')
-rw-r--r--audio/libmp3splt/Makefile58
1 files changed, 28 insertions, 30 deletions
diff --git a/audio/libmp3splt/Makefile b/audio/libmp3splt/Makefile
index e61d320865fb..aa03147a4a68 100644
--- a/audio/libmp3splt/Makefile
+++ b/audio/libmp3splt/Makefile
@@ -18,59 +18,55 @@ USE_LDCONFIG= yes
USE_AUTOTOOLS= libltdl
MAKE_JOBS_SAFE= yes
-OPTIONS= MP3 "mp3 support" on \
- ID3 "id3tag support for the mp3" on \
- PCRE "pcre support to set tags from input filename" on \
- VORBIS "ogg vorbis support" on \
- NLS "native language support" on
+OPTIONS_MULTI= plugin
+OPTIONS_MULTI_plugin= MAD VORBIS
+OPTIONS_DEFINE= ID3 PCRE NLS
+
+PCRE_DESC= PCRE support to set tags from input filename
+
+OPTIONS_DEFAULT= MAD VORBIS ID3 PCRE NLS
PLIST_DIRS= include/libmp3splt lib/libmp3splt
PLIST_FILES= include/libmp3splt/mp3splt.h lib/libmp3splt.a \
lib/libmp3splt.la lib/libmp3splt.so lib/libmp3splt.so.0 \
share/aclocal/mp3splt.m4
-.include <bsd.port.pre.mk>
-
-.if defined(WITHOUT_MP3) && defined(WITHOUT_VORBIS)
-IGNORE= select at least one plugin: mp3 or vorbis
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_MP3)
-CONFIGURE_ARGS+= --disable-mp3
-.else
+.if ${PORT_OPTIONS:MMAD}
LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
PLIST_FILES+= lib/libmp3splt/libsplt_mp3.a \
lib/libmp3splt/libsplt_mp3.la \
lib/libmp3splt/libsplt_mp3.so \
lib/libmp3splt/libsplt_mp3.so.0
-.endif
-
-.if defined(WITHOUT_PCRE)
-CONFIGURE_ARGS+= --disable-pcre
-.else
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
-.endif
-
-.if defined(WITHOUT_ID3)
-CONFIGURE_ARGS+= --disable-id3tag
.else
-LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag
+CONFIGURE_ARGS+= --disable-mp3
.endif
-.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --disable-ogg
-.else
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= ogg:${PORTSDIR}/audio/libogg \
vorbis:${PORTSDIR}/audio/libvorbis
PLIST_FILES+= lib/libmp3splt/libsplt_ogg.a \
lib/libmp3splt/libsplt_ogg.la \
lib/libmp3splt/libsplt_ogg.so \
lib/libmp3splt/libsplt_ogg.so.0
+.else
+CONFIGURE_ARGS+= --disable-ogg
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+.if ${PORT_OPTIONS:MPCRE}
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+.else
+CONFIGURE_ARGS+= --disable-pcre
+.endif
+
+.if ${PORT_OPTIONS:MID3}
+LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag
.else
+CONFIGURE_ARGS+= --disable-id3tag
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
LANGUAGES= de_DE cs es fr_FR hr
.for language in ${LANGUAGES}
@@ -78,9 +74,11 @@ PLIST_FILES+= share/locale/${language}/LC_MESSAGES/libmp3splt.mo
.endfor
PLIST_FILES+= "@dirrmtry share/locale/de_DE/LC_MESSAGES"
PLIST_FILES+= "@dirrmtry share/locale/de_DE"
+.else
+CONFIGURE_ARGS+= --disable-nls
.endif
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>