aboutsummaryrefslogtreecommitdiff
path: root/audio/libmpcdec
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2004-11-30 21:03:12 +0000
committerKoop Mast <kwm@FreeBSD.org>2004-11-30 21:03:12 +0000
commit2c17d552a01d7b97346f66f4a7d8f8651a416d4c (patch)
tree95c26573c54d2d4a7973008a287dbf5cc8434377 /audio/libmpcdec
parent5148ea2a0b404088f51a83f1abca62b75bc4d100 (diff)
Notes
Diffstat (limited to 'audio/libmpcdec')
-rw-r--r--audio/libmpcdec/Makefile27
-rw-r--r--audio/libmpcdec/distinfo2
-rw-r--r--audio/libmpcdec/pkg-descr10
-rw-r--r--audio/libmpcdec/pkg-plist10
4 files changed, 49 insertions, 0 deletions
diff --git a/audio/libmpcdec/Makefile b/audio/libmpcdec/Makefile
new file mode 100644
index 000000000000..2f50c611a6c6
--- /dev/null
+++ b/audio/libmpcdec/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libmusepack
+# Date created: 29 November 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmusepack
+PORTVERSION= 1.0.3
+CATEGORIES= audio
+MASTER_SITES= http://www.saunalahti.fi/grimmel/musepack.net/source/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= High quality audio compression format
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= gnometarget
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3\ -fomit-frame-pointer||g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/audio/libmpcdec/distinfo b/audio/libmpcdec/distinfo
new file mode 100644
index 000000000000..edd4c91433cb
--- /dev/null
+++ b/audio/libmpcdec/distinfo
@@ -0,0 +1,2 @@
+MD5 (libmusepack-1.0.3.tar.bz2) = 01a0b1f338244e6a7d95f826c382f70b
+SIZE (libmusepack-1.0.3.tar.bz2) = 226099
diff --git a/audio/libmpcdec/pkg-descr b/audio/libmpcdec/pkg-descr
new file mode 100644
index 000000000000..77d16c9de360
--- /dev/null
+++ b/audio/libmpcdec/pkg-descr
@@ -0,0 +1,10 @@
+Musepack is an audio compression format with a strong emphasis on high quality.
+It's not lossless, but it is designed for transparency, so that you won't be
+able to hear differences between the original wave file and the much smaller
+MPC file.
+
+It is based on the MPEG-1 Layer-2 / MP2 algorithms, but has rapidly developed
+and vastly improved and is now at an advanced stage in which it contains
+heavily optimized and patentless code.
+
+WWW: http://www.musepack.net/
diff --git a/audio/libmpcdec/pkg-plist b/audio/libmpcdec/pkg-plist
new file mode 100644
index 000000000000..444b739bd77e
--- /dev/null
+++ b/audio/libmpcdec/pkg-plist
@@ -0,0 +1,10 @@
+include/musepack/config_types.h
+include/musepack/mpc_dec.h
+include/musepack/mpc_math.h
+include/musepack/requant.h
+include/musepack/stdafx.h
+include/musepack/streaminfo.h
+lib/libmusepack.a
+lib/libmusepack.so
+lib/libmusepack.so.1
+@dirrm include/musepack