aboutsummaryrefslogtreecommitdiff
path: root/audio/libmusicbrainz4/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-05-31 10:30:50 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-05-31 10:30:50 +0000
commit526d39bb84a46ddc2288c008e84e32d662e6f558 (patch)
tree23f49622ac1033b40eecb552e323394aae714da1 /audio/libmusicbrainz4/Makefile
parent0dba116c8cfc2f7043b4a7270ba255cdce45853c (diff)
- The CMake scripts were supposed to use pkg-config to find the libraries, but
they use an obsolete module that doesn't seem to work anymore. As a result, the scripts fall back on the hard-coded paths. I have reworked the scripts so they don't use pkg-config or hard-coded paths and fixed build with custom PREFIX/LOCALBASE [1] - mark MAKE_JOB_SAFE Submitted by: maintainer Reported by: QATty [1]
Notes
Notes: svn path=/head/; revision=234898
Diffstat (limited to 'audio/libmusicbrainz4/Makefile')
-rw-r--r--audio/libmusicbrainz4/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/audio/libmusicbrainz4/Makefile b/audio/libmusicbrainz4/Makefile
index e3da4b1ea641..0821ba484f8f 100644
--- a/audio/libmusicbrainz4/Makefile
+++ b/audio/libmusicbrainz4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmusicbrainz3
PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/ \
http://uk.musicbrainz.org/pub/musicbrainz/ \
@@ -24,10 +24,12 @@ USE_CMAKE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
.include <bsd.port.pre.mk>
pre-configure:
- ${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}\/pkgconfig|libdata\/pkgconfig|' \
- ${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
+ -e '/CppUnit/d' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.post.mk>