aboutsummaryrefslogtreecommitdiff
path: root/audio/libopenmpt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-11 22:27:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-11 22:27:26 +0000
commit5d6cc9df0f8c1d7392106c9a57df9655ad8177cd (patch)
treef66e29db6016421d73c24a659e7e5a6eb30316af /audio/libopenmpt
parentc1db777f7bf0ea87f0e730c02764b1c3eb7b430b (diff)
downloadports-5d6cc9df0f8c1d7392106c9a57df9655ad8177cd.tar.gz
ports-5d6cc9df0f8c1d7392106c9a57df9655ad8177cd.zip
- Use distfile with bundled autotools files
- Provide options for MPG123, OGG, VORBIS, PORTAUDIO, SNDFILE, FLAC - Install manpage - Don't install license twice
Notes
Notes: svn path=/head/; revision=479570
Diffstat (limited to 'audio/libopenmpt')
-rw-r--r--audio/libopenmpt/Makefile37
-rw-r--r--audio/libopenmpt/distinfo6
-rw-r--r--audio/libopenmpt/pkg-plist6
3 files changed, 33 insertions, 16 deletions
diff --git a/audio/libopenmpt/Makefile b/audio/libopenmpt/Makefile
index 3d1a549b75e1..322cbdf234dc 100644
--- a/audio/libopenmpt/Makefile
+++ b/audio/libopenmpt/Makefile
@@ -3,7 +3,10 @@
PORTNAME= libopenmpt
PORTVERSION= 0.3.11
+DISTVERSIONSUFFIX= +release.autotools
+PORTREVISION= 1
CATEGORIES= audio
+MASTER_SITES= https://lib.openmpt.org/files/libopenmpt/src/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module music library based on OpenMPT
@@ -11,19 +14,33 @@ COMMENT= Module music library based on OpenMPT
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GITHUB= yes
-GH_ACCOUNT= OpenMPT
-GH_PROJECT= openmpt
-GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+CONFIGURE_ARGS+= --without-portaudiocpp
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES FLAC MPG123 OGG PORTAUDIO SNDFILE VORBIS
+OPTIONS_DEFAULT=FLAC MPG123 OGG PORTAUDIO SNDFILE VORBIS
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|$$(PREFIX)/share/doc/libopenmpt/examples|${EXAMPLESDIR}|g' \
- ${WRKSRC}/Makefile
+FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
+MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
+OGG_LIB_DEPENDS= libogg.so:audio/libogg
+PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
+SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
+VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
+
+FLAC_CONFIGURE_WITH= flac
+MPG123_CONFIGURE_WITH= mpg123
+OGG_CONFIGURE_WITH= ogg
+PORTAUDIO_CONFIGURE_WITH= portaudio
+SNDFILE_CONFIGURE_WITH= sndfile
+VORBIS_CONFIGURE_WITH= vorbis vorbisfile
+
+post-install-DOCS-on:
+ @${RM} ${STAGEDIR}${DOCSDIR}/LICENSE # do not install twice
+
+post-install-EXAMPLES-on:
+ @${MV} ${STAGEDIR}${DOCSDIR}/examples ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/audio/libopenmpt/distinfo b/audio/libopenmpt/distinfo
index 324af20c2051..48f370b48f7e 100644
--- a/audio/libopenmpt/distinfo
+++ b/audio/libopenmpt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536677968
-SHA256 (OpenMPT-openmpt-0.3.11-libopenmpt-0.3.11_GH0.tar.gz) = 416355f542e2cbfde987e5af3d26c7ee15648c6c457ae19e55fe38dd2f40b942
-SIZE (OpenMPT-openmpt-0.3.11-libopenmpt-0.3.11_GH0.tar.gz) = 12049714
+TIMESTAMP = 1536696218
+SHA256 (libopenmpt-0.3.11+release.autotools.tar.gz) = df1ec44212e9f73b33d5aa4970cf3fb7ce27c9fef88d1d1a8be79271c4c705e6
+SIZE (libopenmpt-0.3.11+release.autotools.tar.gz) = 1412893
diff --git a/audio/libopenmpt/pkg-plist b/audio/libopenmpt/pkg-plist
index bcb9dd917a97..b03cceff7f10 100644
--- a/audio/libopenmpt/pkg-plist
+++ b/audio/libopenmpt/pkg-plist
@@ -10,13 +10,13 @@ include/libopenmpt/libopenmpt_stream_callbacks_file.h
include/libopenmpt/libopenmpt_version.h
lib/libopenmpt.a
lib/libopenmpt.so
-lib/libopenmpt.so.1
+lib/libopenmpt.so.0
+lib/libopenmpt.so.0.1.1
libdata/pkgconfig/libopenmpt.pc
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+man/man1/openmpt123.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_mem.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_pipe.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_probe.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_stdout.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_unsafe.c