aboutsummaryrefslogtreecommitdiff
path: root/audio/libshout2
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-15 20:40:48 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-15 20:40:48 +0000
commitf10ba047c7076d12cd37841898c425f006a8c98f (patch)
tree961c9f91b5a0a429cde63d7a28f317058b7009c5 /audio/libshout2
parent71a7a62ba25d960734d8164a9c0b937ba3eead46 (diff)
downloadports-f10ba047c7076d12cd37841898c425f006a8c98f.tar.gz
ports-f10ba047c7076d12cd37841898c425f006a8c98f.zip
Notes
Diffstat (limited to 'audio/libshout2')
-rw-r--r--audio/libshout2/Makefile37
-rw-r--r--audio/libshout2/distinfo2
-rw-r--r--audio/libshout2/files/patch-aa16
-rw-r--r--audio/libshout2/files/patch-ab11
-rw-r--r--audio/libshout2/files/patch-src::Makefile.in11
-rw-r--r--audio/libshout2/pkg-comment2
-rw-r--r--audio/libshout2/pkg-descr4
-rw-r--r--audio/libshout2/pkg-plist33
8 files changed, 49 insertions, 67 deletions
diff --git a/audio/libshout2/Makefile b/audio/libshout2/Makefile
index 112498c4fdfd..673a9be0d872 100644
--- a/audio/libshout2/Makefile
+++ b/audio/libshout2/Makefile
@@ -5,15 +5,42 @@
# $FreeBSD$
#
-PORTNAME= libshout
-PORTVERSION= 1.0.7
+PORTNAME= libshout2
+PORTVERSION= 20021112
CATEGORIES= audio net
-MASTER_SITES= http://developer.icecast.org/libshout/releases/
+MASTER_SITES= http://tigress.com/lofi/ \
+ http://lofi.dyndns.org/
+DISTNAME= libshout-devel-${PORTVERSION}
-MAINTAINER= zach@pabst.bendnet.com
+MAINTAINER= michaelnottebrock@gmx.net
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.2:${PORTSDIR}/audio/libvorbis
+
+CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/libshout
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|'\
+ ${WRKSRC}/examples/Makefile
+ @${REINPLACE_CMD} -E -e 's|(INCLUDES \=.*)|\1 -I${LOCALBASE}/include|'\
+ ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|-O20|${CFLAGS}|' ${WRKSRC}/examples/Makefile \
+ ${WRKSRC}/include/Makefile \
+ ${WRKSRC}/include/shout/Makefile \
+ ${WRKSRC}/src/avl/Makefile \
+ ${WRKSRC}/src/httpp/Makefile \
+ ${WRKSRC}/src/net/Makefile \
+ ${WRKSRC}/src/timing/Makefile \
+ ${WRKSRC}/src/thread/Makefile \
+ ${WRKSRC}/src/Makefile \
+ ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/audio/libshout2/distinfo b/audio/libshout2/distinfo
index 97be1b6a634d..64838a0e8553 100644
--- a/audio/libshout2/distinfo
+++ b/audio/libshout2/distinfo
@@ -1 +1 @@
-MD5 (libshout-1.0.7.tar.gz) = 7e8054f8c6dbb0bd9179057e2ee465c1
+MD5 (libshout-devel-20021112.tar.gz) = 24678973d24ec6b5ae3fdb213a1d47b1
diff --git a/audio/libshout2/files/patch-aa b/audio/libshout2/files/patch-aa
deleted file mode 100644
index 7787a49dec2f..000000000000
--- a/audio/libshout2/files/patch-aa
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.in.orig Wed Aug 1 17:56:09 2001
-+++ Makefile.in Tue Dec 11 08:50:30 2001
-@@ -507,9 +507,10 @@
-
- install-data-local:
- mkdir -p $(DESTDIR)$(includedir)/shout
-- mkdir -p $(DESTDIR)$(prefix)/doc/$(PACKAGE)-$(VERSION)/example
-- $(INSTALL) -m 0644 $(top_srcdir)/README $(top_srcdir)/AUTHORS $(top_srcdir)/COPYING $(top_srcdir)/CHANGES $(DESTDIR)$(prefix)/doc/$(PACKAGE)-$(VERSION)
-- $(INSTALL) -m 0644 $(top_srcdir)/example/Makefile $(top_srcdir)/example/example.c $(DESTDIR)$(prefix)/doc/$(PACKAGE)-$(VERSION)/example
-+ mkdir -p $(DESTDIR)$(prefix)/share/doc/$(PACKAGE)-$(VERSION)
-+ mkdir -p $(DESTDIR)$(prefix)/share/examples/$(PACKAGE)-$(VERSION)
-+ $(INSTALL) -m 0644 $(top_srcdir)/README $(top_srcdir)/AUTHORS $(top_srcdir)/COPYING $(top_srcdir)/CHANGES $(DESTDIR)$(prefix)/share/doc/$(PACKAGE)-$(VERSION)
-+ $(INSTALL) -m 0644 $(top_srcdir)/example/Makefile $(top_srcdir)/example/example.c $(DESTDIR)$(prefix)/share/examples/$(PACKAGE)-$(VERSION)
- $(INSTALL) -m 0644 $(top_srcdir)/shout.h $(DESTDIR)$(includedir)/shout
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/audio/libshout2/files/patch-ab b/audio/libshout2/files/patch-ab
deleted file mode 100644
index 65112e1f5765..000000000000
--- a/audio/libshout2/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig Tue Dec 11 09:28:01 2001
-+++ doc/Makefile.in Tue Dec 11 09:28:08 2001
-@@ -76,7 +76,7 @@
-
- AUTOMAKE_OPTIONS = foreign
-
--docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
-+docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
-
- doc_DATA = index.html overview.html initialization.html connection.html datastreaming.html metadata.html datastructures.html shout_conn_t.html shout_connect.html shout_disconnect.html shout_sleep.html shout_init_connection.html shout_send_data.html shout_update_metadata.html style.css example.html example_c.html reference.html errorhandling.html shout_strerror.html
-
diff --git a/audio/libshout2/files/patch-src::Makefile.in b/audio/libshout2/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..87eaf57fb0ec
--- /dev/null
+++ b/audio/libshout2/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Jan 15 18:27:50 2003
++++ src/Makefile.in Wed Jan 15 18:29:09 2003
+@@ -106,7 +106,7 @@
+ DEFS = @DEFS@ -I. -I$(srcdir)
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-libshout_la_LDFLAGS =
++libshout_la_LDFLAGS = -version-info 3:0:1
+ libshout_la_DEPENDENCIES = net/libicenet.la timing/libicetiming.la \
+ avl/libiceavl.la httpp/libicehttpp.la thread/libicethread.la
+ libshout_la_OBJECTS = shout.lo util.lo vorbis.lo mp3.lo
diff --git a/audio/libshout2/pkg-comment b/audio/libshout2/pkg-comment
index e5b650179863..905dbe4b2315 100644
--- a/audio/libshout2/pkg-comment
+++ b/audio/libshout2/pkg-comment
@@ -1 +1 @@
-A library providing routines for connecting and transmitting data to the icecast server
+Routines for connecting and transmitting data to the icecast server
diff --git a/audio/libshout2/pkg-descr b/audio/libshout2/pkg-descr
index e25884891692..f758bd5c0a70 100644
--- a/audio/libshout2/pkg-descr
+++ b/audio/libshout2/pkg-descr
@@ -6,5 +6,5 @@ implementation details.
WWW: http://developer.icecast.org/libshout/
-- Zach
-zach@pabst.bendnet.com
+- Michael Nottebrock
+michaelnottebrock@gmx.net
diff --git a/audio/libshout2/pkg-plist b/audio/libshout2/pkg-plist
index 4b771016fcc8..218b21f53545 100644
--- a/audio/libshout2/pkg-plist
+++ b/audio/libshout2/pkg-plist
@@ -1,34 +1,5 @@
include/shout/shout.h
-lib/libshout.so.2
-lib/libshout.so
-lib/libshout.la
lib/libshout.a
-share/doc/libshout-%%PORTVERSION%%/index.html
-share/doc/libshout-%%PORTVERSION%%/overview.html
-share/doc/libshout-%%PORTVERSION%%/initialization.html
-share/doc/libshout-%%PORTVERSION%%/connection.html
-share/doc/libshout-%%PORTVERSION%%/datastreaming.html
-share/doc/libshout-%%PORTVERSION%%/metadata.html
-share/doc/libshout-%%PORTVERSION%%/datastructures.html
-share/doc/libshout-%%PORTVERSION%%/shout_conn_t.html
-share/doc/libshout-%%PORTVERSION%%/shout_connect.html
-share/doc/libshout-%%PORTVERSION%%/shout_disconnect.html
-share/doc/libshout-%%PORTVERSION%%/shout_sleep.html
-share/doc/libshout-%%PORTVERSION%%/shout_init_connection.html
-share/doc/libshout-%%PORTVERSION%%/shout_send_data.html
-share/doc/libshout-%%PORTVERSION%%/shout_update_metadata.html
-share/doc/libshout-%%PORTVERSION%%/style.css
-share/doc/libshout-%%PORTVERSION%%/example.html
-share/doc/libshout-%%PORTVERSION%%/example_c.html
-share/doc/libshout-%%PORTVERSION%%/reference.html
-share/doc/libshout-%%PORTVERSION%%/errorhandling.html
-share/doc/libshout-%%PORTVERSION%%/shout_strerror.html
-share/doc/libshout-%%PORTVERSION%%/README
-share/doc/libshout-%%PORTVERSION%%/AUTHORS
-share/doc/libshout-%%PORTVERSION%%/COPYING
-share/doc/libshout-%%PORTVERSION%%/CHANGES
-share/examples/libshout-%%PORTVERSION%%/Makefile
-share/examples/libshout-%%PORTVERSION%%/example.c
+lib/libshout.so
+lib/libshout.so.3
@dirrm include/shout
-@dirrm share/doc/libshout-%%PORTVERSION%%
-@dirrm share/examples/libshout-%%PORTVERSION%%