aboutsummaryrefslogtreecommitdiff
path: root/audio/libsidplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-05-22 08:03:12 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-05-22 08:03:12 +0000
commit509a7f09381db83e54b3b7d7a963911164e85454 (patch)
tree2970bdfb01460270920e80bddc749c58aea06d6b /audio/libsidplay
parent0e15b5e9476a33e9d32f78ca7266528e5f8482d0 (diff)
downloadports-509a7f09381db83e54b3b7d7a963911164e85454.tar.gz
ports-509a7f09381db83e54b3b7d7a963911164e85454.zip
Diffstat (limited to 'audio/libsidplay')
-rw-r--r--audio/libsidplay/Makefile21
-rw-r--r--audio/libsidplay/distinfo5
-rw-r--r--audio/libsidplay/files/patch-src_pp__.cpp11
-rw-r--r--audio/libsidplay/files/patch-src_samples.cpp29
-rw-r--r--audio/libsidplay/files/patch-src_sidtune.cpp24
-rw-r--r--audio/libsidplay/files/patch-src_smart.h26
6 files changed, 87 insertions, 29 deletions
diff --git a/audio/libsidplay/Makefile b/audio/libsidplay/Makefile
index b5380ae23bd4..99e1f9a46f7f 100644
--- a/audio/libsidplay/Makefile
+++ b/audio/libsidplay/Makefile
@@ -1,11 +1,10 @@
# Created by: Stefan Zehl <sec@42.org>
PORTNAME= libsidplay
-PORTVERSION= 1.36.59
-PORTREVISION= 1
+PORTVERSION= 1.36.60
CATEGORIES= audio emulators
-MASTER_SITES= http://bsd-geek.de/FreeBSD/distfiles/ \
- LOCAL/ehaupt
+MASTER_SITES= DEBIAN
+DISTNAME= ${PORTNAME}_${DISTVERSION}${DISTVERSIONSUFFIX}.orig
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Commodore SID-chip emulator library to play SID music files
@@ -13,16 +12,16 @@ COMMENT= Commodore SID-chip emulator library to play SID music files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf libtool tar:bz2
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= sid_cv_have_ios_binary=yes
+
INSTALL_TARGET= install-strip
-USES= autoreconf libtool tar:tgz
-USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS= --enable-optendian --enable-optfixpoint
-.endif
+CONFIGURE_ARGS_i386= --enable-optendian --enable-optfixpoint
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/libsidplay/distinfo b/audio/libsidplay/distinfo
index fee61a708dcf..b5689aaff392 100644
--- a/audio/libsidplay/distinfo
+++ b/audio/libsidplay/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libsidplay-1.36.59.tgz) = 3da9b38d4eb5bf9e936b9604ba92da0594ef38047d50cf806a8e11c400008024
-SIZE (libsidplay-1.36.59.tgz) = 390097
+TIMESTAMP = 1621634985
+SHA256 (libsidplay_1.36.60.orig.tar.bz2) = 1729beb5b54e7486e0b2b83dc0e02130e753a8dcd6fe03677217dbe358941396
+SIZE (libsidplay_1.36.60.orig.tar.bz2) = 338516
diff --git a/audio/libsidplay/files/patch-src_pp__.cpp b/audio/libsidplay/files/patch-src_pp__.cpp
new file mode 100644
index 000000000000..474e303fc160
--- /dev/null
+++ b/audio/libsidplay/files/patch-src_pp__.cpp
@@ -0,0 +1,11 @@
+--- src/pp_.cpp.orig 2001-12-28 23:10:17 UTC
++++ src/pp_.cpp
+@@ -40,6 +40,8 @@ static udword outputLen;
+ static bool isCompressed;
+ static bool globalError;
+
++using namespace std;
++
+
+ // Move four bytes to Motorola big-endian double-word.
+ static inline void bytesTOudword()
diff --git a/audio/libsidplay/files/patch-src_samples.cpp b/audio/libsidplay/files/patch-src_samples.cpp
index ccc4d2ba4735..24def0b3ceb8 100644
--- a/audio/libsidplay/files/patch-src_samples.cpp
+++ b/audio/libsidplay/files/patch-src_samples.cpp
@@ -6,26 +6,23 @@ samples.cpp:80:2: note: insert an explicit cast to silence this issue
^~~~
static_cast<sbyte>( )
---- src/samples.cpp.orig 2002-05-22 17:38:18 UTC
+--- src/samples.cpp.orig 2021-05-22 05:06:11 UTC
+++ src/samples.cpp
-@@ -77,7 +77,7 @@ sampleChannel ch4, ch5;
+@@ -75,7 +75,7 @@ struct sampleChannel
+ sampleChannel ch4, ch5;
- const sbyte galwayNoiseTab1[16] =
+
+-const sbyte galwayNoiseTab1[16] =
++const ubyte galwayNoiseTab1[16] =
{
-- 0x80,0x91,0xa2,0xb3,0xc4,0xd5,0xe6,0xf7,
-+ (sbyte)0x80,(sbyte)0x91,(sbyte)0xa2,(sbyte)0xb3,(sbyte)0xc4,(sbyte)0xd5,(sbyte)0xe6,(sbyte)0xf7,
+ (sbyte)0x80,(sbyte)0x91,(sbyte)0xa2,(sbyte)0xb3,(sbyte)0xc4,(sbyte)0xd5,(sbyte)0xe6,(sbyte)0xf7,
0x08,0x19,0x2a,0x3b,0x4c,0x5d,0x6e,0x7f
- };
-
-@@ -86,9 +86,9 @@ sbyte galwayNoiseSamTab[16];
+@@ -84,7 +84,7 @@ const sbyte galwayNoiseTab1[16] =
+ ubyte galwayNoiseVolTab[16];
+ sbyte galwayNoiseSamTab[16];
- const sbyte sampleConvertTab[16] =
+-const sbyte sampleConvertTab[16] =
++const ubyte sampleConvertTab[16] =
{
--// 0x81,0x99,0xaa,0xbb,0xcc,0xdd,0xee,0xff,
-+// (sbyte)0x81,(sbyte)0x99,(sbyte)0xaa,(sbyte)0xbb,(sbyte)0xcc,(sbyte)0xdd,(sbyte)0xee,(sbyte)0xff,
+ // (sbyte)0x81,(sbyte)0x99,(sbyte)0xaa,(sbyte)0xbb,(sbyte)0xcc,(sbyte)0xdd,(sbyte)0xee,(sbyte)0xff,
// 0x00,0x11,0x22,0x33,0x44,0x55,0x66,0x7f
-- 0x81,0x90,0xa0,0xb0,0xc0,0xd0,0xe0,0xf0,
-+ (sbyte)0x81,(sbyte)0x90,(sbyte)0xa0,(sbyte)0xb0,(sbyte)0xc0,(sbyte)0xd0,(sbyte)0xe0,(sbyte)0xf0,
- 0x00,0x10,0x20,0x30,0x40,0x50,0x60,0x70
- };
-
diff --git a/audio/libsidplay/files/patch-src_sidtune.cpp b/audio/libsidplay/files/patch-src_sidtune.cpp
new file mode 100644
index 000000000000..d73ed163c216
--- /dev/null
+++ b/audio/libsidplay/files/patch-src_sidtune.cpp
@@ -0,0 +1,24 @@
+--- src/sidtune.cpp.orig 2010-08-20 11:48:14 UTC
++++ src/sidtune.cpp
+@@ -35,7 +35,9 @@ using namespace std;
+ #include "myendian.h"
+ #include "pp.h"
+
++using namespace std;
+
++
+ const char text_songNumberExceed[] = "WARNING: Selected song number was too high";
+ const char text_emptyFile[] = "ERROR: File is empty";
+ const char text_unrecognizedFormat[] = "ERROR: Could not determine file format";
+@@ -307,9 +309,9 @@ udword sidTune::loadFile(const char* fileName, ubyte**
+ }
+ // Open binary input file stream at end of file.
+ #if defined(SID_HAVE_IOS_BIN)
+- ifstream myIn( fileName, ios::in|ios::bin|ios::ate );
++ ifstream myIn( fileName, ios::in|ios::bin );
+ #else
+- ifstream myIn( fileName, ios::in|ios::binary|ios::ate );
++ ifstream myIn( fileName, ios::in|ios::binary );
+ #endif
+ // As a replacement for !is_open(), bad() and the NOT-operator
+ // don't seem to work on all systems.
diff --git a/audio/libsidplay/files/patch-src_smart.h b/audio/libsidplay/files/patch-src_smart.h
new file mode 100644
index 000000000000..316482ac4d3b
--- /dev/null
+++ b/audio/libsidplay/files/patch-src_smart.h
@@ -0,0 +1,26 @@
+--- src/smart.h.orig 2004-07-17 21:43:15 UTC
++++ src/smart.h
+@@ -17,16 +17,16 @@ class smartPtrBase
+ doFree = bufOwner;
+ if ( bufferLen >= 1 )
+ {
+- pBufCurrent = ( bufBegin = buffer );
+- bufEnd = bufBegin + bufferLen;
+- bufLen = bufferLen;
+- status = true;
++ this->pBufCurrent = ( this->bufBegin = buffer );
++ this->bufEnd = this->bufBegin + bufferLen;
++ this->bufLen = bufferLen;
++ this->status = true;
+ }
+ else
+ {
+- pBufCurrent = ( bufBegin = ( bufEnd = 0 ));
+- bufLen = 0;
+- status = false;
++ this->pBufCurrent = ( this->bufBegin = ( this->bufEnd = 0 ));
++ this->bufLen = 0;
++ this->status = false;
+ }
+ }
+