aboutsummaryrefslogtreecommitdiff
path: root/audio/libsndfile/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-09 17:13:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-09 17:13:17 +0000
commit997c82b947955e03f70dbd8084b2164205994ab0 (patch)
treef6185c17918a3a81a812ff34ab0ed3a35d2390f2 /audio/libsndfile/Makefile
parent35d66bdf72eb08c1e8e2224d374352add67ea8cf (diff)
downloadports-997c82b947955e03f70dbd8084b2164205994ab0.tar.gz
ports-997c82b947955e03f70dbd8084b2164205994ab0.zip
Notes
Diffstat (limited to 'audio/libsndfile/Makefile')
-rw-r--r--audio/libsndfile/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 17ba5a42085f..04dedd920506 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libsndfile
-PORTVERSION= 1.0.9
+PORTVERSION= 1.0.10
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/
@@ -16,20 +16,24 @@ COMMENT= Reading and writing files containing sampled sound (like WAV or AIFF)
USE_GCC= 3.3
USE_GNOME= gnomehack gnometarget lthack pkgconfig
+USE_REINPLACE= yes
USE_LIBTOOL_VER= 13
CONFIGURE_ARGS= --enable-justsrc --disable-gcc-pipe
INSTALLS_SHLIB= yes
MAN1= sndfile-convert.1 sndfile-info.1 sndfile-play.1
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/ doc / /g' ${WRKSRC}/Makefile.in
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
- ${TAR} -C ${WRKSRC}/doc --exclude "*Makefile*" -cf - . | \
- ${TAR} -C ${DOCSDIR} --unlink -xf -
+ ${TAR} -C ${WRKSRC}/doc --exclude "*Makefile*" --exclude "*.in" \
+ -cf - . | ${TAR} -C ${DOCSDIR} --unlink -xf -
@${CHOWN} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif