aboutsummaryrefslogtreecommitdiff
path: root/audio/libsndfile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-09-15 16:02:19 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-09-15 16:02:19 +0000
commitfac32e69a7f585d064f50ca31f39d859f238a79d (patch)
tree6732b8d4af3cb848a6efb2dd1e42f07a868fbe46 /audio/libsndfile
parent16fae2b3e3426c079b673fd8a75ac095f5112fc2 (diff)
downloadports-fac32e69a7f585d064f50ca31f39d859f238a79d.tar.gz
ports-fac32e69a7f585d064f50ca31f39d859f238a79d.zip
Notes
Diffstat (limited to 'audio/libsndfile')
-rw-r--r--audio/libsndfile/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index fce92d46f306..63c36479b71a 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-justsrc \
--disable-gcc-pipe \
--disable-sqlite
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-isystem /usr/include -isystem ${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
@@ -29,8 +29,11 @@ OPTIONS= FLAC "Enable flac support" On
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_FLAC) || exists(${LOCALBASE}/lib/libFLAC.a)
+.if !defined(WITHOUT_FLAC)
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+=--enable-flac
+.else
+CONFIGURE_ARGS+=--disable-flac
.endif
post-patch: