aboutsummaryrefslogtreecommitdiff
path: root/audio/lindele
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-19 23:16:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-19 23:16:24 +0000
commitfcb21a7cbb9a0f7061e137c4541be07a721bd536 (patch)
treec04505c529fc134cd13dcee47d09bda4e0a57a85 /audio/lindele
parentf31e29e939a5362dd63d76a8e0bf768e091f5845 (diff)
downloadports-fcb21a7cbb9a0f7061e137c4541be07a721bd536.tar.gz
ports-fcb21a7cbb9a0f7061e137c4541be07a721bd536.zip
Notes
Diffstat (limited to 'audio/lindele')
-rw-r--r--audio/lindele/Makefile17
-rw-r--r--audio/lindele/distinfo4
-rw-r--r--audio/lindele/files/patch-src::gui.c60
-rw-r--r--audio/lindele/files/patch-src::lindele.c19
-rw-r--r--audio/lindele/files/patch-src::main.c13
-rw-r--r--audio/lindele/files/patch-src::playlist.c10
-rw-r--r--audio/lindele/pkg-plist2
7 files changed, 48 insertions, 77 deletions
diff --git a/audio/lindele/Makefile b/audio/lindele/Makefile
index cc5f8f0cd54d..48659cb1f6f6 100644
--- a/audio/lindele/Makefile
+++ b/audio/lindele/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lindele
-PORTVERSION= 0.1.0
-PORTREVISION= 3
+PORTVERSION= 0.1.1
CATEGORIES= audio
MASTER_SITES= http://download.gna.org/${PORTNAME}/
@@ -19,15 +18,17 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
tag:${PORTSDIR}/audio/taglib
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui gstreamerplugins
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|musicbox|musicbox-tag-editor|g' \
+ ${WRKSRC}/src/gui.c \
+ ${WRKSRC}/src/lindele.c
+ @${REINPLACE_CMD} -e 's|@prefix@/share|@datadir@|' \
+ ${WRKSRC}/data/lindele.glade.in
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/lindele/distinfo b/audio/lindele/distinfo
index 5453e49db781..d066bd939936 100644
--- a/audio/lindele/distinfo
+++ b/audio/lindele/distinfo
@@ -1,2 +1,2 @@
-MD5 (lindele-0.1.0.tar.gz) = f86c1b6b846357f6fa5778286a9ab869
-SIZE (lindele-0.1.0.tar.gz) = 168128
+MD5 (lindele-0.1.1.tar.gz) = 6d5387fd607fe0516bcc3ddd84dc4a77
+SIZE (lindele-0.1.1.tar.gz) = 168572
diff --git a/audio/lindele/files/patch-src::gui.c b/audio/lindele/files/patch-src::gui.c
index c28390fa30d6..794d1f856b1d 100644
--- a/audio/lindele/files/patch-src::gui.c
+++ b/audio/lindele/files/patch-src::gui.c
@@ -1,56 +1,10 @@
---- src/gui.c.orig Mon Jul 26 22:14:52 2004
-+++ src/gui.c Tue Jul 27 00:47:21 2004
-@@ -26,6 +26,7 @@
+--- src/gui.c.orig Tue Jan 18 02:32:02 2005
++++ src/gui.c Tue Jan 18 02:32:04 2005
+@@ -303,7 +303,6 @@
- void on_about_activate(GtkMenuItem *menu, Lindele *l)
+ gboolean on_tree_popup_menu (GtkWidget *widget)
{
-+ l->about = do_about();
- gtk_widget_show (GTK_WIDGET(l->about));
+- g_printf("got popup-menu signal\n");
+ popup_context_menu(widget,NULL);
+ return TRUE;
}
-
-@@ -130,14 +131,14 @@
-
- void on_properties_activate (GtkWidget *menu, Lindele *l)
- {
-- if(g_file_test(g_find_program_in_path("musicbox"),G_FILE_TEST_IS_EXECUTABLE))
-+ if(g_file_test(g_find_program_in_path("musicbox-tag-editor"),G_FILE_TEST_IS_EXECUTABLE))
- {
-- g_printf("EXECUTE: %s\n",g_strconcat("musicbox \"",playlist_get_current_filepath(l),"\"",NULL));
-- gnome_execute_shell(NULL,g_strconcat("musicbox \"",playlist_get_current_filepath(l),"\"",NULL));
-+ g_printf("EXECUTE: %s\n",g_strconcat("musicbox-tag-editor \"",playlist_get_current_filepath(l),"\"",NULL));
-+ gnome_execute_shell(NULL,g_strconcat("musicbox-tag-editor \"",playlist_get_current_filepath(l),"\"",NULL));
- }
- else
- {
-- g_printf("musicbox is not installed on your system\n.");
-+ g_printf("musicbox-tag-editor is not installed on your system\n.");
- }
- }
-
-@@ -385,13 +386,15 @@
- {
- GtkTreeViewColumn *column;
- GtkCellRenderer *cellrenderer;
-+ gchar* gladepath;
-
- l->mmkeys = mmkeys_new();
- l->player = init_player();
-- l->about = do_about();
- l->playlist_num = 0;
-+ l->random = FALSE;
-+ l->repeat = FALSE;
-
-- gchar* gladepath = g_strconcat(DATADIR,"/lindele/lindele.glade",NULL);
-+ gladepath = g_strconcat(DATADIR,"/lindele/lindele.glade",NULL);
- //gchar* gladepath = g_strconcat("/home/link/Hacking/lindele/lindele-work/data/lindele.glade",NULL);
-
- l->xml = glade_xml_new (gladepath, NULL, NULL);
-@@ -468,7 +471,7 @@
-
- /* Disable the preferences, since its not implemented. */
- gtk_widget_set_sensitive(GTK_WIDGET(glade_xml_get_widget(l->xml,"m_preferences")),FALSE);
-- if(! g_file_test(g_find_program_in_path("musicbox"),G_FILE_TEST_IS_EXECUTABLE))
-+ if(! g_file_test(g_find_program_in_path("musicbox-tag-editor"),G_FILE_TEST_IS_EXECUTABLE))
- gtk_widget_set_sensitive(GTK_WIDGET(glade_xml_get_widget(l->xml,"m_properties")),FALSE);
-
- update_buttons(l);
diff --git a/audio/lindele/files/patch-src::lindele.c b/audio/lindele/files/patch-src::lindele.c
new file mode 100644
index 000000000000..032bb4f7780a
--- /dev/null
+++ b/audio/lindele/files/patch-src::lindele.c
@@ -0,0 +1,19 @@
+--- src/lindele.c.orig Tue Jan 18 02:30:18 2005
++++ src/lindele.c Tue Jan 18 02:30:28 2005
+@@ -82,6 +82,7 @@
+ const gchar *documenters[] = {NULL};
+ const gchar *translator_credits = NULL;
+ GdkPixbuf *logo_pixbuf = gdk_pixbuf_new_from_file(LINDELE_PNG,NULL);
++ gchar *gladepath;
+
+ object->mmkeys = mmkeys_new();
+ object->player = init_player();
+@@ -90,7 +91,7 @@
+ object->random = FALSE;
+ object->repeat = FALSE;
+
+- gchar* gladepath = g_strconcat(DATADIR,"/lindele/lindele.glade",NULL);
++ gladepath = g_strconcat(DATADIR,"/lindele/lindele.glade",NULL);
+ //gchar* gladepath = g_strconcat("/home/link/Hacking/lindele/lindele-head/data/lindele.glade",NULL);
+
+ object->xml = glade_xml_new (gladepath, NULL, NULL);
diff --git a/audio/lindele/files/patch-src::main.c b/audio/lindele/files/patch-src::main.c
index 088f9783493c..4410b1ec8cb6 100644
--- a/audio/lindele/files/patch-src::main.c
+++ b/audio/lindele/files/patch-src::main.c
@@ -1,19 +1,20 @@
---- src/main.c.orig Mon Jul 26 22:14:22 2004
-+++ src/main.c Mon Jul 26 22:14:39 2004
+--- src/main.c.orig Tue Jan 18 02:24:29 2005
++++ src/main.c Tue Jan 18 02:24:53 2005
@@ -21,6 +21,8 @@
int
main (int argc, char *argv[])
{
-+ Lindele lindele;
++ Lindele *lindele;
+
gst_init(&argc, &argv);
glade_init();
gnome_program_init ("lindele", VERSION,
-@@ -28,7 +30,6 @@
+@@ -28,7 +30,7 @@
argc, argv,
GNOME_PARAM_APP_DATADIR, DATADIR, NULL);
-- Lindele lindele;
- init_lindele(&lindele);
+- Lindele *lindele = lindele_new();
++ lindele = lindele_new();
gtk_main();
+
diff --git a/audio/lindele/files/patch-src::playlist.c b/audio/lindele/files/patch-src::playlist.c
index f395617b58c9..99cc8d20029d 100644
--- a/audio/lindele/files/patch-src::playlist.c
+++ b/audio/lindele/files/patch-src::playlist.c
@@ -1,6 +1,6 @@
---- src/playlist.c.orig Mon Jul 26 22:15:56 2004
-+++ src/playlist.c Mon Jul 26 22:16:13 2004
-@@ -458,10 +458,10 @@
+--- src/playlist.c.orig Tue Jan 18 02:25:55 2005
++++ src/playlist.c Tue Jan 18 02:25:57 2005
+@@ -458,7 +458,6 @@
void
popup_context_menu(GtkWidget *widget, GdkEventButton *event)
{
@@ -8,7 +8,3 @@
GtkWidget *menu,*menuitem;
int button, event_time;
-+ g_printf("entry into popup_context_menu\n");
- menu = gtk_menu_new ();
- g_signal_connect (menu,"deactivate",G_CALLBACK(gtk_widget_destroy),NULL);
-
diff --git a/audio/lindele/pkg-plist b/audio/lindele/pkg-plist
index d774381b7921..2ca7e7d0d98c 100644
--- a/audio/lindele/pkg-plist
+++ b/audio/lindele/pkg-plist
@@ -1,7 +1,6 @@
bin/lindele
share/gnome/applications/lindele.desktop
share/gnome/lindele/lindele.glade
-share/gnome/lindele/lindele.png
share/gnome/lindele/load.png
share/gnome/lindele/next.png
share/gnome/lindele/pause.png
@@ -9,4 +8,5 @@ share/gnome/lindele/play.png
share/gnome/lindele/playing.png
share/gnome/lindele/prev.png
share/gnome/lindele/stop.png
+share/gnome/pixmaps/lindele.png
@dirrm share/gnome/lindele