aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-f10-libogg/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
commit824eda00fccb57b36978b562ecfc6572fa5de766 (patch)
treedddb20be9539275c41e943b4763c0b29ba61151d /audio/linux-f10-libogg/Makefile
parent8217c4dd1dea5cbe146907f97afb3e458208ec77 (diff)
Here are new Linux Fedora 8 infrastructure ports.
The recommended version of FreeBSD to use them is 8-CURRENT. FreeBSD-7.x is not fully compatible with compat.linux.osrelease 2.6.16. Some syscalls cannot be MFCed due to native FreeBSD ABI breakage. Usage (and package building): 1. define compat.linux.osrelease=2.6.16; 2. add following variables to /etc/make.conf: . OVERRIDE_LINUX_BASE_PORT=f8; . OVERRIDE_LINUX_NONBASE_PORTS=f8. Approved by: bsam (me) ;-)
Notes
Notes: svn path=/head/; revision=231438
Diffstat (limited to 'audio/linux-f10-libogg/Makefile')
-rw-r--r--audio/linux-f10-libogg/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/audio/linux-f10-libogg/Makefile b/audio/linux-f10-libogg/Makefile
index 9f33fefbaa61..e8f42ea170f8 100644
--- a/audio/linux-f10-libogg/Makefile
+++ b/audio/linux-f10-libogg/Makefile
@@ -1,23 +1,28 @@
-# New ports collection makefile for: linux-libogg
-# Date created: 25 Nov 2005
-# Whom: jylefort@FreeBSD.org
+# New ports collection makefile for: audio/linux-f8-libogg
+# Date created: 2008-04-03
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= libogg
-DISTVERSION= 1.1.2-2
-PORTREVISION= 3
+PORTVERSION= 1.1.3
CATEGORIES= audio linux
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Ogg bitstream library (Linux version)
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Ogg bitstream library (Linux Fedora 8)
ONLY_FOR_ARCHS= i386 amd64
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 4
+LINUX_DIST_VER= 8
+RPMVERSION= 5.fc8
USE_LDCONFIG= yes
-AUTOMATIC_PLIST=yes
+
+PLIST_FILES= usr/lib/libogg.so.0 usr/lib/libogg.so.0.5.3
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= AUTHORS CHANGES COPYING README
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
.include <bsd.port.mk>