aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-shoutcast
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:02:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:02:41 +0000
commita0a19e5533d374152bfca09c2470c3eb43a2de32 (patch)
tree1739db28d843d98a54ba946513cc17b8b05c2028 /audio/linux-shoutcast
parent3bcd0f2ec1a8ae0d3ae8e29f17ad1f94086b1957 (diff)
downloadports-a0a19e5533d374152bfca09c2470c3eb43a2de32.tar.gz
ports-a0a19e5533d374152bfca09c2470c3eb43a2de32.zip
Notes
Diffstat (limited to 'audio/linux-shoutcast')
-rw-r--r--audio/linux-shoutcast/Makefile20
-rw-r--r--audio/linux-shoutcast/pkg-install7
2 files changed, 16 insertions, 11 deletions
diff --git a/audio/linux-shoutcast/Makefile b/audio/linux-shoutcast/Makefile
index e00ce88b9d49..d47d402e6dde 100644
--- a/audio/linux-shoutcast/Makefile
+++ b/audio/linux-shoutcast/Makefile
@@ -26,7 +26,7 @@ PORTDOCS= README.TXT
WRKSRC= ${WRKDIR}
post-patch:
- ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
+ @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
-e 's|=sc_serv.log|=/var/log/sc_serv.log|' \
-e 's|=sc_w3c.log|=/var/log/sc_w3c.log|' \
-e 's|ScreenLog=1|ScreenLog=0|' \
@@ -36,19 +36,19 @@ post-patch:
${WRKSRC}/sc_serv.conf
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
- ${MKDIR} ${PREFIX}/etc/shoutcast
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
- @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
+ @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${TARGETDIR}/sbin
+ @${MKDIR} ${TARGETDIR}/etc/shoutcast
+ @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${TARGETDIR}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
.endif
post-install:
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- ${BRANDELF} -t Linux ${PREFIX}/sbin/sc_serv
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${BRANDELF} -t Linux ${TARGETDIR}/sbin/sc_serv
.include <bsd.port.mk>
diff --git a/audio/linux-shoutcast/pkg-install b/audio/linux-shoutcast/pkg-install
index bb97ac95dde2..75387ad52143 100644
--- a/audio/linux-shoutcast/pkg-install
+++ b/audio/linux-shoutcast/pkg-install
@@ -8,7 +8,12 @@ SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
SC_HOME=/nonexistent
-PW=/usr/sbin/pw
+
+if [ -n "${DESTDIR}" ] ; then
+ PW="/usr/sbin/chroot ${DESTDIR} /usr/sbin/pw"
+else
+ PW="/usr/sbin/pw"
+fi
if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
gid=210