aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-shoutcast
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-03 15:06:00 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-03 15:06:00 +0000
commitd2e4a5a9e07ed2383d08ea0d7af7a4395abf3579 (patch)
tree658fbcb8c2872df14409a0ec70154dae2deda617 /audio/linux-shoutcast
parentd6db46aade6ffa86b0ddda72d3a04318bd30fa3b (diff)
downloadports-d2e4a5a9e07ed2383d08ea0d7af7a4395abf3579.tar.gz
ports-d2e4a5a9e07ed2383d08ea0d7af7a4395abf3579.zip
Notes
Diffstat (limited to 'audio/linux-shoutcast')
-rw-r--r--audio/linux-shoutcast/Makefile3
-rw-r--r--audio/linux-shoutcast/pkg-install50
2 files changed, 2 insertions, 51 deletions
diff --git a/audio/linux-shoutcast/Makefile b/audio/linux-shoutcast/Makefile
index 721aeeda001e..85e65e56a0ed 100644
--- a/audio/linux-shoutcast/Makefile
+++ b/audio/linux-shoutcast/Makefile
@@ -21,6 +21,8 @@ ONLY_FOR_ARCHS= i386 amd64 ia64
NO_BUILD= YES
RESTRICTED= Redistribution of the software is not allowed
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
USE_RC_SUBR= shoutcast.sh
PORTDOCS= README.TXT
WRKSRC= ${WRKDIR}
@@ -48,7 +50,6 @@ do-install:
.endif
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${BRANDELF} -t Linux ${PREFIX}/sbin/sc_serv
.include <bsd.port.mk>
diff --git a/audio/linux-shoutcast/pkg-install b/audio/linux-shoutcast/pkg-install
deleted file mode 100644
index 2b6c96b93a64..000000000000
--- a/audio/linux-shoutcast/pkg-install
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-SC_GROUP=shoutcast
-SC_USER=shoutcast
-SC_SHELL=/bin/sh
-SC_HOME=/nonexistent
-PW="/usr/sbin/pw"
-
-if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
- gid=210
- while ${PW} show group -g ${gid} -q >/dev/null; do
- gid=`expr ${gid} + 1`
- done
- if ! ${PW} add group ${SC_GROUP} -g ${gid}; then
- e=$?
- echo "*** Failed to add group \`${SC_GROUP}'. Please add it manually."
- exit ${e}
- fi
- echo "*** Added group \`${SC_GROUP}' (id ${gid})"
-else
- gid=`${PW} show group ${SC_GROUP} 2>/dev/null | cut -d: -f3`
-fi
-
-if ! ${PW} show user ${SC_USER} -q >/dev/null; then
- uid=210
- while ${PW} show user -u ${uid} -q >/dev/null; do
- uid=`expr ${uid} + 1`
- done
- if ! ${PW} add user ${SC_USER} -u ${uid} -g ${gid} -d "${SC_HOME}" \
- -c "Shoutcast sandbox" -s "${SC_SHELL}" -p "*" \
- ; then
- e=$?
- echo "*** Failed to add user \`${SC_USER}'. Please add it manually."
- exit ${e}
- fi
- echo "*** Added user \`${SC_USER}' (id ${uid})"
-else
- if ! ${PW} mod user ${SC_USER} -g ${gid} -d "${SC_HOME}" \
- -c "Shoutcast sandbox" -s "${SC_SHELL}" -p "*" \
- ; then
- e=$?
- echo "*** Failed to update user \`${SC_USER}'."
- exit ${e}
- fi
- echo "*** Updated user \`${SC_USER}'."
-fi