aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-vsound
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-01-29 08:24:02 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-01-29 08:24:02 +0000
commit2607aee727fcfbad21ffe92ca6edfe607bf62636 (patch)
tree28b4b3ed89825d05a7ed935a54ee427a20dfaa7f /audio/linux-vsound
parentb37067d0f1c4bc3c1f5a0462d5739d3d5e3784ae (diff)
downloadports-2607aee727fcfbad21ffe92ca6edfe607bf62636.tar.gz
ports-2607aee727fcfbad21ffe92ca6edfe607bf62636.zip
Notes
Diffstat (limited to 'audio/linux-vsound')
-rw-r--r--audio/linux-vsound/Makefile26
-rw-r--r--audio/linux-vsound/distinfo1
-rw-r--r--audio/linux-vsound/pkg-comment1
-rw-r--r--audio/linux-vsound/pkg-descr18
-rw-r--r--audio/linux-vsound/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/audio/linux-vsound/Makefile b/audio/linux-vsound/Makefile
new file mode 100644
index 000000000000..7c17b6dfac31
--- /dev/null
+++ b/audio/linux-vsound/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: linux-vsound
+# Date created: 28 January 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-vsound
+PORTVERSION= 0.4
+CATEGORIES= audio linux
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kris
+DISTNAME= vsound-${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= kris@FreeBSD.org
+
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base/ \
+ sox:${PORTSDIR}/audio/sox/
+
+NO_BUILD= yes
+
+do-install:
+ @cd ${PREFIX} && ${TAR} xfz ${DISTDIR}/${DISTFILES}
+
+.include <bsd.port.mk>
diff --git a/audio/linux-vsound/distinfo b/audio/linux-vsound/distinfo
new file mode 100644
index 000000000000..ca1cb1c493ba
--- /dev/null
+++ b/audio/linux-vsound/distinfo
@@ -0,0 +1 @@
+MD5 (vsound-0.4.tar.gz) = e3d9132488feaf8d62a5d2cc80d23e1b
diff --git a/audio/linux-vsound/pkg-comment b/audio/linux-vsound/pkg-comment
new file mode 100644
index 000000000000..0f404455bb9d
--- /dev/null
+++ b/audio/linux-vsound/pkg-comment
@@ -0,0 +1 @@
+Utility for capturing audio streams from Linux binaries
diff --git a/audio/linux-vsound/pkg-descr b/audio/linux-vsound/pkg-descr
new file mode 100644
index 000000000000..a896c73f69ff
--- /dev/null
+++ b/audio/linux-vsound/pkg-descr
@@ -0,0 +1,18 @@
+This program allows you to record the output of any standard OSS
+program (one that uses /dev/dsp for sound) without having to modify or
+recompile the program. It uses the same idea as the esddsp wrapper
+from the Enlightened Sound Daemon (in fact, vsound is based on
+esddsp). That is, it preloads a library that intercepts calls to open
+/dev/dsp, and instead returns a handle to a normal file. It also
+intercepts ioctl's on that file handle and logs them, to help convert
+the audio data from its raw form. Vsound then uses sox to convert the
+raw data to the desired file format.
+
+The upshoot of this is that instead of playing sound to the sound card
+in your computer, the data is recorded to a file. This is similar to
+if you connected a loopback cable to the line in and line out jacks on
+your sound card, but no DA or AD conversions take place, so quality is
+not lost.
+
+Erik de Castro Lopo <erikd@zip.com.au>
+WWW: http://www.zip.com.au/~erikd/vsound/
diff --git a/audio/linux-vsound/pkg-plist b/audio/linux-vsound/pkg-plist
new file mode 100644
index 000000000000..8699e55becf2
--- /dev/null
+++ b/audio/linux-vsound/pkg-plist
@@ -0,0 +1,5 @@
+bin/vsound
+lib/vsound/libvsound.so
+share/doc/vsound/README
+@dirrm lib/vsound
+@dirrm share/doc/vsound