aboutsummaryrefslogtreecommitdiff
path: root/audio/lmms
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-04-11 21:01:11 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-04-11 21:01:11 +0000
commita2078b240bc0e107d6d492c34d4197510e478133 (patch)
tree26627de7afe8146767c513db70524b84a26a4231 /audio/lmms
parent19ab686195c72a26f068babf7732986221feb30a (diff)
downloadports-a2078b240bc0e107d6d492c34d4197510e478133.tar.gz
ports-a2078b240bc0e107d6d492c34d4197510e478133.zip
Notes
Diffstat (limited to 'audio/lmms')
-rw-r--r--audio/lmms/Makefile10
-rw-r--r--audio/lmms/files/patch-src-widgets_knob.cpp11
2 files changed, 12 insertions, 9 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 7054e677300f..7e9439ed2c94 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -54,12 +54,4 @@ post-install:
# (root privileges are dropped in the main routine)
${CHMOD} u+s ${PREFIX}/bin/lmms
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/lmms/files/patch-src-widgets_knob.cpp b/audio/lmms/files/patch-src-widgets_knob.cpp
new file mode 100644
index 000000000000..781764a515eb
--- /dev/null
+++ b/audio/lmms/files/patch-src-widgets_knob.cpp
@@ -0,0 +1,11 @@
+--- src/widgets/knob.cpp.orig 2009-04-11 22:43:48.000000000 +0200
++++ src/widgets/knob.cpp 2009-04-11 22:44:54.000000000 +0200
+@@ -471,7 +471,7 @@
+ eng()->getMainWindow()->isShiftPressed() == TRUE )
+ {
+ new stringPairDrag( "link_object",
+- QString::number( (uint) this ),
++ QString::number( (intptr_t) this ),
+ QPixmap(), this, eng() );
+ }
+ else if( _me->button() == Qt::MidButton )