aboutsummaryrefslogtreecommitdiff
path: root/audio/lmms
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-21 21:14:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-21 21:14:47 +0000
commit5f66447962336193269a022301360d43cda4aa5d (patch)
tree6a75818107d26fec4cba9f4b2c37a425f62cc12c /audio/lmms
parent4c347376ee357bd88ff0848a1285bb05eb62d23f (diff)
downloadports-5f66447962336193269a022301360d43cda4aa5d.tar.gz
ports-5f66447962336193269a022301360d43cda4aa5d.zip
Notes
Diffstat (limited to 'audio/lmms')
-rw-r--r--audio/lmms/Makefile9
-rw-r--r--audio/lmms/distinfo6
-rw-r--r--audio/lmms/files/patch-CMakeLists.txt24
-rw-r--r--audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt39
-rw-r--r--audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx22
-rw-r--r--audio/lmms/pkg-plist162
6 files changed, 148 insertions, 114 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 2a45271c6328..0bfcfa435482 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lmms
-PORTVERSION= 0.4.5
-PORTREVISION= 2
+PORTVERSION= 0.4.6
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
@@ -73,12 +72,6 @@ CMAKE_ARGS+= -DWANT_SDL:BOOL=OFF
.endif
post-patch:
-.for file in CMakeLists.txt
- @${REINPLACE_CMD} -e \
- 's|-O2 -g||g ; \
- s|-ftree-vectorize||g ; \
- s|/share/man/|/man/|g' ${WRKSRC}/${file}
-.endfor
.for file in data/lmms.desktop
@${REINPLACE_CMD} -e \
'/^Icon/s|=.*$$|=lmms|g ; \
diff --git a/audio/lmms/distinfo b/audio/lmms/distinfo
index 6c0b5543ca37..86d176422112 100644
--- a/audio/lmms/distinfo
+++ b/audio/lmms/distinfo
@@ -1,3 +1,3 @@
-MD5 (lmms-0.4.5.tar.bz2) = 6d58d73b44baddadc4f0ac6464fbd530
-SHA256 (lmms-0.4.5.tar.bz2) = 8604f152fbb33b97a8cb13205b768a827e5c6775f52d364129dc3bfe9c2fecda
-SIZE (lmms-0.4.5.tar.bz2) = 12972717
+MD5 (lmms-0.4.6.tar.bz2) = 6b6d64d6e3e864d38e5e821463f2fabb
+SHA256 (lmms-0.4.6.tar.bz2) = c8f103ea9060bcbb72b9856029657edbe13a7c7a5f541fe23dedc47127e970c0
+SIZE (lmms-0.4.6.tar.bz2) = 12567461
diff --git a/audio/lmms/files/patch-CMakeLists.txt b/audio/lmms/files/patch-CMakeLists.txt
index 32201821e182..9e96f9421202 100644
--- a/audio/lmms/files/patch-CMakeLists.txt
+++ b/audio/lmms/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- CMakeLists.txt.orig 2009-08-11 20:52:15.000000000 +0400
-+++ CMakeLists.txt 2010-01-14 22:07:03.000000000 +0300
+--- CMakeLists.txt.orig 2009-12-25 08:49:19.000000000 +0900
++++ CMakeLists.txt 2010-01-20 00:15:00.000000000 +0900
@@ -334,6 +334,7 @@
# check for libsamplerate
IF(WANT_SYSTEM_SR)
@@ -8,3 +8,23 @@
IF(SAMPLERATE_FOUND)
SET(LMMS_HAVE_SAMPLERATE TRUE)
ENDIF(SAMPLERATE_FOUND)
+@@ -364,8 +365,8 @@
+
+ # set compiler flags
+ #SET(CMAKE_BUILD_TYPE relwithdebug)
+-SET(CMAKE_C_FLAGS "-O2 -g -Wall -ftree-vectorize ${CMAKE_C_FLAGS}")
+-SET(CMAKE_CXX_FLAGS "-O2 -g -fno-exceptions -Wall -ftree-vectorize ${CMAKE_CXX_FLAGS}")
++SET(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
++SET(CMAKE_CXX_FLAGS "-fno-exceptions -Wall ${CMAKE_CXX_FLAGS}")
+ #SET(CMAKE_C_FLAGS_${CMAKE_BUILD_TYPE} "${CMAKE_C_FLAGS}")
+ #SET(CMAKE_CXX_FLAGS_${CMAKE_BUILD_TYPE} "${CMAKE_CXX_FLAGS}")
+
+@@ -459,7 +460,7 @@
+ ENDIF(NOT LMMS_BUILD_APPLE)
+
+ INSTALL(TARGETS lmms RUNTIME DESTINATION bin)
+- INSTALL(FILES ${CMAKE_BINARY_DIR}/lmms.1.gz DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1/ PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
++ INSTALL(FILES ${CMAKE_BINARY_DIR}/lmms.1.gz DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1/ PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
+
+ ENDIF(LMMS_BUILD_WIN32)
+
diff --git a/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt b/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
index 63248f91c93e..7adaef165ef5 100644
--- a/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
+++ b/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
@@ -1,26 +1,29 @@
---- plugins/zynaddsubfx/CMakeLists.txt.orig 2009-08-11 20:52:18.000000000 +0400
-+++ plugins/zynaddsubfx/CMakeLists.txt 2010-01-14 22:15:51.000000000 +0300
-@@ -97,12 +97,9 @@
- ADD_DEFINITIONS(-DASM_F2I_YES)
+--- plugins/zynaddsubfx/CMakeLists.txt.orig 2009-12-25 08:49:24.000000000 +0900
++++ plugins/zynaddsubfx/CMakeLists.txt 2010-01-20 00:48:44.000000000 +0900
+@@ -52,15 +52,13 @@
+ ADD_DEFINITIONS(-DASM_F2I_YES)
ENDIF(LMMS_HOST_X86 OR LMMS_HOST_X86_64)
-# build ZynAddSubFX with full optimizations
--SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O3 -Wno-write-strings -Wno-deprecated-declarations")
+-SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -Wno-write-strings -Wno-deprecated-declarations")
-
- # link default libraries
- LINK_DIRECTORIES(${FFTW3F_LIBRARY_DIRS})
--LINK_LIBRARIES(${FFTW3F_LIBRARIES} -lz -lpthread ${CMAKE_CURRENT_BINARY_DIR}/fltk/bin/libfltk.a)
-+LINK_LIBRARIES(${FFTW3F_LIBRARIES} -lz ${CMAKE_CURRENT_BINARY_DIR}/fltk/bin/libfltk.a)
-
- # FLTK needs X
- IF(LMMS_BUILD_LINUX)
-@@ -117,7 +114,8 @@
- LINK_LIBRARIES(${QT_LIBRARIES} -lole32 -luuid -lcomctl32 -lgdi32)
+ # link system-libraries when on win32
+ IF(LMMS_BUILD_WIN32)
+ ADD_DEFINITIONS(-DPTW32_STATIC_LIB)
ENDIF(LMMS_BUILD_WIN32)
--INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/fltk/ ${CMAKE_CURRENT_SOURCE_DIR} ${FFTW3F_INCLUDE_DIRS})
-+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR} ${FFTW3F_INCLUDE_DIRS})
+-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/fltk/ ${CMAKE_CURRENT_SOURCE_DIR}/mxml ${CMAKE_CURRENT_SOURCE_DIR} ${FFTW3F_INCLUDE_DIRS})
++INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/mxml ${CMAKE_CURRENT_SOURCE_DIR} ${FFTW3F_INCLUDE_DIRS})
+INCLUDE_DIRECTORIES(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/fltk/)
- ADD_EXECUTABLE(remote_zynaddsubfx remote_zynaddsubfx.cpp ${ZYN_SRC} ${MXML_SRC})
- INSTALL(TARGETS remote_zynaddsubfx RUNTIME DESTINATION ${PLUGIN_DIR})
+ set(ZASF_CORE_LIBS
+ zynaddsubfx_input
+@@ -90,7 +88,7 @@
+ add_subdirectory(src/Samples)
+
+ ADD_LIBRARY(ZynAddSubFxCore SHARED LocalZynAddSubFx.cpp ${MXML_SRC})
+-TARGET_LINK_LIBRARIES(ZynAddSubFxCore ${ZASF_CORE_LIBS} ${FFTW3F_LIBRARIES} -lz -lpthread)
++TARGET_LINK_LIBRARIES(ZynAddSubFxCore ${ZASF_CORE_LIBS} ${FFTW3F_LIBRARIES} -lz -L${FFTW3F_LIBRARY_DIRS})
+ IF(LMMS_BUILD_WIN32)
+ TARGET_LINK_LIBRARIES(ZynAddSubFxCore -lwsock32)
+ INSTALL(TARGETS ZynAddSubFxCore DESTINATION ${PLUGIN_DIR})
diff --git a/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx b/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx
new file mode 100644
index 000000000000..9b9c04bc7dff
--- /dev/null
+++ b/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx
@@ -0,0 +1,22 @@
+--- plugins/zynaddsubfx/fltk/src/filename_list.cxx.orig 2009-12-25 08:49:24.000000000 +0900
++++ plugins/zynaddsubfx/fltk/src/filename_list.cxx 2010-01-22 02:17:11.000000000 +0900
+@@ -31,6 +31,10 @@
+ #include "flstring.h"
+ #include <stdlib.h>
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+
+ extern "C" {
+ #ifndef HAVE_SCANDIR
+@@ -77,7 +81,7 @@
+ Fl_File_Sort_F *sort) {
+ #ifndef HAVE_SCANDIR
+ int n = scandir(d, list, 0, sort);
+-#elif defined(__hpux) || defined(__CYGWIN__) || (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 10 )
++#elif defined(__hpux) || defined(__CYGWIN__) || (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 10 ) || (defined(__FreeBSD__) && __FreeBSD_version >= 900006)
+ // HP-UX, Cygwin and POSIX (2008) define the comparison function like this:
+ int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
+ #elif defined(__osf__)
diff --git a/audio/lmms/pkg-plist b/audio/lmms/pkg-plist
index efea7152b2db..97034e6b3f48 100644
--- a/audio/lmms/pkg-plist
+++ b/audio/lmms/pkg-plist
@@ -1,32 +1,93 @@
bin/lmms
+include/lmms/AudioAlsa.h
+include/lmms/AudioDevice.h
+include/lmms/AudioDummy.h
+include/lmms/AudioFileDevice.h
+include/lmms/AudioFileOgg.h
+include/lmms/AudioFileWave.h
+include/lmms/AudioJack.h
+include/lmms/AudioOss.h
+include/lmms/AudioPort.h
+include/lmms/AudioPortAudio.h
+include/lmms/AudioPulseAudio.h
+include/lmms/AudioSampleRecorder.h
+include/lmms/AudioSdl.h
+include/lmms/AutomatableModel.h
+include/lmms/AutomatableModelView.h
+include/lmms/Clipboard.h
+include/lmms/ComboBoxModel.h
include/lmms/Controller.h
include/lmms/ControllerConnection.h
include/lmms/ControllerConnectionDialog.h
include/lmms/ControllerDialog.h
include/lmms/ControllerRackView.h
include/lmms/ControllerView.h
+include/lmms/DummyEffect.h
+include/lmms/DummyInstrument.h
+include/lmms/DummyPlugin.h
+include/lmms/Effect.h
+include/lmms/EffectChain.h
+include/lmms/EffectControlDialog.h
+include/lmms/EffectControls.h
+include/lmms/EffectRackView.h
+include/lmms/EffectSelectDialog.h
+include/lmms/EffectView.h
+include/lmms/EnvelopeAndLfoParameters.h
+include/lmms/EnvelopeAndLfoView.h
+include/lmms/FxMixer.h
+include/lmms/FxMixerView.h
+include/lmms/ImportFilter.h
+include/lmms/Instrument.h
+include/lmms/InstrumentFunctionViews.h
+include/lmms/InstrumentFunctions.h
+include/lmms/InstrumentMidiIOView.h
+include/lmms/InstrumentPlayHandle.h
+include/lmms/InstrumentSoundShaping.h
+include/lmms/InstrumentSoundShapingView.h
+include/lmms/InstrumentTrack.h
+include/lmms/InstrumentView.h
+include/lmms/JournallingObject.h
+include/lmms/LadspaBase.h
+include/lmms/LadspaControl.h
+include/lmms/LadspaControlView.h
include/lmms/LfoController.h
+include/lmms/MainWindow.h
+include/lmms/MeterDialog.h
+include/lmms/MeterModel.h
+include/lmms/MicroTimer.h
+include/lmms/MidiAlsaRaw.h
+include/lmms/MidiAlsaSeq.h
+include/lmms/MidiClient.h
include/lmms/MidiController.h
+include/lmms/MidiDummy.h
+include/lmms/MidiEventProcessor.h
+include/lmms/MidiOss.h
+include/lmms/MidiPort.h
+include/lmms/MidiPortMenu.h
+include/lmms/MidiWinMM.h
+include/lmms/Model.h
+include/lmms/ModelView.h
+include/lmms/Oscillator.h
include/lmms/PeakController.h
+include/lmms/Piano.h
+include/lmms/PianoView.h
+include/lmms/Plugin.h
+include/lmms/PluginView.h
+include/lmms/ProjectJournal.h
+include/lmms/ProjectRenderer.h
+include/lmms/RemotePlugin.h
+include/lmms/SerializingObject.h
+include/lmms/SideBar.h
+include/lmms/SideBarWidget.h
+include/lmms/SweepOscillator.h
+include/lmms/TempoSyncKnob.h
+include/lmms/TempoSyncKnobModel.h
+include/lmms/ToolPlugin.h
+include/lmms/ToolPluginView.h
include/lmms/about_dialog.h
include/lmms/aeffectx.h
include/lmms/atomic_int.h
-include/lmms/audio_alsa.h
-include/lmms/audio_device.h
-include/lmms/audio_dummy.h
-include/lmms/audio_file_device.h
-include/lmms/audio_file_ogg.h
-include/lmms/audio_file_wave.h
-include/lmms/audio_jack.h
-include/lmms/audio_oss.h
-include/lmms/audio_port.h
-include/lmms/audio_portaudio.h
-include/lmms/audio_pulseaudio.h
-include/lmms/audio_sample_recorder.h
-include/lmms/audio_sdl.h
include/lmms/automatable_button.h
-include/lmms/automatable_model.h
-include/lmms/automatable_model_view.h
include/lmms/automatable_slider.h
include/lmms/automation_editor.h
include/lmms/automation_pattern.h
@@ -38,32 +99,18 @@ include/lmms/bb_editor.h
include/lmms/bb_track.h
include/lmms/bb_track_container.h
include/lmms/caption_menu.h
-include/lmms/clipboard.h
include/lmms/combobox.h
-include/lmms/combobox_model.h
include/lmms/config_mgr.h
include/lmms/cpuload_widget.h
include/lmms/custom_events.h
include/lmms/debug.h
include/lmms/detuning_helper.h
include/lmms/drumsynth.h
-include/lmms/dummy_effect.h
-include/lmms/dummy_instrument.h
-include/lmms/dummy_plugin.h
-include/lmms/effect.h
-include/lmms/effect_chain.h
-include/lmms/effect_control_dialog.h
-include/lmms/effect_controls.h
include/lmms/effect_lib.h
-include/lmms/effect_rack_view.h
-include/lmms/effect_select_dialog.h
-include/lmms/effect_view.h
include/lmms/embed.cpp
include/lmms/embed.h
include/lmms/endian_handling.h
include/lmms/engine.h
-include/lmms/envelope_and_lfo_parameters.h
-include/lmms/envelope_and_lfo_view.h
include/lmms/export.h
include/lmms/export_project_dialog.h
include/lmms/fade_button.h
@@ -71,31 +118,14 @@ include/lmms/fader.h
include/lmms/fft_helpers.h
include/lmms/fifo_buffer.h
include/lmms/file_browser.h
-include/lmms/fx_mixer.h
-include/lmms/fx_mixer_view.h
include/lmms/graph.h
include/lmms/group_box.h
include/lmms/gui_templates.h
-include/lmms/import_filter.h
include/lmms/inline_automation.h
-include/lmms/instrument.h
-include/lmms/instrument_function_views.h
-include/lmms/instrument_functions.h
-include/lmms/instrument_midi_io_view.h
-include/lmms/instrument_play_handle.h
-include/lmms/instrument_sound_shaping.h
-include/lmms/instrument_sound_shaping_view.h
-include/lmms/instrument_track.h
-include/lmms/instrument_view.h
include/lmms/interpolation.h
-include/lmms/journalling_object.h
-include/lmms/kmultitabbar.h
include/lmms/knob.h
include/lmms/ladspa.h
include/lmms/ladspa_2_lmms.h
-include/lmms/ladspa_base.h
-include/lmms/ladspa_control.h
-include/lmms/ladspa_control_view.h
include/lmms/ladspa_manager.h
include/lmms/lcd_spinbox.h
include/lmms/led_checkbox.h
@@ -104,69 +134,42 @@ include/lmms/lmms_constants.h
include/lmms/lmms_math.h
include/lmms/lmms_style.h
include/lmms/lmmsconfig.h
-include/lmms/main_window.h
-include/lmms/meter_dialog.h
-include/lmms/meter_model.h
-include/lmms/micro_timer.h
include/lmms/midi.h
-include/lmms/midi_alsa_raw.h
-include/lmms/midi_alsa_seq.h
-include/lmms/midi_client.h
-include/lmms/midi_dummy.h
-include/lmms/midi_event_processor.h
-include/lmms/midi_oss.h
-include/lmms/midi_port.h
-include/lmms/midi_port_menu.h
include/lmms/midi_time.h
-include/lmms/midi_winmm.h
include/lmms/mixer.h
include/lmms/mmp.h
-include/lmms/mv_base.h
include/lmms/note.h
include/lmms/note_play_handle.h
include/lmms/nstate_button.h
-include/lmms/oscillator.h
include/lmms/panning.h
include/lmms/panning_constants.h
include/lmms/pattern.h
include/lmms/pch.h
-include/lmms/piano.h
include/lmms/piano_roll.h
include/lmms/pixmap_button.h
include/lmms/play_handle.h
-include/lmms/plugin.h
include/lmms/plugin_browser.h
-include/lmms/plugin_view.h
include/lmms/preset_preview_play_handle.h
-include/lmms/project_journal.h
include/lmms/project_notes.h
-include/lmms/project_renderer.h
include/lmms/project_version.h
-include/lmms/remote_plugin.h
include/lmms/rename_dialog.h
include/lmms/rubberband.h
include/lmms/sample_buffer.h
include/lmms/sample_play_handle.h
include/lmms/sample_record_handle.h
include/lmms/sample_track.h
-include/lmms/serializing_object.h
include/lmms/setup_dialog.h
include/lmms/shared_object.h
-include/lmms/side_bar.h
-include/lmms/side_bar_widget.h
include/lmms/song.h
include/lmms/song_editor.h
include/lmms/string_pair_drag.h
include/lmms/surround_area.h
-include/lmms/sweep_oscillator.h
include/lmms/tab_bar.h
include/lmms/tab_button.h
include/lmms/tab_widget.h
include/lmms/templates.h
-include/lmms/tempo_sync_knob.h
include/lmms/text_float.h
include/lmms/timeline.h
-include/lmms/tool.h
include/lmms/tool_button.h
include/lmms/tooltip.h
include/lmms/track.h
@@ -177,6 +180,8 @@ include/lmms/transformable_auto_model.h
include/lmms/update_event.h
include/lmms/visualization_widget.h
include/lmms/volume.h
+lib/lmms/RemoteZynAddSubFx
+lib/lmms/libZynAddSubFxCore.so
lib/lmms/libaudiofileprocessor.so
lib/lmms/libbassbooster.so
lib/lmms/libbitinvader.so
@@ -198,7 +203,6 @@ lib/lmms/libstereomatrix.so
lib/lmms/libtripleoscillator.so
lib/lmms/libvibedstrings.so
lib/lmms/libzynaddsubfx.so
-lib/lmms/remote_zynaddsubfx
share/applications/lmms.desktop
%%DATADIR%%/backgrounds/lmms_tile.png
%%DATADIR%%/backgrounds/vinnie.png
@@ -211,6 +215,7 @@ share/applications/lmms.desktop
%%DATADIR%%/locale/ir.qm
%%DATADIR%%/locale/it.qm
%%DATADIR%%/locale/ja.qm
+%%DATADIR%%/locale/ko.qm
%%DATADIR%%/locale/nl.qm
%%DATADIR%%/locale/pt_br.qm
%%DATADIR%%/locale/ru.qm
@@ -756,8 +761,6 @@ share/applications/lmms.desktop
%%DATADIR%%/projects/cool_songs/TobyDox-Psycho.mmp
%%DATADIR%%/projects/cool_songs/TobyDox-TheFourthDimension.mmp
%%DATADIR%%/projects/cool_songs/j1m-DingDong.mmp
-%%DATADIR%%/projects/covers/J.S.Bach-Preludium_and_Fugue_A-Minor.mmpz
-%%DATADIR%%/projects/covers/MonkeyIsland1-Intro.mmpz
%%DATADIR%%/projects/demos/TobyDox-Crystallo.mmp
%%DATADIR%%/projects/demos/Zvonsully-RaceTheZBeat.mmp
%%DATADIR%%/projects/demos/beat_collection.mmp
@@ -771,11 +774,6 @@ share/applications/lmms.desktop
%%DATADIR%%/projects/demos/loop_collection.mmp
%%DATADIR%%/projects/demos/newFangled.mmpz
%%DATADIR%%/projects/demos/some_basslines.mmp
-%%DATADIR%%/projects/oldstuff/1st.mmp
-%%DATADIR%%/projects/oldstuff/Mart-Dirt_Track.mmp
-%%DATADIR%%/projects/oldstuff/MaxFellner-Ease.mmp
-%%DATADIR%%/projects/oldstuff/SharkyX-DeadManDancing.mmp
-%%DATADIR%%/projects/oldstuff/time_machine.mmp
%%DATADIR%%/projects/tutorials/editing_note_volumes.mmp
%%DATADIR%%/samples/basses/bass01.ogg
%%DATADIR%%/samples/basses/bass_acid01.ogg
@@ -1994,9 +1992,7 @@ share/pixmaps/lmms.png
@dirrm %%DATADIR%%/samples/basses
@dirrm %%DATADIR%%/samples
@dirrm %%DATADIR%%/projects/tutorials
-@dirrm %%DATADIR%%/projects/oldstuff
@dirrm %%DATADIR%%/projects/demos
-@dirrm %%DATADIR%%/projects/covers
@dirrm %%DATADIR%%/projects/cool_songs
@dirrm %%DATADIR%%/projects
@dirrm %%DATADIR%%/presets/ZynAddSubFX/SynthPiano