aboutsummaryrefslogtreecommitdiff
path: root/audio/lplayer
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-23 13:28:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-23 13:28:41 +0000
commitc7d1bb1b9f1e99dbbd05b92f7f4130fc9534d81f (patch)
tree45f8929a0b468bb5e6ca5b144f376d78da2f2041 /audio/lplayer
parentb77c661dfb54d014b8759c662ce56305a438501c (diff)
downloadports-c7d1bb1b9f1e99dbbd05b92f7f4130fc9534d81f.tar.gz
ports-c7d1bb1b9f1e99dbbd05b92f7f4130fc9534d81f.zip
Notes
Diffstat (limited to 'audio/lplayer')
-rw-r--r--audio/lplayer/Makefile50
-rw-r--r--audio/lplayer/distinfo2
-rw-r--r--audio/lplayer/files/lplayer41
-rw-r--r--audio/lplayer/files/patch-lp.pro14
-rw-r--r--audio/lplayer/pkg-plist38
5 files changed, 35 insertions, 110 deletions
diff --git a/audio/lplayer/Makefile b/audio/lplayer/Makefile
index 0c5177b8bc4d..a98bca7323e4 100644
--- a/audio/lplayer/Makefile
+++ b/audio/lplayer/Makefile
@@ -8,55 +8,31 @@
#
PORTNAME= lplayer
-PORTVERSION= 0.98.2
+PORTVERSION= 0.99.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+DISTNAME= ${PORTNAME}-${PORTVERSION}_src
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A QT program to queue lots of MP3s for random XMMS play
-BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
-MAKE_ENV+= QTDIR=${QT_PREFIX}
-CONFIGURE_ENV= ${MAKE_ENV}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-xmms-prefix=${X11BASE} --with-xinerama
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
-do-configure:
- cd ${WRKSRC}; \
- XMMSLIBS=$$(xmms-config --libs); \
- XMMSINCS=$$(xmms-config --cflags | sed 's|-I||g'); \
- ${REINPLACE_CMD} -e "s|@X11BASE@|${X11BASE}|g" \
- -e "s|@LOCALBASE@|${LOCALBASE}|g" \
- -e "s|@XMMSLIBS@|$$XMMSLIBS|" \
- -e "s|@XMMSINCS@|$$XMMSINCS|" lp.pro; \
- ${SETENV} ${CONFIGURE_ENV} qmake -makefile -o Makefile -unix lp.pro
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pedantic||g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-DOCS_SUBDIR= ${DOCSDIR:S|^${PREFIX}/||}
-EXAMPLES_SUBDIR= ${EXAMPLESDIR:S|^${PREFIX}/||}
-
-BINDIR= ${PREFIX}/bin
-BIN_SUBDIR= ${BINDIR:S|^${PREFIX}/||}
-LIBDIR= ${PREFIX}/lib
-LIB_SUBDIR= ${LIBDIR:S|^${PREFIX}/||}
-PKGLIBDIR= ${LIBDIR}/${PORTNAME}
-PKGLIB_SUBDIR= ${PKGLIBDIR:S|^${PREFIX}/||}
-
-do-install:
- ${MKDIR} ${BINDIR} ${PKGLIBDIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-bin ${PKGLIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/../gnu/lplayerdir/*.png ${PKGLIBDIR}
- ${INSTALL_SCRIPT} ${FILESDIR}/lplayer ${BINDIR}
-
-.include <bsd.port.post.mk>
-
-#EOF
+.include <bsd.port.mk>
diff --git a/audio/lplayer/distinfo b/audio/lplayer/distinfo
index bec0e59c64fa..a52999a9b423 100644
--- a/audio/lplayer/distinfo
+++ b/audio/lplayer/distinfo
@@ -1 +1 @@
-MD5 (lplayer_0.98.2_src.tgz) = 95e74e891696f68fdf2cb5202bf159d8
+MD5 (lplayer-0.99.0_src.tgz) = 5d627e8cd36fd8f809935d94e655636a
diff --git a/audio/lplayer/files/lplayer b/audio/lplayer/files/lplayer
deleted file mode 100644
index 48d3a8f3b3d1..000000000000
--- a/audio/lplayer/files/lplayer
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-# -*-mode: shell-script-*-
-#
-# lplayer
-#
-# 2002-12-16 Alan Eldridge <alane@freebsd.org>
-#
-
-run_lplayer() {
- ./lplayer-bin ${1:+"$@"} &
- exit 0
-}
-
-INFOPID=0
-XDIALOG=/usr/X11R6/bin/Xdialog
-if test -x $XDIALOG; then
- $XDIALOG --title LongPlayer --backtitle "Please wait ..." \
- --no-buttons --infobox "Backing up DB ..." 15 50 5000 &
- INFOPID=$!
-fi # test -x $XDIALOG ...
-
-DBFILE=$HOME/.lptable.lp2
-PLISTS=$HOME/.lpplaylists.xml
-SETTINGS=$HOME/.lpsettings.xml
-SUFFIX=.save
-LPLAYERDIR=/usr/local/lib/lplayer
-
-for i in $DBFILE $PLISTS $SETTINGS; do
- if test -f $i; then
- test -f $i$SUFFIX && cmp -s $i $i$SUFFIX && continue
- rm -f $i$SUFFIX 2>/dev/null; cp -pf $i $i$SUFFIX
- fi
-done
-
-test $INFOPID -gt 0 && wait $INFOPID
-
-cd $LPLAYERDIR
-run_lplayer ${1:+"$@"} &
-
-exit 0
-#EOF
diff --git a/audio/lplayer/files/patch-lp.pro b/audio/lplayer/files/patch-lp.pro
deleted file mode 100644
index 1d9de0c44c08..000000000000
--- a/audio/lplayer/files/patch-lp.pro
+++ /dev/null
@@ -1,14 +0,0 @@
---- lp.pro.orig Tue Jan 21 01:57:13 2003
-+++ lp.pro Sat Jun 14 20:08:02 2003
-@@ -88,9 +88,8 @@
- #Qt only
- #==============================================================================
- #works most of the time
--TMAKE_LIBS = -lxmms -L/sw/lib -lglib
--INCLUDEPATH = /usr/include/xmms /usr/lib/glib/include /usr/include/glib-1.2\
-- /sw/include/xmms /sw/lib/glib/include /sw/include/glib-1.2 /sw/include/qt
-+TMAKE_LIBS = -L@X11BASE@/lib -L@LOCALBASE@/lib @XMMSLIBS@
-+INCLUDEPATH = @X11BASE@/include @LOCALBASE@/include @XMMSINCS@
-
- #mac os x using fink
- #TMAKE_LIBS = -lxmms -L/sw/lib -lglib
diff --git a/audio/lplayer/pkg-plist b/audio/lplayer/pkg-plist
index c2a33bd36f2a..c7c0de2f4ec9 100644
--- a/audio/lplayer/pkg-plist
+++ b/audio/lplayer/pkg-plist
@@ -1,17 +1,21 @@
-bin/lplayer
-lib/lplayer/go.png
-lib/lplayer/go32.png
-lib/lplayer/lplayer-bin
-lib/lplayer/lplayericon.png
-lib/lplayer/lplayerlogo.png
-lib/lplayer/lplayerlogo2.png
-lib/lplayer/lplayerlogo3.png
-lib/lplayer/next.png
-lib/lplayer/play.png
-lib/lplayer/previous.png
-lib/lplayer/ratedown.png
-lib/lplayer/ratedown32.png
-lib/lplayer/rateup.png
-lib/lplayer/rateup32.png
-lib/lplayer/stop.png
-@dirrm lib/lplayer
+bin/longplayer
+bin/lplayer-bin
+share/lplayer/images/genre.png
+share/lplayer/images/go.png
+share/lplayer/images/go32.png
+share/lplayer/images/lplayericon.png
+share/lplayer/images/lplayerlogo.png
+share/lplayer/images/lplayerlogo2.png
+share/lplayer/images/lplayerlogo3.png
+share/lplayer/images/next.png
+share/lplayer/images/play.png
+share/lplayer/images/playnow.png
+share/lplayer/images/previous.png
+share/lplayer/images/queue.png
+share/lplayer/images/ratedown.png
+share/lplayer/images/ratedown32.png
+share/lplayer/images/rateup.png
+share/lplayer/images/rateup32.png
+share/lplayer/images/stop.png
+@dirrm share/lplayer/images
+@dirrm share/lplayer