aboutsummaryrefslogtreecommitdiff
path: root/audio/lv2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-31 20:40:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-31 20:40:43 +0000
commitfac48329edda2f4b9339e03247c672fca06f0796 (patch)
tree049c1844c3713b910de6977eb8c5ae092b480676 /audio/lv2
parent2588a1a9a20d267acc89cdf71e61583ba41cf7e3 (diff)
downloadports-fac48329edda2f4b9339e03247c672fca06f0796.tar.gz
ports-fac48329edda2f4b9339e03247c672fca06f0796.zip
Notes
Diffstat (limited to 'audio/lv2')
-rw-r--r--audio/lv2/Makefile45
-rw-r--r--audio/lv2/distinfo3
-rw-r--r--audio/lv2/files/patch-pkgconf30
-rw-r--r--audio/lv2/pkg-descr6
-rw-r--r--audio/lv2/pkg-plist205
5 files changed, 289 insertions, 0 deletions
diff --git a/audio/lv2/Makefile b/audio/lv2/Makefile
new file mode 100644
index 000000000000..71bec60ea88e
--- /dev/null
+++ b/audio/lv2/Makefile
@@ -0,0 +1,45 @@
+# Created by: Michael Beer <beerml@sigma6audio.de>
+# $FreeBSD$
+
+PORTNAME= lv2
+PORTVERSION= 1.14.0
+CATEGORIES= audio
+MASTER_SITES= http://lv2plug.in/spec/
+
+MAINTAINER= beerml@sigma6audio.de
+COMMENT= Open standard for audio plugins (successor to LADSPA)
+
+LICENSE= MIT ISCL
+LICENSE_COMB= multi
+# Only lv2specgen.py is under MIT
+LICENSE_FILE_ISCL= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}rdflib>0:textproc/py-rdflib
+
+CONFLICTS_INSTALL= lv2core
+
+USES= python shebangfix tar:bzip2 waf
+SHEBANG_FILES= lv2specgen/lv2specgen.py
+
+OPTIONS_DEFINE= DOXYGEN EXAMPLES
+OPTIONS_SUB= yes
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ ${PYTHON_PKGNAMEPREFIX}rdflib>0:textproc/py-rdflib
+DOXYGEN_CONFIGURE_ON= --docs
+DOXYGEN_PORTDOCS= *
+
+EXAMPLES_CONFIGURE_OFF= --no-plugins
+EXAMPLES_LIB_DEPENDS= libsndfile.so:audio/libsndfile
+EXAMPLES_USES= pkgconfig
+EXAMPLES_USE= GNOME=cairo,gtk20
+EXAMPLES_CONFIGURE_ENV= CC='${CC} -Wl,--as-needed' # Gtk deps
+
+post-install:
+# Waf doesn't have built-in strip support
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/${PORTNAME} \
+ -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/audio/lv2/distinfo b/audio/lv2/distinfo
new file mode 100644
index 000000000000..35ebc33a22b8
--- /dev/null
+++ b/audio/lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475763856
+SHA256 (lv2-1.14.0.tar.bz2) = b8052683894c04efd748c81b95dd065d274d4e856c8b9e58b7c3da3db4e71d32
+SIZE (lv2-1.14.0.tar.bz2) = 386438
diff --git a/audio/lv2/files/patch-pkgconf b/audio/lv2/files/patch-pkgconf
new file mode 100644
index 000000000000..30144576d0c0
--- /dev/null
+++ b/audio/lv2/files/patch-pkgconf
@@ -0,0 +1,30 @@
+Waf doesn't support changing pkg-config data install path
+
+--- wscript.orig 2016-09-20 01:34:12 UTC
++++ wscript
+@@ -400,7 +400,7 @@ def build(bld):
+ bld(features = 'subst',
+ source = 'lv2.pc.in',
+ target = 'lv2.pc',
+- install_path = '${LIBDIR}/pkgconfig',
++ install_path = '${LIBDIR}data/pkgconfig',
+ PREFIX = bld.env.PREFIX,
+ INCLUDEDIR = bld.env.INCLUDEDIR,
+ VERSION = VERSION)
+--- lv2/lv2plug.in/ns/lv2core/wscript.orig 2016-09-10 13:54:00 UTC
++++ lv2/lv2plug.in/ns/lv2core/wscript
+@@ -52,7 +52,13 @@ def build(bld):
+ bld.install_files('${LV2DIR}/lv2core.lv2', 'lv2.h')
+
+ # Pkgconfig file
+- autowaf.build_pc(bld, 'LV2CORE', LV2CORE_VERSION, '', [])
++ bld(features = 'subst',
++ source = 'lv2core.pc.in',
++ target = 'lv2core.pc',
++ install_path = '${LIBDIR}data/pkgconfig',
++ PREFIX = bld.env.PREFIX,
++ INCLUDEDIR = bld.env.INCLUDEDIR,
++ VERSION = LV2CORE_VERSION)
+
+ # URI-like header include
+ include_dir = os.path.join(bld.env['INCLUDEDIR'], 'lv2/lv2plug.in/ns')
diff --git a/audio/lv2/pkg-descr b/audio/lv2/pkg-descr
new file mode 100644
index 000000000000..e9b54ad6044f
--- /dev/null
+++ b/audio/lv2/pkg-descr
@@ -0,0 +1,6 @@
+LV2 is an open standard for audio plugins, used by hundreds of plugins
+and other projects. At its core, LV2 is a simple stable interface,
+accompanied by extensions which add functionality to support the needs
+of increasingly powerful audio software.
+
+WWW: http://lv2plug.in/
diff --git a/audio/lv2/pkg-plist b/audio/lv2/pkg-plist
new file mode 100644
index 000000000000..2f0bf292d03d
--- /dev/null
+++ b/audio/lv2/pkg-plist
@@ -0,0 +1,205 @@
+bin/lv2specgen.py
+include/lv2.h
+include/lv2/lv2plug.in/ns/ext/atom
+include/lv2/lv2plug.in/ns/ext/buf-size
+include/lv2/lv2plug.in/ns/ext/data-access
+include/lv2/lv2plug.in/ns/ext/dynmanifest
+include/lv2/lv2plug.in/ns/ext/event
+include/lv2/lv2plug.in/ns/ext/instance-access
+include/lv2/lv2plug.in/ns/ext/log
+include/lv2/lv2plug.in/ns/ext/midi
+include/lv2/lv2plug.in/ns/ext/morph
+include/lv2/lv2plug.in/ns/ext/options
+include/lv2/lv2plug.in/ns/ext/parameters
+include/lv2/lv2plug.in/ns/ext/patch
+include/lv2/lv2plug.in/ns/ext/port-groups
+include/lv2/lv2plug.in/ns/ext/port-props
+include/lv2/lv2plug.in/ns/ext/presets
+include/lv2/lv2plug.in/ns/ext/resize-port
+include/lv2/lv2plug.in/ns/ext/state
+include/lv2/lv2plug.in/ns/ext/time
+include/lv2/lv2plug.in/ns/ext/uri-map
+include/lv2/lv2plug.in/ns/ext/urid
+include/lv2/lv2plug.in/ns/ext/worker
+include/lv2/lv2plug.in/ns/extensions/ui
+include/lv2/lv2plug.in/ns/extensions/units
+include/lv2/lv2plug.in/ns/lv2core
+lib/lv2/atom.lv2/atom-test.c
+lib/lv2/atom.lv2/atom.h
+lib/lv2/atom.lv2/atom.ttl
+lib/lv2/atom.lv2/forge.h
+lib/lv2/atom.lv2/lv2-atom.doap.ttl
+lib/lv2/atom.lv2/manifest.ttl
+lib/lv2/atom.lv2/util.h
+lib/lv2/buf-size.lv2/buf-size.h
+lib/lv2/buf-size.lv2/buf-size.ttl
+lib/lv2/buf-size.lv2/lv2-buf-size.doap.ttl
+lib/lv2/buf-size.lv2/manifest.ttl
+lib/lv2/data-access.lv2/data-access.h
+lib/lv2/data-access.lv2/data-access.ttl
+lib/lv2/data-access.lv2/lv2-data-access.doap.ttl
+lib/lv2/data-access.lv2/manifest.ttl
+lib/lv2/dynmanifest.lv2/dynmanifest.h
+lib/lv2/dynmanifest.lv2/dynmanifest.ttl
+lib/lv2/dynmanifest.lv2/lv2-dynmanifest.doap.ttl
+lib/lv2/dynmanifest.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-amp.lv2/amp.so
+%%EXAMPLES%%lib/lv2/eg-amp.lv2/amp.ttl
+%%EXAMPLES%%lib/lv2/eg-amp.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-fifths.lv2/fifths.so
+%%EXAMPLES%%lib/lv2/eg-fifths.lv2/fifths.ttl
+%%EXAMPLES%%lib/lv2/eg-fifths.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-metro.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-metro.lv2/metro.so
+%%EXAMPLES%%lib/lv2/eg-metro.lv2/metro.ttl
+%%EXAMPLES%%lib/lv2/eg-midigate.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-midigate.lv2/midigate.so
+%%EXAMPLES%%lib/lv2/eg-midigate.lv2/midigate.ttl
+%%EXAMPLES%%lib/lv2/eg-params.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-params.lv2/params.so
+%%EXAMPLES%%lib/lv2/eg-params.lv2/params.ttl
+%%EXAMPLES%%lib/lv2/eg-sampler.lv2/click.wav
+%%EXAMPLES%%lib/lv2/eg-sampler.lv2/manifest.ttl
+%%EXAMPLES%%lib/lv2/eg-sampler.lv2/sampler.so
+%%EXAMPLES%%lib/lv2/eg-sampler.lv2/sampler.ttl
+%%EXAMPLES%%lib/lv2/eg-sampler.lv2/sampler_ui.so
+%%EXAMPLES%%lib/lv2/eg-scope.lv2/examploscope.so
+%%EXAMPLES%%lib/lv2/eg-scope.lv2/examploscope.ttl
+%%EXAMPLES%%lib/lv2/eg-scope.lv2/examploscope_ui.so
+%%EXAMPLES%%lib/lv2/eg-scope.lv2/manifest.ttl
+lib/lv2/event.lv2/event-helpers.h
+lib/lv2/event.lv2/event.h
+lib/lv2/event.lv2/event.ttl
+lib/lv2/event.lv2/lv2-event.doap.ttl
+lib/lv2/event.lv2/manifest.ttl
+lib/lv2/instance-access.lv2/instance-access.h
+lib/lv2/instance-access.lv2/instance-access.ttl
+lib/lv2/instance-access.lv2/lv2-instance-access.doap.ttl
+lib/lv2/instance-access.lv2/manifest.ttl
+lib/lv2/log.lv2/log.h
+lib/lv2/log.lv2/log.ttl
+lib/lv2/log.lv2/logger.h
+lib/lv2/log.lv2/lv2-log.doap.ttl
+lib/lv2/log.lv2/manifest.ttl
+lib/lv2/lv2core.lv2/lv2.h
+lib/lv2/lv2core.lv2/lv2core.doap.ttl
+lib/lv2/lv2core.lv2/lv2core.ttl
+lib/lv2/lv2core.lv2/manifest.ttl
+lib/lv2/midi.lv2/lv2-midi.doap.ttl
+lib/lv2/midi.lv2/manifest.ttl
+lib/lv2/midi.lv2/midi.h
+lib/lv2/midi.lv2/midi.ttl
+lib/lv2/morph.lv2/lv2-morph.doap.ttl
+lib/lv2/morph.lv2/manifest.ttl
+lib/lv2/morph.lv2/morph.h
+lib/lv2/morph.lv2/morph.ttl
+lib/lv2/options.lv2/lv2-options.doap.ttl
+lib/lv2/options.lv2/manifest.ttl
+lib/lv2/options.lv2/options.h
+lib/lv2/options.lv2/options.ttl
+lib/lv2/parameters.lv2/lv2-parameters.doap.ttl
+lib/lv2/parameters.lv2/manifest.ttl
+lib/lv2/parameters.lv2/parameters.h
+lib/lv2/parameters.lv2/parameters.ttl
+lib/lv2/patch.lv2/lv2-patch.doap.ttl
+lib/lv2/patch.lv2/manifest.ttl
+lib/lv2/patch.lv2/patch.h
+lib/lv2/patch.lv2/patch.ttl
+lib/lv2/port-groups.lv2/lv2-port-groups.doap.ttl
+lib/lv2/port-groups.lv2/manifest.ttl
+lib/lv2/port-groups.lv2/port-groups.h
+lib/lv2/port-groups.lv2/port-groups.ttl
+lib/lv2/port-props.lv2/lv2-port-props.doap.ttl
+lib/lv2/port-props.lv2/manifest.ttl
+lib/lv2/port-props.lv2/port-props.h
+lib/lv2/port-props.lv2/port-props.ttl
+lib/lv2/presets.lv2/lv2-presets.doap.ttl
+lib/lv2/presets.lv2/manifest.ttl
+lib/lv2/presets.lv2/presets.h
+lib/lv2/presets.lv2/presets.ttl
+lib/lv2/resize-port.lv2/lv2-resize-port.doap.ttl
+lib/lv2/resize-port.lv2/manifest.ttl
+lib/lv2/resize-port.lv2/resize-port.h
+lib/lv2/resize-port.lv2/resize-port.ttl
+lib/lv2/schemas.lv2/dcs.ttl
+lib/lv2/schemas.lv2/dct.ttl
+lib/lv2/schemas.lv2/doap.ttl
+lib/lv2/schemas.lv2/foaf.ttl
+lib/lv2/schemas.lv2/manifest.ttl
+lib/lv2/schemas.lv2/owl.ttl
+lib/lv2/schemas.lv2/rdf.ttl
+lib/lv2/schemas.lv2/rdfs.ttl
+lib/lv2/schemas.lv2/xsd.ttl
+lib/lv2/state.lv2/lv2-state.doap.ttl
+lib/lv2/state.lv2/manifest.ttl
+lib/lv2/state.lv2/state.h
+lib/lv2/state.lv2/state.ttl
+lib/lv2/time.lv2/lv2-time.doap.ttl
+lib/lv2/time.lv2/manifest.ttl
+lib/lv2/time.lv2/time.h
+lib/lv2/time.lv2/time.ttl
+lib/lv2/ui.lv2/lv2-ui.doap.ttl
+lib/lv2/ui.lv2/manifest.ttl
+lib/lv2/ui.lv2/ui.h
+lib/lv2/ui.lv2/ui.ttl
+lib/lv2/units.lv2/lv2-units.doap.ttl
+lib/lv2/units.lv2/manifest.ttl
+lib/lv2/units.lv2/units.h
+lib/lv2/units.lv2/units.ttl
+lib/lv2/uri-map.lv2/lv2-uri-map.doap.ttl
+lib/lv2/uri-map.lv2/manifest.ttl
+lib/lv2/uri-map.lv2/uri-map.h
+lib/lv2/uri-map.lv2/uri-map.ttl
+lib/lv2/urid.lv2/lv2-urid.doap.ttl
+lib/lv2/urid.lv2/manifest.ttl
+lib/lv2/urid.lv2/urid.h
+lib/lv2/urid.lv2/urid.ttl
+lib/lv2/worker.lv2/lv2-worker.doap.ttl
+lib/lv2/worker.lv2/manifest.ttl
+lib/lv2/worker.lv2/worker.h
+lib/lv2/worker.lv2/worker.ttl
+libdata/pkgconfig/lv2.pc
+libdata/pkgconfig/lv2core.pc
+%%DATADIR%%specgen/DTD/xhtml-attribs-1.mod
+%%DATADIR%%specgen/DTD/xhtml-base-1.mod
+%%DATADIR%%specgen/DTD/xhtml-basic-table-1.mod
+%%DATADIR%%specgen/DTD/xhtml-basic11-model-1.mod
+%%DATADIR%%specgen/DTD/xhtml-basic11.dtd
+%%DATADIR%%specgen/DTD/xhtml-bdo-1.mod
+%%DATADIR%%specgen/DTD/xhtml-blkphras-1.mod
+%%DATADIR%%specgen/DTD/xhtml-blkpres-1.mod
+%%DATADIR%%specgen/DTD/xhtml-blkstruct-1.mod
+%%DATADIR%%specgen/DTD/xhtml-charent-1.mod
+%%DATADIR%%specgen/DTD/xhtml-csismap-1.mod
+%%DATADIR%%specgen/DTD/xhtml-datatypes-1.mod
+%%DATADIR%%specgen/DTD/xhtml-edit-1.mod
+%%DATADIR%%specgen/DTD/xhtml-events-1.mod
+%%DATADIR%%specgen/DTD/xhtml-form-1.mod
+%%DATADIR%%specgen/DTD/xhtml-framework-1.mod
+%%DATADIR%%specgen/DTD/xhtml-hypertext-1.mod
+%%DATADIR%%specgen/DTD/xhtml-image-1.mod
+%%DATADIR%%specgen/DTD/xhtml-inlphras-1.mod
+%%DATADIR%%specgen/DTD/xhtml-inlpres-1.mod
+%%DATADIR%%specgen/DTD/xhtml-inlstruct-1.mod
+%%DATADIR%%specgen/DTD/xhtml-inlstyle-1.mod
+%%DATADIR%%specgen/DTD/xhtml-inputmode-1.mod
+%%DATADIR%%specgen/DTD/xhtml-lat1.ent
+%%DATADIR%%specgen/DTD/xhtml-legacy-1.mod
+%%DATADIR%%specgen/DTD/xhtml-link-1.mod
+%%DATADIR%%specgen/DTD/xhtml-list-1.mod
+%%DATADIR%%specgen/DTD/xhtml-meta-1.mod
+%%DATADIR%%specgen/DTD/xhtml-object-1.mod
+%%DATADIR%%specgen/DTD/xhtml-param-1.mod
+%%DATADIR%%specgen/DTD/xhtml-pres-1.mod
+%%DATADIR%%specgen/DTD/xhtml-qname-1.mod
+%%DATADIR%%specgen/DTD/xhtml-script-1.mod
+%%DATADIR%%specgen/DTD/xhtml-special.ent
+%%DATADIR%%specgen/DTD/xhtml-ssismap-1.mod
+%%DATADIR%%specgen/DTD/xhtml-struct-1.mod
+%%DATADIR%%specgen/DTD/xhtml-style-1.mod
+%%DATADIR%%specgen/DTD/xhtml-symbol.ent
+%%DATADIR%%specgen/DTD/xhtml-table-1.mod
+%%DATADIR%%specgen/DTD/xhtml-target-1.mod
+%%DATADIR%%specgen/DTD/xhtml-text-1.mod
+%%DATADIR%%specgen/style.css
+%%DATADIR%%specgen/template.html