aboutsummaryrefslogtreecommitdiff
path: root/audio/mac
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-15 08:39:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-15 08:39:47 +0000
commit6cb0df921173007164fb58b331abaaa9ce6772ba (patch)
treefe4697b4e5a563e56b0c5c8e17e61ff9de5038bc /audio/mac
parent68ea2b0fa984898a62ff0c8d81be3eb297fd57d7 (diff)
downloadports-6cb0df921173007164fb58b331abaaa9ce6772ba.tar.gz
ports-6cb0df921173007164fb58b331abaaa9ce6772ba.zip
Notes
Diffstat (limited to 'audio/mac')
-rw-r--r--audio/mac/Makefile11
-rw-r--r--audio/mac/distinfo5
-rw-r--r--audio/mac/files/patch-long-pointers114
-rw-r--r--audio/mac/files/patch-src-MACLib-Assembly-Assembly.h11
-rw-r--r--audio/mac/files/patch-src-MACLib-MACLib.cpp36
-rw-r--r--audio/mac/files/patch-src-Shared-NoWindows.h22
-rw-r--r--audio/mac/pkg-plist1
7 files changed, 153 insertions, 47 deletions
diff --git a/audio/mac/Makefile b/audio/mac/Makefile
index eed9117bc9d9..d08940b64979 100644
--- a/audio/mac/Makefile
+++ b/audio/mac/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= mac
-PORTVERSION= 3.99.4
-PORTREVISION= 1
+PORTVERSION= 3.99.4.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mac-port
-DISTNAME= ${PORTNAME}-3.99-u4-linux
+DISTNAME= ${PORTNAME}-3.99-u4-b4
MAINTAINER= dieringe@zedat.fu-berlin.de
COMMENT= Monkey's Audio lossless audio (de)compressor
@@ -19,11 +18,10 @@ COMMENT= Monkey's Audio lossless audio (de)compressor
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+= --enable-backward
-WRKSRC= ${WRKDIR}/mac-3.99-u4
-
INSTALLS_SHLIB= yes
# does not compile on sparc64
@@ -35,4 +33,7 @@ NOT_FOR_ARCHS= sparc64
IGNORE= does not compile on 4.x due to missing multibyte string functions in libc
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-s -O3||' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/audio/mac/distinfo b/audio/mac/distinfo
index cc6d0ad4689e..cfb41ee9889a 100644
--- a/audio/mac/distinfo
+++ b/audio/mac/distinfo
@@ -1,2 +1,3 @@
-MD5 (mac-3.99-u4-linux.tar.gz) = 3012a9c7e33da1dcc06350065b2b984a
-SIZE (mac-3.99-u4-linux.tar.gz) = 410412
+MD5 (mac-3.99-u4-b4.tar.gz) = 7eab2b9cc4bb696452d6c147976294b5
+SHA256 (mac-3.99-u4-b4.tar.gz) = 707e03533ccf66adbbc5bae1f97d98804882af57fdfee6238320f56a53a6639d
+SIZE (mac-3.99-u4-b4.tar.gz) = 435442
diff --git a/audio/mac/files/patch-long-pointers b/audio/mac/files/patch-long-pointers
new file mode 100644
index 000000000000..167c8929508f
--- /dev/null
+++ b/audio/mac/files/patch-long-pointers
@@ -0,0 +1,114 @@
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.cpp
+--- src/MACLib/APEDecompress.cpp Sun Jul 3 16:31:35 2005
++++ src/MACLib/APEDecompress.cpp Mon Nov 28 02:05:18 2005
+@@ -23,7 +23,7 @@
+ }
+
+ // get format information
+- GetInfo(APE_INFO_WAVEFORMATEX, (int) &m_wfeInput);
++ GetInfo(APE_INFO_WAVEFORMATEX, (long) &m_wfeInput);
+ m_nBlockAlign = GetInfo(APE_INFO_BLOCK_ALIGN);
+
+ // initialize other stuff
+@@ -367,7 +367,7 @@
+ /*****************************************************************************************
+ Get information from the decompressor
+ *****************************************************************************************/
+-int CAPEDecompress::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
++int CAPEDecompress::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
+ {
+ int nRetVal = 0;
+ BOOL bHandled = TRUE;
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.h mac/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.h
+--- src/MACLib/APEDecompress.h Thu Mar 10 13:36:25 2005
++++ src/MACLib/APEDecompress.h Mon Nov 28 02:05:37 2005
+@@ -22,7 +22,7 @@
+ int GetData(char * pBuffer, int nBlocks, int * pBlocksRetrieved);
+ int Seek(int nBlockOffset);
+
+- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
++ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
+
+ protected:
+
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEInfo.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APEInfo.cpp
+--- src/MACLib/APEInfo.cpp Mon Nov 28 02:15:38 2005
++++ src/MACLib/APEInfo.cpp Mon Nov 28 02:13:29 2005
+@@ -129,7 +129,7 @@
+ /*****************************************************************************************
+ Primary query function
+ *****************************************************************************************/
+-int CAPEInfo::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
++int CAPEInfo::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
+ {
+ int nRetVal = -1;
+
+@@ -254,7 +254,7 @@
+ }
+ else
+ {
+- WAVEFORMATEX wfeFormat; GetInfo(APE_INFO_WAVEFORMATEX, (int) &wfeFormat, 0);
++ WAVEFORMATEX wfeFormat; GetInfo(APE_INFO_WAVEFORMATEX, (long) &wfeFormat, 0);
+ WAVE_HEADER WAVHeader; FillWaveHeader(&WAVHeader, m_APEFileInfo.nWAVDataBytes, &wfeFormat,
+ m_APEFileInfo.nWAVTerminatingBytes);
+ memcpy(pBuffer, &WAVHeader, sizeof(WAVE_HEADER));
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEInfo.h mac/work/mac-3.99-u4-b4/src/MACLib/APEInfo.h
+--- src/MACLib/APEInfo.h Thu Mar 10 13:36:25 2005
++++ src/MACLib/APEInfo.h Mon Nov 28 02:13:35 2005
+@@ -82,7 +82,7 @@
+ virtual ~CAPEInfo();
+
+ // query for information
+- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
++ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
+
+ private:
+
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APESimple.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APESimple.cpp
+--- src/MACLib/APESimple.cpp Thu Mar 10 13:36:25 2005
++++ src/MACLib/APESimple.cpp Mon Nov 28 02:00:57 2005
+@@ -291,7 +291,7 @@
+ if (spAPEDecompress == NULL || nFunctionRetVal != ERROR_SUCCESS) throw(nFunctionRetVal);
+
+ // get the input format
+- THROW_ON_ERROR(spAPEDecompress->GetInfo(APE_INFO_WAVEFORMATEX, (int) &wfeInput))
++ THROW_ON_ERROR(spAPEDecompress->GetInfo(APE_INFO_WAVEFORMATEX, (long) &wfeInput))
+
+ // allocate space for the header
+ spTempBuffer.Assign(new unsigned char [spAPEDecompress->GetInfo(APE_INFO_WAV_HEADER_BYTES)], TRUE);
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/MACLib.h mac/work/mac-3.99-u4-b4/src/MACLib/MACLib.h
+--- src/MACLib/MACLib.h Tue May 31 10:02:27 2005
++++ src/MACLib/MACLib.h Mon Nov 28 02:06:30 2005
+@@ -259,7 +259,7 @@
+ // int nParam2
+ // generic parameter... usage is listed in APE_DECOMPRESS_FIELDS
+ //////////////////////////////////////////////////////////////////////////////////////////////
+- virtual int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0) = 0;
++ virtual int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0) = 0;
+ };
+
+ /*************************************************************************************************
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.cpp mac/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.cpp
+--- src/MACLib/Old/APEDecompressOld.cpp Fri Mar 11 13:23:37 2005
++++ src/MACLib/Old/APEDecompressOld.cpp Mon Nov 28 02:11:44 2005
+@@ -165,7 +165,7 @@
+ return ERROR_SUCCESS;
+ }
+
+-int CAPEDecompressOld::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
++int CAPEDecompressOld::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
+ {
+ int nRetVal = 0;
+ BOOL bHandled = TRUE;
+diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.h mac/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.h
+--- src/MACLib/Old/APEDecompressOld.h Thu Mar 10 13:36:26 2005
++++ src/MACLib/Old/APEDecompressOld.h Mon Nov 28 02:11:54 2005
+@@ -13,7 +13,7 @@
+ int GetData(char * pBuffer, int nBlocks, int * pBlocksRetrieved);
+ int Seek(int nBlockOffset);
+
+- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
++ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
+
+ protected:
+
diff --git a/audio/mac/files/patch-src-MACLib-Assembly-Assembly.h b/audio/mac/files/patch-src-MACLib-Assembly-Assembly.h
deleted file mode 100644
index c9123d059239..000000000000
--- a/audio/mac/files/patch-src-MACLib-Assembly-Assembly.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/MACLib/Assembly/Assembly.h.orig Wed May 12 06:35:56 2004
-+++ src/MACLib/Assembly/Assembly.h Mon Aug 9 20:26:40 2004
-@@ -6,7 +6,7 @@
- void Adapt(short * pM, const short * pAdapt, int nDirection, int nOrder);
- int CalculateDotProduct(const short * pA, const short * pB, int nOrder);
- BOOL GetMMXAvailable();
--};
-+}
-
- #endif // #ifndef APE_ASSEMBLY_H
-
diff --git a/audio/mac/files/patch-src-MACLib-MACLib.cpp b/audio/mac/files/patch-src-MACLib-MACLib.cpp
index 386142cb0e5e..01ee0a50d942 100644
--- a/audio/mac/files/patch-src-MACLib-MACLib.cpp
+++ b/audio/mac/files/patch-src-MACLib-MACLib.cpp
@@ -1,20 +1,20 @@
---- src/MACLib/MACLib.cpp.orig Wed May 12 08:56:22 2004
-+++ src/MACLib/MACLib.cpp Mon Aug 9 20:27:19 2004
+--- src/MACLib/MACLib.cpp.orig Wed May 4 15:35:33 2005
++++ src/MACLib/MACLib.cpp Mon Nov 28 01:45:59 2005
@@ -62,7 +62,7 @@
- pExtension--;
-
- // take the appropriate action (based on the extension)
-- if (wcsicmp(pExtension, L".apl") == 0)
-+ if (wcscmp(pExtension, L".apl") == 0)
- {
- // "link" file (.apl linked large APE file)
- CAPELink APELink(pFilename);
+ pExtension--;
+
+ // take the appropriate action (based on the extension)
+- if (wcsicmp(pExtension, L".apl") == 0)
++ if (wcscmp(pExtension, L".apl") == 0)
+ {
+ // "link" file (.apl linked large APE file)
+ CAPELink APELink(pFilename);
@@ -72,7 +72,7 @@
- nStartBlock = APELink.GetStartBlock(); nFinishBlock = APELink.GetFinishBlock();
- }
- }
-- else if ((wcsicmp(pExtension, L".mac") == 0) || (wcsicmp(pExtension, L".ape") == 0))
-+ else if ((wcscmp(pExtension, L".mac") == 0) || (wcscmp(pExtension, L".ape") == 0))
- {
- // plain .ape file
- pAPEInfo = new CAPEInfo(&nErrorCode, pFilename);
+ nStartBlock = APELink.GetStartBlock(); nFinishBlock = APELink.GetFinishBlock();
+ }
+ }
+- else if ((wcsicmp(pExtension, L".mac") == 0) || (wcsicmp(pExtension, L".ape") == 0))
++ else if ((wcscmp(pExtension, L".mac") == 0) || (wcscmp(pExtension, L".ape") == 0))
+ {
+ // plain .ape file
+ pAPEInfo = new CAPEInfo(&nErrorCode, pFilename);
diff --git a/audio/mac/files/patch-src-Shared-NoWindows.h b/audio/mac/files/patch-src-Shared-NoWindows.h
index ca15ca2be98b..7051635da62c 100644
--- a/audio/mac/files/patch-src-Shared-NoWindows.h
+++ b/audio/mac/files/patch-src-Shared-NoWindows.h
@@ -1,11 +1,11 @@
---- src/Shared/NoWindows.h.orig Wed May 12 09:00:17 2004
-+++ src/Shared/NoWindows.h Mon Aug 9 20:28:34 2004
-@@ -50,7 +50,7 @@
-
- #include <locale.h>
-
--#define _FPOSOFF(fp) ((long)(fp).__pos)
-+#define _FPOSOFF(fp) ((long)(fp))
- #define MAX_PATH 260
-
- #ifndef _WAVEFORMATEX_
+--- src/Shared/NoWindows.h.orig Tue May 3 10:05:03 2005
++++ src/Shared/NoWindows.h Mon Nov 28 01:47:00 2005
+@@ -65,7 +65,7 @@
+
+ #include <locale.h>
+
+-#define _FPOSOFF(fp) ((long)(fp).__pos)
++#define _FPOSOFF(fp) ((long)(fp))
+ #define MAX_PATH 260
+
+ #ifndef _WAVEFORMATEX_
diff --git a/audio/mac/pkg-plist b/audio/mac/pkg-plist
index 7b1c8a5bb243..a4075504ce3a 100644
--- a/audio/mac/pkg-plist
+++ b/audio/mac/pkg-plist
@@ -18,6 +18,7 @@ include/mac/APELink.h
include/mac/APETag.h
include/mac/MACLib.h
include/mac/MACProgressHelper.h
+include/mac/MACUtils.h
@dirrm include/mac
lib/libmac.so.2
lib/libmac.so