aboutsummaryrefslogtreecommitdiff
path: root/audio/mad/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-02-20 18:51:09 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-02-20 18:51:09 +0000
commit9a1e7ef84830d882008da3aa9022e7cf93e006d8 (patch)
treebbbdc0aae4ec947a350e6e572d96a20885fbd7f4 /audio/mad/Makefile
parent4ccf9150498b9685caaca979994d14334968e661 (diff)
o update mad to 0.12.5beta.
o respect CFLAGS. o add LIB_DEPENDS to gettext and use shared libintl. o add USE_LIBTOOL to supress installing ltlibs. o add CONFIGURE_ARGS tweak to get the fast and accurate output(I believe). o obsolete patch-ab(integrated). Approved by: maintainer
Notes
Notes: svn path=/head/; revision=38524
Diffstat (limited to 'audio/mad/Makefile')
-rw-r--r--audio/mad/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/audio/mad/Makefile b/audio/mad/Makefile
index f2de6995a3de..f02312fe7ca5 100644
--- a/audio/mad/Makefile
+++ b/audio/mad/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mad
-PORTVERSION= 0.12.1b
+PORTVERSION= 0.12.5b
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.mars.org/pub/mpeg/
@@ -14,16 +14,15 @@ MASTER_SITE_SUBDIR= mad
MAINTAINER= jason-freebsd@mastaler.com
-GNU_CONFIGURE= yes
-# This port is not CFLAGS SAFE, something like CFLAGS="-O -Os"
-# breaks configure and configure likes to use -O2 instead of
-# trusting the system. We'll have it use -O instead of -O*
-# since this configure requires a standard and this has
-# been the system standard
-CONFIGURE_ENV= CFLAGS="-O -pipe"
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
USE_GMAKE= yes
USE_LIBTOOL= yes
+LIBTOOLFILES= configure libmad/configure
+CONFIGURE_ARGS= --disable-debugging --enable-sso --enable-accuracy
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= abxtest.1 madplay.1
+MAN1= abxtest.1 madplay.1
.include <bsd.port.mk>