aboutsummaryrefslogtreecommitdiff
path: root/audio/mad
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2001-11-18 14:44:21 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2001-11-18 14:44:21 +0000
commit337b036e7e8a0f9c51825d5110f88cd43bd04151 (patch)
tree3bab3f8b6bce7fc702cc841cb1f00ff74aa54fe3 /audio/mad
parent2c64933b33414eaabe79895de6540d65e51fcfe1 (diff)
downloadports-337b036e7e8a0f9c51825d5110f88cd43bd04151.tar.gz
ports-337b036e7e8a0f9c51825d5110f88cd43bd04151.zip
Notes
Diffstat (limited to 'audio/mad')
-rw-r--r--audio/mad/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/audio/mad/Makefile b/audio/mad/Makefile
index 3872cc5f2d3c..d0397214775a 100644
--- a/audio/mad/Makefile
+++ b/audio/mad/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mad
PORTVERSION= 0.14.2b
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.mars.org/pub/mpeg/
@@ -16,11 +17,10 @@ MAINTAINER= jason@mastaler.com
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+WANT_ESOUND= yes
-USE_GMAKE= yes
USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
+INSTALLS_SHLIB= yes
LIBTOOLFILES= configure libmad/configure libid3tag/configure
CONFIGURE_ARGS= --enable-shared \
--disable-debugging \
@@ -31,4 +31,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= abxtest.1 madplay.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
+
+.include <bsd.port.post.mk>