aboutsummaryrefslogtreecommitdiff
path: root/audio/madplay/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 01:05:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 01:05:38 +0000
commit96ffab3c238fbce7434b75a6f3079308ab9396b9 (patch)
tree643da4498cb327f684df300b9a516eabdc1545f4 /audio/madplay/Makefile
parent402c1f8fdefee70e6ca7404a993b913ac8a27272 (diff)
downloadports-96ffab3c238fbce7434b75a6f3079308ab9396b9.tar.gz
ports-96ffab3c238fbce7434b75a6f3079308ab9396b9.zip
Notes
Diffstat (limited to 'audio/madplay/Makefile')
-rw-r--r--audio/madplay/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/audio/madplay/Makefile b/audio/madplay/Makefile
new file mode 100644
index 000000000000..a91652d639e5
--- /dev/null
+++ b/audio/madplay/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: madplay
+# Date created: 26 November 2003
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= madplay
+PORTVERSION= 0.15.0b
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://ftp.mars.org/pub/mpeg/
+MASTER_SITE_SUBDIR= mad
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Madplay MP3 player (part of MAD project)
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ mad.2:${PORTSDIR}/audio/libmad \
+ id3tag.2:${PORTSDIR}/audio/libid3tag
+
+WANT_GNOME= yes
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= abxtest.1 madplay.1
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+PKGNAMESUFFIX= -esound
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
+
+.include <bsd.port.post.mk>