aboutsummaryrefslogtreecommitdiff
path: root/audio/mehdiaplayer
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:26:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:26:54 +0000
commit2f60fe848df658b52032c2f7382d9b410a4482ee (patch)
tree8fa437c293cca74141eb6ffdcf7a4aeca25e4ece /audio/mehdiaplayer
parent7b4ad546cd755023d16c62465a99b96a39083cbe (diff)
downloadports-2f60fe848df658b52032c2f7382d9b410a4482ee.tar.gz
ports-2f60fe848df658b52032c2f7382d9b410a4482ee.zip
Notes
Diffstat (limited to 'audio/mehdiaplayer')
-rw-r--r--audio/mehdiaplayer/Makefile34
-rw-r--r--audio/mehdiaplayer/distinfo3
-rw-r--r--audio/mehdiaplayer/pkg-descr5
3 files changed, 42 insertions, 0 deletions
diff --git a/audio/mehdiaplayer/Makefile b/audio/mehdiaplayer/Makefile
new file mode 100644
index 000000000000..d5176d9a5fee
--- /dev/null
+++ b/audio/mehdiaplayer/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mehdiaplayer
+# Date created: 2009-11-12
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mehdiaplayer
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= A simple media player using Qt/Phonon
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build \
+ rcc_build phonon
+
+QMAKE_PRO= ${PORTNAME}.pro
+
+WRKSRC= ${WRKDIR}/dev
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/mehdiaplayer/distinfo b/audio/mehdiaplayer/distinfo
new file mode 100644
index 000000000000..4bf493c31efd
--- /dev/null
+++ b/audio/mehdiaplayer/distinfo
@@ -0,0 +1,3 @@
+MD5 (mehdiaplayer-0.2.tar.bz2) = 5144e5858f2075afe4d645c6943f509d
+SHA256 (mehdiaplayer-0.2.tar.bz2) = 6ccf8a05bcdca1eb1581ab3c45bbbe8cc43b1dabe1962c25d021d7343e2a17d5
+SIZE (mehdiaplayer-0.2.tar.bz2) = 64337
diff --git a/audio/mehdiaplayer/pkg-descr b/audio/mehdiaplayer/pkg-descr
new file mode 100644
index 000000000000..aaeb437a5d24
--- /dev/null
+++ b/audio/mehdiaplayer/pkg-descr
@@ -0,0 +1,5 @@
+An audio player inspired by Sonata.
+In fact, it's my first project with Qt, I developed it in order to apprehend the
+Qt framework.
+
+WWW: http://code.google.com/p/mehdiaplayer/