aboutsummaryrefslogtreecommitdiff
path: root/audio/mhwaveedit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-27 18:01:58 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-27 18:01:58 +0000
commit5e5ba15b63c1e06240e519b2da655161574d4e5a (patch)
tree3e1940c7d68ea453c678e0d3fb8290d87ec4229f /audio/mhwaveedit/Makefile
parent8a6c5769d92a4508961f01bcae9d25a94592442b (diff)
downloadports-5e5ba15b63c1e06240e519b2da655161574d4e5a.tar.gz
ports-5e5ba15b63c1e06240e519b2da655161574d4e5a.zip
Notes
Diffstat (limited to 'audio/mhwaveedit/Makefile')
-rw-r--r--audio/mhwaveedit/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index 6f4a328e1403..d510d6ac9023 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,21 +7,23 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.9
+PORTVERSION= 1.3.0
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical program for editing sound files
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
portaudio.0:${PORTSDIR}/audio/portaudio
USE_GNOME= gnomehack gnometarget gtk20
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-optimization --without-sdl
+CONFIGURE_ARGS= --disable-optimization --without-alsalib --without-sdl
PLIST_FILES= bin/mhwaveedit
@@ -29,6 +31,12 @@ PLIST_FILES= bin/mhwaveedit
CONFIGURE_ARGS+= --with-double-samples
.endif
+.if defined(WITH_JACK)
+LIB_DPENDS+= jack:${PORTSDIR}/audio/jack
+.else
+CONFIGURE_ARGS+= --without-jack
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "mhWaveEdit has the following tunable option:"
@@ -38,5 +46,11 @@ pre-everything::
@${ECHO_MSG} " processing (slows down program but may increase"
@${ECHO_MSG} " quality for 24/32-bit samplerates)"
@${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_JACK=yes"
+ @${ECHO_MSG} " Support JACK driver"
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/configure
.include <bsd.port.mk>