aboutsummaryrefslogtreecommitdiff
path: root/audio/mhwaveedit
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-27 14:46:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-27 14:46:45 +0000
commit7664565a22038237f227ff6d04eba569195324bf (patch)
treeaec161226d1cf34359fcde65f0298584d8dcdcc7 /audio/mhwaveedit
parentab40d3c7a11abaf1e146bf29f11efdc8fda2170f (diff)
downloadports-7664565a22038237f227ff6d04eba569195324bf.tar.gz
ports-7664565a22038237f227ff6d04eba569195324bf.zip
Notes
Diffstat (limited to 'audio/mhwaveedit')
-rw-r--r--audio/mhwaveedit/Makefile2
-rw-r--r--audio/mhwaveedit/distinfo2
-rw-r--r--audio/mhwaveedit/files/patch-src::datasource.c12
-rw-r--r--audio/mhwaveedit/files/patch-src::viewcache.c14
4 files changed, 14 insertions, 16 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index 93751a3d51d0..e6393cbc426f 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index a0484b74a657..0278cfae210e 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1 +1 @@
-MD5 (mhwaveedit-1.2.3.tar.gz) = 25fb4d7c03f52acda4dd523b7ce7662e
+MD5 (mhwaveedit-1.2.4.tar.gz) = 136507e084ef715481129e6c241b2d32
diff --git a/audio/mhwaveedit/files/patch-src::datasource.c b/audio/mhwaveedit/files/patch-src::datasource.c
new file mode 100644
index 000000000000..9213f316e593
--- /dev/null
+++ b/audio/mhwaveedit/files/patch-src::datasource.c
@@ -0,0 +1,12 @@
+--- src/datasource.c.orig Tue Dec 23 07:06:26 2003
++++ src/datasource.c Sat Dec 27 00:59:02 2003
+@@ -212,8 +212,8 @@
+
+ Datasource *datasource_byteswap(Datasource *source)
+ {
+- if (source == NULL) return NULL;
+ Datasource *ds;
++ if (source == NULL) return NULL;
+ ds = gtk_type_new(datasource_get_type());
+ ds->type = DATASOURCE_BYTESWAP;
+ memcpy(&(ds->format),&(source->format),sizeof(Dataformat));
diff --git a/audio/mhwaveedit/files/patch-src::viewcache.c b/audio/mhwaveedit/files/patch-src::viewcache.c
deleted file mode 100644
index a45dc8675c67..000000000000
--- a/audio/mhwaveedit/files/patch-src::viewcache.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/viewcache.c.orig Wed Jun 4 15:23:06 2003
-+++ src/viewcache.c Wed Jun 4 15:23:45 2003
-@@ -24,6 +24,11 @@
- #include "inifile.h"
- #include "main.h"
-
-+#ifndef HAVE_CEILL
-+# define ceill(x) ceil((double)(x))
-+# define HAVE_CEILL
-+#endif
-+
- /* How many columns to update (max) for each call to view_cache_update */
- #define PIXELS_PER_UPDATE 10
- #define GUINT32(x) ((guint32)x)