aboutsummaryrefslogtreecommitdiff
path: root/audio/mixxx/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-13 14:26:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-13 14:26:41 +0000
commitde8dbbfa7ffbc68b990662e15f68cdd7872b188d (patch)
treebdd06734334b3da9466add76e4eb2106485f0640 /audio/mixxx/Makefile
parent4a581ee73fee6aab41fde962d9c9ea72626dbecf (diff)
downloadports-de8dbbfa7ffbc68b990662e15f68cdd7872b188d.tar.gz
ports-de8dbbfa7ffbc68b990662e15f68cdd7872b188d.zip
Notes
Diffstat (limited to 'audio/mixxx/Makefile')
-rw-r--r--audio/mixxx/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index e3ce471afb5e..3259edb49e75 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= mixxx
-PORTVERSION= 1.3.2
+PORTVERSION= 1.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-${PORTVERSION}a${EXTRACT_SUFX}
MAINTAINER= jylefort@brutele.be
COMMENT= A DJ mixing application
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= samplerate:${PORTSDIR}/audio/libsamplerate \
portaudio:${PORTSDIR}/audio/portaudio \
@@ -32,24 +33,20 @@ CONFIGURE_WRKSRC= ${WRKSRC}/src
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
-CONFIGURE_ENV= QTDIR="${X11BASE}" \
- QMAKESPEC="freebsd-g++" \
- NOPORTDOCS="${NOPORTDOCS}"
+CONFIGURE_ENV= QTDIR="${X11BASE}" QMAKESPEC="freebsd-g++"
MAKE_ENV= QTDIR="${X11BASE}"
.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --prefix=${PREFIX}
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${REINPLACE_CMD} \
- -e 's|@LOCALBASE@|${LOCALBASE}|g' \
- -e 's|@X11BASE@|${X11BASE}|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ -e 's|/bin/bash|${LOCALBASE}&| ; \
+ s|$$QTDIR/bin/qmake|${LOCALBASE}/bin/qmake|g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} \
+ -e 's|system( ld|& -shared -L${LOCALBASE}/lib -L${X11BASE}/lib|' \
${CONFIGURE_WRKSRC}/check.qbas
.if !defined(NOPORTDOCS)