aboutsummaryrefslogtreecommitdiff
path: root/audio/mixxx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 09:38:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 09:38:09 +0000
commitf40f4381dbbeca19d5a3802f5f4955d93d768bda (patch)
treedfe994ab68480c0ef60d2f1c390610d92bdf9487 /audio/mixxx
parent170a76404d55c6d2aedb2547ffc29c0cf507899a (diff)
downloadports-f40f4381dbbeca19d5a3802f5f4955d93d768bda.tar.gz
ports-f40f4381dbbeca19d5a3802f5f4955d93d768bda.zip
Notes
Diffstat (limited to 'audio/mixxx')
-rw-r--r--audio/mixxx/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index e38283719179..81c9172743f7 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -29,10 +29,9 @@ LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
portaudio.2:${PORTSDIR}/audio/portaudio2 \
tag.1:${PORTSDIR}/audio/taglib
-OPTIONS= LAME "LAME MP3 audio encoder support" off \
- SHOUTCAST "Shoutcast Broadcasting" off \
- FAAD "FAAD AAC audio decoder plugin" off \
- WAVPACK "WavPack audio support plugin" off
+OPTIONS_DEFINE= LAME FAAD WAVPACK SHOUTCAST DOCS
+SHOUTCAST_DESC= Enable Shoutcast Broadcasting
+WAVPACK_DESC= Enable WavPack audio support plugin
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -48,18 +47,18 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
-.if defined(WITH_SHOUTCAST)
+.if ${PORT_OPTIONS:MSHOUTCAST}
LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
SCONS_ARGS+= shoutcast=1
.else
SCONS_ARGS+= shoutcast=0
.endif
-.if defined(WITH_FAAD)
+.if ${PORT_OPTIONS:MFAAD}
LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2
SCONS_ARGS+= faad=1
@@ -69,7 +68,7 @@ SCONS_ARGS+= faad=0
PLIST_SUB+= FAAD="@comment "
.endif
-.if defined(WITH_WAVPACK)
+.if ${PORT_OPTIONS:MWAVPACK}
LIB_DEPENDS+= wavpack.2:${PORTSDIR}/audio/wavpack
SCONS_ARGS+= wv=1
PLIST_SUB+= WAVPACK=""
@@ -91,7 +90,7 @@ post-patch:
post-install:
@${STRIP_CMD} ${PREFIX}/bin/mixxx
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in Mixxx-Manual.pdf README
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}