aboutsummaryrefslogtreecommitdiff
path: root/audio/moc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-29 11:25:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-29 11:25:04 +0000
commit4edc2395011b45dd2a5031e3fe71658411748b7c (patch)
treed5cf3684890420ac270194927bb13e3d5edd1556 /audio/moc
parentd8bcbcbd7ed233fb7e87e8fd56872c1ae34f0e69 (diff)
downloadports-4edc2395011b45dd2a5031e3fe71658411748b7c.tar.gz
ports-4edc2395011b45dd2a5031e3fe71658411748b7c.zip
Notes
Diffstat (limited to 'audio/moc')
-rw-r--r--audio/moc/Makefile1
-rw-r--r--audio/moc/files/patch-player.c15
-rw-r--r--audio/moc/files/patch-themes-yellow_red_theme10
3 files changed, 26 insertions, 0 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index fa10e190b633..d2c28eb720ee 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= moc
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.daper.net/pub/soft/moc/stable/
diff --git a/audio/moc/files/patch-player.c b/audio/moc/files/patch-player.c
new file mode 100644
index 000000000000..a43621a1bb76
--- /dev/null
+++ b/audio/moc/files/patch-player.c
@@ -0,0 +1,15 @@
+Index: player.c
+===================================================================
+--- player.c (revision 1478)
++++ player.c (working copy)
+@@ -615,7 +615,9 @@
+ }
+
+ already_decoded_time = precache.decoded_time;
+- bitrate_list = precache.bitrate_list;
++ bitrate_list_init (&bitrate_list);
++ bitrate_list.head = precache.bitrate_list.head;
++ bitrate_list.tail = precache.bitrate_list.tail;
+
+ /* don't free list elements when reseting precache */
+ precache.bitrate_list.head = NULL;
diff --git a/audio/moc/files/patch-themes-yellow_red_theme b/audio/moc/files/patch-themes-yellow_red_theme
new file mode 100644
index 000000000000..9224e1bffe14
--- /dev/null
+++ b/audio/moc/files/patch-themes-yellow_red_theme
@@ -0,0 +1,10 @@
+--- themes/yellow_red_theme.orig Wed Jun 15 18:56:44 2005
++++ themes/yellow_red_theme Fri Jul 29 10:29:23 2005
+@@ -1,7 +1,6 @@
+ # Yellow/Red theme - mostly Yellow. By Morten Grunnet Buhl
+ # Doesn't work on terminals when underline is not supported (like Linux console)
+
+-border = red default
+ background = red default
+ frame = red default
+ window_title = yellow default underline,dim