aboutsummaryrefslogtreecommitdiff
path: root/audio/mp-player/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-29 17:31:14 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-29 17:31:14 +0000
commit8ef903640a256ab43495f880f2948117d54f4261 (patch)
tree303da4e7865822665cc0cced7094de15de85c61e /audio/mp-player/Makefile
parente75a8ad50f8f7569f4cc38b652cffd6188607c8b (diff)
downloadports-8ef903640a256ab43495f880f2948117d54f4261.tar.gz
ports-8ef903640a256ab43495f880f2948117d54f4261.zip
Notes
Diffstat (limited to 'audio/mp-player/Makefile')
-rw-r--r--audio/mp-player/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/mp-player/Makefile b/audio/mp-player/Makefile
new file mode 100644
index 000000000000..877520ac8ba7
--- /dev/null
+++ b/audio/mp-player/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mp-player
+# Date created: 26 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp-player
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://mp.waw.cx/ \
+ http://critical.ch/distfiles/
+DISTNAME= mp-current
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A curses based module tracker using libmikmod
+
+LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lmikmod -pthread -lncurses -lpanel
+DEFINES= -D_REENTRANT
+
+WRKSRC= ${WRKDIR}/mp-beta-06
+
+PLIST_FILES= bin/mp-player
+
+post-patch:
+ @${RM} ${WRKSRC}/mp
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${DEFINES} ${WRKSRC}/mp.c -o ${WRKSRC}/mp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mp ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>