aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-06 00:00:51 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-06 00:00:51 +0000
commit8d7d65b160b136c06c3244322094d8f1701102e7 (patch)
tree8d8b85dc501df243e53e9f26fbcb8969d4f3eb79 /audio/mp3blaster/Makefile
parentaec686abf2dac549ada1df87b352dbe461d827db (diff)
Add mp3blaster.
mp3blaster is an interactive text-based mp3player. One of the unique features of this player is the ability to divide a playlist into groups (albums). Therefore, the play order can be adjusted with great flexibility. PR: 15902 Submitted by: Michael Vasilenko <acid@stu.cn.ua>
Notes
Notes: svn path=/head/; revision=24464
Diffstat (limited to 'audio/mp3blaster/Makefile')
-rw-r--r--audio/mp3blaster/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
new file mode 100644
index 000000000000..3accd6461343
--- /dev/null
+++ b/audio/mp3blaster/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mp3blaster
+# Version required: 2.0b16
+# Date created: 5 January 2000
+# Whom: Michael Vasilenko <acid@stu.cn.ua>
+#
+# $FreeBSD$
+#
+
+DISTNAME= mp3blaster-2.0b16
+CATEGORIES= audio
+MASTER_SITES= ftp://mud.stack.nl/pub/mp3blaster/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/players
+
+MAINTAINER= ports@FreeBSD.org
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400010
+LIB_DEPENDS= ncurses.4:${PORTSDIR}/devel/ncurses
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "CPPFLAGS=-DPTHREADED_MPEG=1 -D_REENTERANT=1" \
+ "LDFLAGS=-pthread"
+USE_GMAKE= yes
+MAN1= mp3blaster.1 nmixer.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/mp3blaster ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/mp3tag ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/nmixer/nmixer ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/mp3blaster.1 ${PREFIX}/man/man1
+ @ ${INSTALL_MAN} ${WRKSRC}/nmixer.1 ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>