aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-01-31 15:20:00 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-01-31 15:20:00 +0000
commit8bfeab738a25b3a38a3b75ae98d29a7194a25bbd (patch)
treeeaed0c3ffd4e05815408b93de4542ccdd751ca9f /audio/mp3blaster/Makefile
parent8dceac46e10e4166b9150f408593069f9b400e11 (diff)
Notes
Diffstat (limited to 'audio/mp3blaster/Makefile')
-rw-r--r--audio/mp3blaster/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 82c361172136..05fffb72f005 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mp3blaster
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +18,7 @@ USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
@@ -57,8 +58,19 @@ CONFIGURE_ARGS+= --without-oggvorbis
LIB_DEPENDS+= vorbisfile.4:${PORTSDIR}/audio/libvorbis
.endif
-post-extract:
- @${FIND} ${WRKSRC} -name "getopt*" -delete
+.if !defined(WITHOUT_SDL)
+CONFIGURE_ARGS+= --with-sdl
+USE_SDL= yes
+.else
+CONFIGURE_ARGS+= --without-sdl
+.endif
+
+.if ${HAVE_GNOME:Mesound} != ""
+USE_GNOME+= esound
+CONFIGURE_ARGS+= --with-esd
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure