aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-05 20:59:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-05 20:59:22 +0000
commite5a9a72f660e0402da873a0d5cc19be984c940b1 (patch)
treedd76b4c45b3d1cde4085200c7b797c34f3e2b1d8 /audio/mp3blaster
parent56ff16ada7d196d2194dbbff22eabbfb28df6677 (diff)
downloadports-e5a9a72f660e0402da873a0d5cc19be984c940b1.tar.gz
ports-e5a9a72f660e0402da873a0d5cc19be984c940b1.zip
Notes
Diffstat (limited to 'audio/mp3blaster')
-rw-r--r--audio/mp3blaster/Makefile57
-rw-r--r--audio/mp3blaster/distinfo2
-rw-r--r--audio/mp3blaster/files/patch-ab38
-rw-r--r--audio/mp3blaster/files/patch-mpegsound::oggplayer.cc14
-rw-r--r--audio/mp3blaster/files/patch-nmixer::Makefile.in45
-rw-r--r--audio/mp3blaster/files/patch-nmixer_getopt.h14
-rw-r--r--audio/mp3blaster/files/patch-src::Makefile.in64
-rw-r--r--audio/mp3blaster/files/patch-src::main.cc14
-rw-r--r--audio/mp3blaster/files/patch-src_getopt.h14
9 files changed, 177 insertions, 85 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index d236659ea21d..d0fc53e3312d 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -6,40 +6,61 @@
#
PORTNAME= mp3blaster
-PORTVERSION= 3.1.3
+PORTVERSION= 3.2.0
CATEGORIES= audio
MASTER_SITES= http://www.stack.nl/~brama/mp3blaster/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= MP3 console ncurses-based player
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
+
+MAN1= mp3blaster.1 nmixer.1 splay.1
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400010
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}" \
- --without-sidplay
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbisfile.3:${PORTSDIR}/audio/libvorbis
+.if defined(WITH_LIRC)
+LIB_DEPENDS+= lirc_client.0:${PORTSDIR}/comms/lirc
+CONFIGURE_ARGS+= --with-lirc
+.endif
+
+.if !defined(WITHOUT_SIDPLAY)
+LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
.else
-CONFIGURE_ARGS+= --without-oggvorbis
+CONFIGURE_ARGS+= --without-sidplay
.endif
-MAN1= mp3blaster.1 nmixer.1 splay.1
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --without-oggvorbis
+.else
+LIB_DEPENDS+= vorbisfile.3:${PORTSDIR}/audio/libvorbis
+.endif
-.if !defined(WITHOUT_VORBIS)
pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "You can disable support for Ogg Vorbis by defining WITHOUT_VORBIS."
- @${ECHO_MSG}
-.endif
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "MP3Blaster has the following tunable option(s):"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_LIRC=yes Turns on LIRC support"
+ @${ECHO_MSG} " WITHOUT_SIDPLAY=yes Turns on Sidplayer support"
+ @${ECHO_MSG} " WITHOUT_VORBIS=yes Turns off Ogg Vorbis support"
+ @${ECHO_MSG} ""
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "getopt*" -delete
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/audio/mp3blaster/distinfo b/audio/mp3blaster/distinfo
index b33c5c66fbc6..77d3fba3615b 100644
--- a/audio/mp3blaster/distinfo
+++ b/audio/mp3blaster/distinfo
@@ -1 +1 @@
-MD5 (mp3blaster-3.1.3.tar.gz) = 38beb6a5648cbca4ec87ee14b0982283
+MD5 (mp3blaster-3.2.0.tar.gz) = d01a36de2ebb5b4f7c407ae6cc7668b1
diff --git a/audio/mp3blaster/files/patch-ab b/audio/mp3blaster/files/patch-ab
deleted file mode 100644
index 395c80d5da01..000000000000
--- a/audio/mp3blaster/files/patch-ab
+++ /dev/null
@@ -1,38 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Sun Oct 20 19:04:59 2002
-+++ configure Thu Sep 25 23:33:55 2003
-@@ -1970,7 +1970,11 @@
-
-
- if test "$INCLUDEPTHREAD" = 1 ; then
-- if test "$FREEBSD" = 1 -o "$OPENBSD" = 1 ; then
-+ if test "${PTHREAD_CFLAGS}${PTHREAD_LIBS}" != ""; then
-+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
-+ CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}"
-+ LIBS="${LIBS} ${PTHREAD_LIBS}"
-+ elif test "$OPENBSD" = 1 ; then
- LDFLAGS="$LDFLAGS -pthread"
- else
- echo $ac_n "checking for main in -lpthread""... $ac_c" 1>&6
-@@ -2420,7 +2424,7 @@
- fi
- done
-
--for ac_hdr in sys/soundcard.h machine/soundcard.h soundcard.h getopt.h
-+for ac_hdr in sys/soundcard.h machine/soundcard.h soundcard.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -3704,7 +3708,9 @@
-
-
- if test "$INCLUDEPTHREAD" = 1 ; then
-- if test "$FREEBSD" = 1 -o "$OPENBSD" = 1 ; then
-+ if test "${PTHREAD_CFLAGS}${PTHREAD_LIBS}" != ""; then
-+ : already handled
-+ elif test "$OPENBSD" = 1 ; then
- LDFLAGS="$LDFLAGS -pthread"
- cat >> confdefs.h <<\EOF
- #define _THREAD_SAFE 1
diff --git a/audio/mp3blaster/files/patch-mpegsound::oggplayer.cc b/audio/mp3blaster/files/patch-mpegsound::oggplayer.cc
new file mode 100644
index 000000000000..60cbb8ccb4f5
--- /dev/null
+++ b/audio/mp3blaster/files/patch-mpegsound::oggplayer.cc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- mpegsound/oggplayer.cc.orig Mon Dec 1 21:30:07 2003
++++ mpegsound/oggplayer.cc Mon Dec 1 21:30:17 2003
+@@ -23,7 +23,7 @@
+ /* Martijn suggests that big endiannes is already taken care of in the rawplayer
+ * class.
+ */
+-#if 0 && defined(WORDS_BIGENDIAN)
++#if defined(WORDS_BIGENDIAN)
+ bigendian = 1;
+ #endif
+ //TODO: On what hardware is data unsigned, and how do I know?
diff --git a/audio/mp3blaster/files/patch-nmixer::Makefile.in b/audio/mp3blaster/files/patch-nmixer::Makefile.in
new file mode 100644
index 000000000000..4e9c777a5c9e
--- /dev/null
+++ b/audio/mp3blaster/files/patch-nmixer::Makefile.in
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- nmixer/Makefile.in.orig Sat Nov 29 05:07:25 2003
++++ nmixer/Makefile.in Sat Dec 6 00:13:22 2003
+@@ -87,9 +87,8 @@
+ LDADD = @LIBNMIXER@ @NCURSES_LIBS@
+ INCLUDES = -I/usr/include/ncurses -I$(srcdir) -I$(includedir)
+ noinst_LIBRARIES = libnmixer.a
+-libnmixer_a_SOURCES = nmixer.cc mixers.cc ossmixer.cc nasmixer.cc nmixer.h getopt.c getopt1.c getopt.h
+-
+-CXXFLAGS = @NAS_CFLAGS@
++libnmixer_a_SOURCES = nmixer.cc mixers.cc ossmixer.cc nasmixer.cc nmixer.h
++CXXFLAGS = @CXXFLAGS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
+@@ -105,8 +104,7 @@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+ libnmixer_a_LIBADD =
+-libnmixer_a_OBJECTS = nmixer.o mixers.o ossmixer.o nasmixer.o getopt.o \
+-getopt1.o
++libnmixer_a_OBJECTS = nmixer.o mixers.o ossmixer.o nasmixer.o
+ AR = ar
+ PROGRAMS = $(bin_PROGRAMS)
+
+@@ -250,13 +248,11 @@
+ || cp -p $$d/$$file $(distdir)/$$file || :; \
+ fi; \
+ done
+-getopt.o: getopt.c ../config.h
+-getopt1.o: getopt1.c ../config.h getopt.h
+-main.o: main.cc nmixer.h ../config.h getopt.h
+-mixers.o: mixers.cc nmixer.h ../config.h getopt.h
++main.o: main.cc nmixer.h ../config.h
++mixers.o: mixers.cc nmixer.h ../config.h
+ nasmixer.o: nasmixer.cc
+-nmixer.o: nmixer.cc nmixer.h ../config.h getopt.h
+-ossmixer.o: ossmixer.cc nmixer.h ../config.h getopt.h
++nmixer.o: nmixer.cc nmixer.h ../config.h
++ossmixer.o: ossmixer.cc nmixer.h ../config.h
+
+ info-am:
+ info: info-am
diff --git a/audio/mp3blaster/files/patch-nmixer_getopt.h b/audio/mp3blaster/files/patch-nmixer_getopt.h
deleted file mode 100644
index 27840b3d7d39..000000000000
--- a/audio/mp3blaster/files/patch-nmixer_getopt.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- nmixer/getopt.h.orig Thu Mar 6 00:37:11 2003
-+++ nmixer/getopt.h Thu Mar 6 00:37:21 2003
-@@ -103,7 +103,7 @@
- errors, only prototype getopt for the GNU C library. */
- extern int getopt (int argc, char *const *argv, const char *shortopts);
- #else /* not __GNU_LIBRARY__ */
--extern int getopt ();
-+/* extern int getopt (); */
- #endif /* __GNU_LIBRARY__ */
- extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);
diff --git a/audio/mp3blaster/files/patch-src::Makefile.in b/audio/mp3blaster/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..7d6b133058aa
--- /dev/null
+++ b/audio/mp3blaster/files/patch-src::Makefile.in
@@ -0,0 +1,64 @@
+
+$FreeBSD$
+
+--- src/Makefile.in.orig Sat Nov 29 05:07:27 2003
++++ src/Makefile.in Sat Dec 6 00:10:10 2003
+@@ -83,7 +83,7 @@
+
+ bin_PROGRAMS = mp3blaster mp3tag splay
+ #bin_PROGRAMS = mp3blaster mp3tag
+-mp3blaster_SOURCES = fileman.cc main.cc scrollwin.cc getopt.c getopt1.c fileman.h genretab.h getopt.h id3parse.cc id3parse.h mp3blaster.h global.cc global.h config.cc scrollwin.h winitem.cc winitem.h mp3win.cc mp3win.h mp3item.cc mp3item.h keybindings.h history.cc history.h getinput.cc getinput.h interface.cc interface.h
++mp3blaster_SOURCES = fileman.cc main.cc scrollwin.cc fileman.h genretab.h id3parse.cc id3parse.h mp3blaster.h global.cc global.h config.cc scrollwin.h winitem.cc winitem.h mp3win.cc mp3win.h mp3item.cc mp3item.h keybindings.h history.cc history.h getinput.cc getinput.h interface.cc interface.h
+
+ splay_SOURCES = splay.cc splay.h splay_common.cc
+ splay_DEPENDENCIES = ../mpegsound/libmpegsound.a
+@@ -110,9 +110,8 @@
+ X_LIBS = @X_LIBS@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+-mp3blaster_OBJECTS = fileman.o main.o scrollwin.o getopt.o getopt1.o \
+-id3parse.o global.o config.o winitem.o mp3win.o mp3item.o history.o \
+-getinput.o interface.o
++mp3blaster_OBJECTS = fileman.o main.o scrollwin.o id3parse.o global.o \
++config.o winitem.o mp3win.o mp3item.o history.o getinput.o interface.o
+ mp3blaster_LDFLAGS =
+ mp3tag_OBJECTS = id3parse.o mp3tag.o
+ mp3tag_LDFLAGS =
+@@ -249,30 +248,28 @@
+ fi; \
+ done
+ config.o: config.cc mp3blaster.h ../config.h global.h
+-fileman.o: fileman.cc mp3blaster.h ../config.h getopt.h fileman.h \
++fileman.o: fileman.cc mp3blaster.h ../config.h fileman.h \
+ scrollwin.h winitem.h global.h
+ getinput.o: getinput.cc getinput.h ../config.h
+-getopt.o: getopt.c ../config.h
+-getopt1.o: getopt1.c ../config.h getopt.h
+-global.o: global.cc getopt.h mp3blaster.h ../config.h id3parse.h
+-history.o: history.cc ../config.h history.h getopt.h
++global.o: global.cc mp3blaster.h ../config.h id3parse.h
++history.o: history.cc ../config.h history.h
+ id3parse.o: id3parse.cc id3parse.h genretab.h
+ interface.o: interface.cc
+-main.o: main.cc ../config.h history.h getopt.h mp3blaster.h global.h \
++main.o: main.cc ../config.h history.h mp3blaster.h global.h \
+ scrollwin.h winitem.h mp3win.h fileman.h \
+ ../mpegsound/mpegsound.h ../nmixer/nmixer.h keybindings.h \
+ getinput.h
+ mp3item.o: mp3item.cc mp3item.h winitem.h mp3blaster.h ../config.h \
+ mp3win.h scrollwin.h
+-mp3tag.o: mp3tag.cc mp3blaster.h ../config.h getopt.h \
++mp3tag.o: mp3tag.cc mp3blaster.h ../config.h \
+ ../mpegsound/mpegsound.h id3parse.h
+ mp3win.o: mp3win.cc mp3win.h scrollwin.h mp3blaster.h ../config.h \
+ winitem.h mp3item.h
+ scrollwin.o: scrollwin.cc mp3blaster.h ../config.h global.h scrollwin.h \
+ winitem.h
+-splay.o: splay.cc ../config.h getopt.h ../mpegsound/mpegsound.h splay.h
++splay.o: splay.cc ../config.h ../mpegsound/mpegsound.h splay.h
+ splay_common.o: splay_common.cc ../config.h ../mpegsound/mpegsound.h \
+- getopt.h splay.h
++ splay.h
+ winitem.o: winitem.cc mp3blaster.h ../config.h scrollwin.h winitem.h
+
+ info-am:
diff --git a/audio/mp3blaster/files/patch-src::main.cc b/audio/mp3blaster/files/patch-src::main.cc
new file mode 100644
index 000000000000..382c2f396446
--- /dev/null
+++ b/audio/mp3blaster/files/patch-src::main.cc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/main.cc.orig Wed Sep 10 06:22:55 2003
++++ src/main.cc Sat Dec 6 00:36:09 2003
+@@ -413,7 +413,7 @@
+ { 0, 0, 0, 0}
+ };
+
+- c = getopt_long_only(argc, argv, "28a:c:df:hl:m:no:p:qRr:s:t:v", long_options,
++ c = getopt_long(argc, argv, "28a:c:df:hl:m:no:p:qRr:s:t:v", long_options,
+ &long_index);
+
+ if (c == EOF)
diff --git a/audio/mp3blaster/files/patch-src_getopt.h b/audio/mp3blaster/files/patch-src_getopt.h
deleted file mode 100644
index 2e54ef719e36..000000000000
--- a/audio/mp3blaster/files/patch-src_getopt.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/getopt.h.orig Sun Jul 21 13:54:13 2002
-+++ src/getopt.h Sun Jul 21 13:54:27 2002
-@@ -103,7 +103,7 @@
- errors, only prototype getopt for the GNU C library. */
- extern int getopt (int argc, char *const *argv, const char *shortopts);
- #else /* not __GNU_LIBRARY__ */
--extern int getopt ();
-+/* extern int getopt (); */
- #endif /* __GNU_LIBRARY__ */
- extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);