aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-06 00:00:51 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-06 00:00:51 +0000
commit8d7d65b160b136c06c3244322094d8f1701102e7 (patch)
tree8d8b85dc501df243e53e9f26fbcb8969d4f3eb79 /audio/mp3blaster
parentaec686abf2dac549ada1df87b352dbe461d827db (diff)
downloadports-8d7d65b160b136c06c3244322094d8f1701102e7.tar.gz
ports-8d7d65b160b136c06c3244322094d8f1701102e7.zip
Notes
Diffstat (limited to 'audio/mp3blaster')
-rw-r--r--audio/mp3blaster/Makefile35
-rw-r--r--audio/mp3blaster/distinfo1
-rw-r--r--audio/mp3blaster/pkg-comment1
-rw-r--r--audio/mp3blaster/pkg-descr9
-rw-r--r--audio/mp3blaster/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
new file mode 100644
index 000000000000..3accd6461343
--- /dev/null
+++ b/audio/mp3blaster/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mp3blaster
+# Version required: 2.0b16
+# Date created: 5 January 2000
+# Whom: Michael Vasilenko <acid@stu.cn.ua>
+#
+# $FreeBSD$
+#
+
+DISTNAME= mp3blaster-2.0b16
+CATEGORIES= audio
+MASTER_SITES= ftp://mud.stack.nl/pub/mp3blaster/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/players
+
+MAINTAINER= ports@FreeBSD.org
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400010
+LIB_DEPENDS= ncurses.4:${PORTSDIR}/devel/ncurses
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "CPPFLAGS=-DPTHREADED_MPEG=1 -D_REENTERANT=1" \
+ "LDFLAGS=-pthread"
+USE_GMAKE= yes
+MAN1= mp3blaster.1 nmixer.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/mp3blaster ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/mp3tag ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/nmixer/nmixer ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/mp3blaster.1 ${PREFIX}/man/man1
+ @ ${INSTALL_MAN} ${WRKSRC}/nmixer.1 ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/audio/mp3blaster/distinfo b/audio/mp3blaster/distinfo
new file mode 100644
index 000000000000..38fd8ce6fe07
--- /dev/null
+++ b/audio/mp3blaster/distinfo
@@ -0,0 +1 @@
+MD5 (mp3blaster-2.0b16.tar.gz) = 0943fbfa0789b4c1e48075da8b4b3d86
diff --git a/audio/mp3blaster/pkg-comment b/audio/mp3blaster/pkg-comment
new file mode 100644
index 000000000000..0b85511d4af8
--- /dev/null
+++ b/audio/mp3blaster/pkg-comment
@@ -0,0 +1 @@
+MP3 console ncurses-based player
diff --git a/audio/mp3blaster/pkg-descr b/audio/mp3blaster/pkg-descr
new file mode 100644
index 000000000000..a194a2a881a3
--- /dev/null
+++ b/audio/mp3blaster/pkg-descr
@@ -0,0 +1,9 @@
+mp3blaster is an interactive text-based mp3player. One of
+the unique features of this player is the ability to divide
+a playlist into groups (albums). Therefore, the play order
+can be adjusted with great flexibility.
+
+WWW: http://www.stack.nl/~brama/mp3blaster.html
+
+- Michael Vasilenko
+acid@stu.cn.ua
diff --git a/audio/mp3blaster/pkg-plist b/audio/mp3blaster/pkg-plist
new file mode 100644
index 000000000000..27ee68babcd0
--- /dev/null
+++ b/audio/mp3blaster/pkg-plist
@@ -0,0 +1,3 @@
+bin/mp3blaster
+bin/nmixer
+bin/mp3tag