aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-09-26 00:07:08 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-09-26 00:07:08 +0000
commit0c9ab2f044526669e158e90b63ae0a2752488aec (patch)
treecd5ba6422dd64ce437fbfc3ef3a5fa724bcffb8e /audio/mp3blaster
parent041a18a3f7b8afa067a251e64d9d34dac0b1e5d8 (diff)
downloadports-0c9ab2f044526669e158e90b63ae0a2752488aec.tar.gz
ports-0c9ab2f044526669e158e90b63ae0a2752488aec.zip
Notes
Diffstat (limited to 'audio/mp3blaster')
-rw-r--r--audio/mp3blaster/Makefile4
-rw-r--r--audio/mp3blaster/files/patch-ab30
2 files changed, 30 insertions, 4 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 971a410192c9..7dd2b9b49c45 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -23,7 +23,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}" \
--without-sidplay
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.if !defined(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbisfile.3:${PORTSDIR}/audio/libvorbis
diff --git a/audio/mp3blaster/files/patch-ab b/audio/mp3blaster/files/patch-ab
index eeb1af95c042..395c80d5da01 100644
--- a/audio/mp3blaster/files/patch-ab
+++ b/audio/mp3blaster/files/patch-ab
@@ -1,9 +1,22 @@
$FreeBSD$
---- configure.orig Sat Mar 16 21:00:46 2002
-+++ configure Sun Jul 21 17:31:27 2002
-@@ -2652,7 +2652,7 @@
+--- configure.orig Sun Oct 20 19:04:59 2002
++++ configure Thu Sep 25 23:33:55 2003
+@@ -1970,7 +1970,11 @@
+
+
+ if test "$INCLUDEPTHREAD" = 1 ; then
+- if test "$FREEBSD" = 1 -o "$OPENBSD" = 1 ; then
++ if test "${PTHREAD_CFLAGS}${PTHREAD_LIBS}" != ""; then
++ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
++ CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}"
++ LIBS="${LIBS} ${PTHREAD_LIBS}"
++ elif test "$OPENBSD" = 1 ; then
+ LDFLAGS="$LDFLAGS -pthread"
+ else
+ echo $ac_n "checking for main in -lpthread""... $ac_c" 1>&6
+@@ -2420,7 +2424,7 @@
fi
done
@@ -12,3 +25,14 @@ $FreeBSD$
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
+@@ -3704,7 +3708,9 @@
+
+
+ if test "$INCLUDEPTHREAD" = 1 ; then
+- if test "$FREEBSD" = 1 -o "$OPENBSD" = 1 ; then
++ if test "${PTHREAD_CFLAGS}${PTHREAD_LIBS}" != ""; then
++ : already handled
++ elif test "$OPENBSD" = 1 ; then
+ LDFLAGS="$LDFLAGS -pthread"
+ cat >> confdefs.h <<\EOF
+ #define _THREAD_SAFE 1