aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3encode
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-01-25 10:40:18 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-01-25 10:40:18 +0000
commiteb87635fb6fa4d9d07880883bc35272ad9289462 (patch)
tree015d29e32374ecfde2c8fbd2d7963129d033bc38 /audio/mp3encode
parente6ed043c2a7b2c1fa5dd2816835bf00b0812fbb3 (diff)
Notes
Diffstat (limited to 'audio/mp3encode')
-rw-r--r--audio/mp3encode/Makefile54
-rw-r--r--audio/mp3encode/distinfo3
-rw-r--r--audio/mp3encode/files/patch-aa19
-rw-r--r--audio/mp3encode/files/patch-ab230
-rw-r--r--audio/mp3encode/files/patch-ac19
-rw-r--r--audio/mp3encode/files/patch-ad19
-rw-r--r--audio/mp3encode/pkg-descr24
7 files changed, 0 insertions, 368 deletions
diff --git a/audio/mp3encode/Makefile b/audio/mp3encode/Makefile
deleted file mode 100644
index 20acff96b105..000000000000
--- a/audio/mp3encode/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# New ports collection makefile for: mp3encode
-# Date created: 5th August, 1998
-# Whom: Joel Sutton <jsutton@bbcon.com.au>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mp3encode
-PORTVERSION= 1.10
-PORTREVISION= 2
-CATEGORIES= audio
-MASTER_SITES= ftp://ftp.sunet.se/pub/multimedia/Berkeley/mpeg2/conformance-bitstreams/audio/mpeg2/software/technical_report/
-DISTNAME= dist10
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= MPEG layer I, II and III audio file encoder
-
-RESTRICTED= Condition is not clear
-DEPRECATED= is unfetchable and has no homepage
-EXPIRATION_DATE= 2006-12-27
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/lsf/encoder
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKE_ARGS+= CC="${CC}"
-ALL_TARGET= encode
-
-# Directories and extra files
-#
-TABLE_LIB= ${PREFIX}/share/mp3encode
-TABLE_LIB_SED= ${TABLE_LIB:S/\//\\\//g}
-TABLE_FILES= 1cb0 1cb1 1cb2 1cb4 1cb5 1cb6 1th0 1th1 1th2 1th4 1th5 1th6 \
- 2cb0 2cb1 2cb2 2cb4 2cb5 2cb6 2th0 2th1 2th2 2th4 2th5 2th6 \
- absthr_0 absthr_1 absthr_2 alloc_0 alloc_1 alloc_2 alloc_3 \
- alloc_4 dewindow enwindow huffcode huffdec psy_data
-
-PLIST_FILES= bin/encode ${TABLE_FILES:S|^|share/mp3encode/|}
-PLIST_DIRS= share/mp3encode
-
-post-patch:
- @${ECHO_MSG} "===> Specifing table path "
- @${REINPLACE_CMD} -e "s/ZAP/${TABLE_LIB_SED}/g" ${WRKSRC}/common.h
-
-do-install:
- @${ECHO_MSG} "===> Installing binaries"
- ${INSTALL_PROGRAM} ${WRKSRC}/encode ${PREFIX}/bin
- @${ECHO_MSG} "===> Installing table files"
- -${MKDIR} ${TABLE_LIB}
-.for file in ${TABLE_FILES}
- ${INSTALL_DATA} ${WRKSRC}/tables/${file} ${TABLE_LIB}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/audio/mp3encode/distinfo b/audio/mp3encode/distinfo
deleted file mode 100644
index b0b3a5eaa61a..000000000000
--- a/audio/mp3encode/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (dist10.tar.gz) = 62cee8daa6041b8a2d0a9a1ef18163b4
-SHA256 (dist10.tar.gz) = 3c22fa4dac080d03519843ac4fcc42c0a925cc6e744b5b4ffec33b3eff4397c4
-SIZE (dist10.tar.gz) = 523930
diff --git a/audio/mp3encode/files/patch-aa b/audio/mp3encode/files/patch-aa
deleted file mode 100644
index 489c6e436e00..000000000000
--- a/audio/mp3encode/files/patch-aa
+++ /dev/null
@@ -1,19 +0,0 @@
-*** Makefile.in.orig Wed Jan 22 18:43:12 1997
---- Makefile.in Wed Nov 8 05:12:34 2000
-***************
-*** 40,46 ****
-
- NINT_SWITCH = @NINTSW@
-
-! CC_SWITCHES = -g -O -DUNIX -DBS_FORMAT=BINARY $(NINT_SWITCH) -DNDEBUG
-
- PGM = encode
-
---- 40,46 ----
-
- NINT_SWITCH = @NINTSW@
-
-! CC_SWITCHES = @CFLAGS@ -DUNIX -DBS_FORMAT=BINARY $(NINT_SWITCH) -DNDEBUG
-
- PGM = encode
-
diff --git a/audio/mp3encode/files/patch-ab b/audio/mp3encode/files/patch-ab
deleted file mode 100644
index d1013f8324d5..000000000000
--- a/audio/mp3encode/files/patch-ab
+++ /dev/null
@@ -1,230 +0,0 @@
-*** musicin.c.orig Wed Jan 22 18:43:17 1997
---- musicin.c Sun Apr 11 01:44:39 1999
-***************
-*** 161,167 ****
-
- do {
- printf("Enter PCM input file name <required>: ");
-! gets(original_file_name);
- if (original_file_name[0] == NULL_CHAR)
- printf("PCM input file name is required.\n");
- } while (original_file_name[0] == NULL_CHAR);
---- 161,168 ----
-
- do {
- printf("Enter PCM input file name <required>: ");
-! fgets(original_file_name,255,stdin);
-! original_file_name[strlen(original_file_name) - 1] = NULL_CHAR;
- if (original_file_name[0] == NULL_CHAR)
- printf("PCM input file name is required.\n");
- } while (original_file_name[0] == NULL_CHAR);
-***************
-*** 182,189 ****
- original_file_name, DFLT_EXT);
- #endif
-
-! gets(encoded_file_name);
-!
- if (encoded_file_name[0] == NULL_CHAR) {
- #ifdef MS_DOS
- strcpy(encoded_file_name, temp_str);
---- 183,191 ----
- original_file_name, DFLT_EXT);
- #endif
-
-! fgets(encoded_file_name,255,stdin);
-! encoded_file_name[strlen(encoded_file_name) - 1] = NULL_CHAR;
-!
- if (encoded_file_name[0] == NULL_CHAR) {
- #ifdef MS_DOS
- strcpy(encoded_file_name, temp_str);
-***************
-*** 227,233 ****
- else { /* Not using Audio IFF sound file headers. */
-
- printf("What is the sampling frequency? <44100>[Hz]: ");
-! gets(t);
- freq = atol(t);
- switch (freq) {
- case 48000 : info->sampling_frequency = 1;
---- 229,236 ----
- else { /* Not using Audio IFF sound file headers. */
-
- printf("What is the sampling frequency? <44100>[Hz]: ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- freq = atol(t);
- switch (freq) {
- case 48000 : info->sampling_frequency = 1;
-***************
-*** 268,274 ****
-
- printf("Which layer do you want to use?\n");
- printf("Available: Layer (1), Layer (<2>), Layer (3): ");
-! gets(t);
- switch(*t){
- case '1': info->lay = 1; printf(">>> Using Layer %s\n",t); break;
- case '2': info->lay = 2; printf(">>> Using Layer %s\n",t); break;
---- 271,278 ----
-
- printf("Which layer do you want to use?\n");
- printf("Available: Layer (1), Layer (<2>), Layer (3): ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- switch(*t){
- case '1': info->lay = 1; printf(">>> Using Layer %s\n",t); break;
- case '2': info->lay = 2; printf(">>> Using Layer %s\n",t); break;
-***************
-*** 279,285 ****
- printf("Which mode do you want?\n");
- printf("Available: (<s>)tereo, (j)oint stereo, ");
- printf("(d)ual channel, s(i)ngle Channel: ");
-! gets(t);
- switch(*t){
- case 's':
- case 'S':
---- 283,290 ----
- printf("Which mode do you want?\n");
- printf("Available: (<s>)tereo, (j)oint stereo, ");
- printf("(d)ual channel, s(i)ngle Channel: ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- switch(*t){
- case 's':
- case 'S':
-***************
-*** 308,314 ****
- }
-
- printf("Which psychoacoustic model do you want to use? <1>: ");
-! gets(t);
- model = atoi(t);
- if (model > 2 || model < 1) {
- printf(">>> Default model 1 selected\n");
---- 313,320 ----
- }
-
- printf("Which psychoacoustic model do you want to use? <1>: ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- model = atoi(t);
- if (model > 2 || model < 1) {
- printf(">>> Default model 1 selected\n");
-***************
-*** 322,328 ****
- /* set default bitrate to highest allowed, which is index 14 */
- brt = bitrate[info->version][info->lay-1][14];
- printf( "What is the total bitrate? <%u>[kbps]: ", brt );
-! gets( t );
- brt = atoi( t );
- if ( brt == 0 )
- j = 15;
---- 328,335 ----
- /* set default bitrate to highest allowed, which is index 14 */
- brt = bitrate[info->version][info->lay-1][14];
- printf( "What is the total bitrate? <%u>[kbps]: ", brt );
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- brt = atoi( t );
- if ( brt == 0 )
- j = 15;
-***************
-*** 348,354 ****
-
- printf("What type of de-emphasis should the decoder use?\n");
- printf("Available: (<n>)one, (5)0/15 microseconds, (c)citt j.17: ");
-! gets(t);
- if (*t != 'n' && *t != '5' && *t != 'c') {
- printf(">>> Using default no de-emphasis\n");
- info->emphasis = 0;
---- 355,362 ----
-
- printf("What type of de-emphasis should the decoder use?\n");
- printf("Available: (<n>)one, (5)0/15 microseconds, (c)citt j.17: ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t != 'n' && *t != '5' && *t != 'c') {
- printf(">>> Using default no de-emphasis\n");
- info->emphasis = 0;
-***************
-*** 363,369 ****
- /* Start 2. Part changes for CD Ver 3.2; jsp; 22-Aug-1991 */
-
- printf("Do you want to set the private bit? (y/<n>): ");
-! gets(t);
- if (*t == 'y' || *t == 'Y') info->extension = 1;
- else info->extension = 0;
- if(info->extension) printf(">>> Private bit set\n");
---- 371,378 ----
- /* Start 2. Part changes for CD Ver 3.2; jsp; 22-Aug-1991 */
-
- printf("Do you want to set the private bit? (y/<n>): ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t == 'y' || *t == 'Y') info->extension = 1;
- else info->extension = 0;
- if(info->extension) printf(">>> Private bit set\n");
-***************
-*** 372,399 ****
- /* End changes for CD Ver 3.2; jsp; 22-Aug-1991 */
-
- printf("Do you want error protection? (y/<n>): ");
-! gets(t);
- if (*t == 'y' || *t == 'Y') info->error_protection = TRUE;
- else info->error_protection = FALSE;
- if(info->error_protection) printf(">>> Error protection used\n");
- else printf(">>> Error protection not used\n");
-
- printf("Is the material copyrighted? (y/<n>): ");
-! gets(t);
- if (*t == 'y' || *t == 'Y') info->copyright = 1;
- else info->copyright = 0;
- if(info->copyright) printf(">>> Copyrighted material\n");
- else printf(">>> Material not copyrighted\n");
-
- printf("Is this the original? (y/<n>): ");
-! gets(t);
- if (*t == 'y' || *t == 'Y') info->original = 1;
- else info->original = 0;
- if(info->original) printf(">>> Original material\n");
- else printf(">>> Material not original\n");
-
- printf("Do you wish to exit (last chance before encoding)? (y/<n>): ");
-! gets(t);
- if (*t == 'y' || *t == 'Y') exit(0);
- }
-
---- 381,413 ----
- /* End changes for CD Ver 3.2; jsp; 22-Aug-1991 */
-
- printf("Do you want error protection? (y/<n>): ");
-! fgets(t,255,stdin);
-!
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t == 'y' || *t == 'Y') info->error_protection = TRUE;
- else info->error_protection = FALSE;
- if(info->error_protection) printf(">>> Error protection used\n");
- else printf(">>> Error protection not used\n");
-
- printf("Is the material copyrighted? (y/<n>): ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t == 'y' || *t == 'Y') info->copyright = 1;
- else info->copyright = 0;
- if(info->copyright) printf(">>> Copyrighted material\n");
- else printf(">>> Material not copyrighted\n");
-
- printf("Is this the original? (y/<n>): ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t == 'y' || *t == 'Y') info->original = 1;
- else info->original = 0;
- if(info->original) printf(">>> Original material\n");
- else printf(">>> Material not original\n");
-
- printf("Do you wish to exit (last chance before encoding)? (y/<n>): ");
-! fgets(t,255,stdin);
-! t[strlen(t) - 1] = NULL_CHAR;
- if (*t == 'y' || *t == 'Y') exit(0);
- }
-
diff --git a/audio/mp3encode/files/patch-ac b/audio/mp3encode/files/patch-ac
deleted file mode 100644
index 5d09cc01663b..000000000000
--- a/audio/mp3encode/files/patch-ac
+++ /dev/null
@@ -1,19 +0,0 @@
-*** common.h.orig Wed Jan 22 20:43:13 1997
---- common.h Thu May 21 14:12:52 1998
-***************
-*** 93,99 ****
- #endif
-
- #ifdef UNIX
-! #define TABLES_PATH "tables" /* to find data files */
- /* name of environment variable holding path of table files */
- #define MPEGTABENV "MPEGTABLES"
- #define PATH_SEPARATOR "/" /* how to build paths */
---- 93,99 ----
- #endif
-
- #ifdef UNIX
-! #define TABLES_PATH "ZAP" /* to find data files */
- /* name of environment variable holding path of table files */
- #define MPEGTABENV "MPEGTABLES"
- #define PATH_SEPARATOR "/" /* how to build paths */
diff --git a/audio/mp3encode/files/patch-ad b/audio/mp3encode/files/patch-ad
deleted file mode 100644
index 41bf19dbb7b8..000000000000
--- a/audio/mp3encode/files/patch-ad
+++ /dev/null
@@ -1,19 +0,0 @@
-*** encoder.h.orig Fri Jul 3 20:20:57 1998
---- encoder.h Fri Jul 3 20:21:56 1998
-***************
-*** 62,68 ****
-
- #define DFLT_LAY 2 /* default encoding layer is II */
- #define DFLT_MOD 's' /* default mode is stereo */
-! #define DFLT_PSY 1 /* default psych model is 1 */
- #define DFLT_SFQ 44.1 /* default input sampling rate is 44.1 kHz */
- #define DFLT_EMP 'n' /* default de-emphasis is none */
- #define DFLT_EXT ".mpg" /* default output file extension */
---- 62,68 ----
-
- #define DFLT_LAY 2 /* default encoding layer is II */
- #define DFLT_MOD 's' /* default mode is stereo */
-! #define DFLT_PSY 2 /* default psych model is 1 */
- #define DFLT_SFQ 44.1 /* default input sampling rate is 44.1 kHz */
- #define DFLT_EMP 'n' /* default de-emphasis is none */
- #define DFLT_EXT ".mpg" /* default output file extension */
diff --git a/audio/mp3encode/pkg-descr b/audio/mp3encode/pkg-descr
deleted file mode 100644
index d4accf700faa..000000000000
--- a/audio/mp3encode/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
- The mp3encode package encodes MPEG layer I, II and III audio files.
-This is the reference implementation so don't expect spectacular performance.
- Driving encode is pretty simple although it may take some practice to
-work out an optimal compression rate. AIFF files are the only type of files that
-seem to work with this version so you may need to install a port like "sox" to
-convert your file types. I use the "nas" port to record and edit all of my audio
-files but so long as you have a valid AIFF file it shouldn't matter what you
-use.
- Although the source code includes a decoder I have decided not to port
-it because we already have a couple of top class MPEG decoders in the ports
-collection.
- Psychoacoustic model 2 is the only supported model in layer III
-encoding. A bit-rate of 128 kilobits/s is adequate for most forms of music but
-you may need to turn down the compression to 160 kilobits/s if the music is
-particularly atmospheric.
- Vocal spoken recordings are best encoded using a 32 kilobits/s bit-rate
-with layer II (layer III makes you sound like a Dalek under digital water) with
-a 32 kHz sample rate in mono. Using this method I have managed to get about 5
-minutes of AM radio quality audio into around 1 MB.
- If anyone finds any bugs in this software please let me know and include
-patches to fix them.
-
-Share and enjoy,
-Joel...