aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3lint
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-08-20 13:48:23 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-08-20 13:48:23 +0000
commit11cbcdc5678841c8835e9e3b625d6b39fc05a5c7 (patch)
tree11503f626721274f9a832343c80fd44937218812 /audio/mp3lint
parent782f0099c5ca5daaa2099d28d16084efd36a07b4 (diff)
downloadports-11cbcdc5678841c8835e9e3b625d6b39fc05a5c7.tar.gz
ports-11cbcdc5678841c8835e9e3b625d6b39fc05a5c7.zip
Notes
Diffstat (limited to 'audio/mp3lint')
-rw-r--r--audio/mp3lint/Makefile30
-rw-r--r--audio/mp3lint/distinfo3
-rw-r--r--audio/mp3lint/pkg-descr9
-rw-r--r--audio/mp3lint/pkg-plist24
4 files changed, 66 insertions, 0 deletions
diff --git a/audio/mp3lint/Makefile b/audio/mp3lint/Makefile
new file mode 100644
index 000000000000..8c29f73d4897
--- /dev/null
+++ b/audio/mp3lint/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mp3lint
+# Date created: 2010-07-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3lint
+PORTVERSION= 0.9
+CATEGORIES= audio perl5
+MASTER_SITES= http://erislabs.net/ianb/projects/${PORTNAME}/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A configurable tool to check collections of audio files
+
+BUILD_DEPENDS= ${SITE_PERL}/MP3/Archive.pm:${PORTSDIR}/audio/libmp3-archive-perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= mp3lintsum.1 mp3lintskip.1 mp3lint.1
+MAN3= mp3lint-tools.3
+MAN5= mp3lintrc.5
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^DESTINSTALLSYSCONFDIR/ s|DESTDIR|PREFIX|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/audio/mp3lint/distinfo b/audio/mp3lint/distinfo
new file mode 100644
index 000000000000..0285b6e86b29
--- /dev/null
+++ b/audio/mp3lint/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3lint-0.9.tar.gz) = 64d13fa98cbf90c330a772f11c41056d
+SHA256 (mp3lint-0.9.tar.gz) = 79a77a6702c76985d2d8d8b64b70657749d76cb6e1ac8e36ec0557adbdba351d
+SIZE (mp3lint-0.9.tar.gz) = 51722
diff --git a/audio/mp3lint/pkg-descr b/audio/mp3lint/pkg-descr
new file mode 100644
index 000000000000..652892a3b0ad
--- /dev/null
+++ b/audio/mp3lint/pkg-descr
@@ -0,0 +1,9 @@
+mp3lint is a tool to check collections of audio files for various problems. It
+is highly configurable, allowing you to specify your preferred format for
+filenames, minimum bitrate, tests to ignore, etc.
+
+Formats checked are currently mp3, ogg, wav, flac, au, and m3u playlists.
+mp3lint is implemented as separate tools (perl modules), each of which
+implements a set of tests. There are a total of 32 different tests.
+
+WWW: http://erislabs.net/ianb/projects/mp3lint/
diff --git a/audio/mp3lint/pkg-plist b/audio/mp3lint/pkg-plist
new file mode 100644
index 000000000000..135a6e998d52
--- /dev/null
+++ b/audio/mp3lint/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+bin/mp3lint
+bin/mp3lintsum
+bin/mp3lintskip
+etc/mp3lintrc
+%%SITE_PERL%%/MP3/Archive/Lint.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Conf.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Skip.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tool.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Au.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Dir.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Filename.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Filesys.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Flac.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Id3.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/M3u.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Mp3check.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Mp3info.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Ogg.pm
+%%SITE_PERL%%/MP3/Archive/Lint/Tools/Wav.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/mp3lint/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/mp3lint
+@dirrmtry %%SITE_PERL%%/MP3/Archive/Lint/Tools
+@dirrmtry %%SITE_PERL%%/MP3/Archive/Lint