aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3splt/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-11-27 02:08:54 +0000
committerWen Heping <wen@FreeBSD.org>2009-11-27 02:08:54 +0000
commit299e1e5c613d60c9f1e9eec0ff6d24c026b8b918 (patch)
tree5bfac45ba1463d08d8c9dfc0393397c2992fe39e /audio/mp3splt/Makefile
parent9367deaf270c3ba25e4e236430cbf6d3a95d54b9 (diff)
downloadports-299e1e5c613d60c9f1e9eec0ff6d24c026b8b918.tar.gz
ports-299e1e5c613d60c9f1e9eec0ff6d24c026b8b918.zip
Notes
Diffstat (limited to 'audio/mp3splt/Makefile')
-rw-r--r--audio/mp3splt/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 5b47a2e02acf..e697eb89ad84 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mp3splt
-PORTVERSION= 2.2.3
-PORTREVISION= 1
+PORTVERSION= 2.2.6a
CATEGORIES= audio
MASTER_SITES= SF
@@ -20,11 +19,22 @@ USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_ARGS+=--enable-oggsplt_symlink --disable-mp3splttest
-MAN1= mp3splt.1
+OPTIONS= NLS "Native language support" on
+
+MAN1= oggsplt.1 mp3splt.1
PLIST_FILES= bin/mp3splt bin/oggsplt
post-install:
- @${LN} -fsv ${PREFIX}/bin/mp3splt ${PREFIX}/bin/oggsplt
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+.else
+USE_GETTEXT= yes
+LANGUAGES= de fr
+.for language in ${LANGUAGES}
+PLIST_FILES+= share/locale/${language}/LC_MESSAGES/mp3splt.mo
+.endfor
+.endif
.include <bsd.port.mk>